Jump to content

Recommended Posts

When using a guitar plug-in and echo -on, there is a very short delay, almost imperceptible, but there.

Easiest to hear when I can hear the  guitar acoustically and the plug-in sound at an even level.

Where or what would be the first place to look to correct this?

 

thanks!

Share this post


Link to post
Share on other sites

 

The first place to look is the audio IF. Are you using asio and is your asio buffer as small as possible while still being stable? I normally run at 96 samples, but if I shutdown the lan 64 is stable. Roundtrip latency in CbB is reporting 9.8 msec at 96 samples. Some plugins have more latency than others - linear phase can be pretty bad. Start with no plugins and tune your system and see if it's ok. Then add plugins one by one and see if one is particularly bad. People have different ideas about how much latency is acceptable.

Share this post


Link to post
Share on other sites

Yes, audio interface buffers and plug-in delay compensation are the two largest contributors. Fortunately, these are things the user has control over.

Except for WASAPI shared which is fixed by the OS, the audio interface buffers are set in preferences or, in some cases, software provided by the interface manufacturer. For 44.1/48K sample rates most find 128 is the largest usable buffer size although some can work with 256.

Plug-in delay compensation is determined by the plug-ins on the track/bus requiring the largest buffer setting.

If the track with the largest PDC requirement is not the track being recorded, bypassing the effects will reduce the PDC. Since the track being monitored requires FX, the global FX bypass in the Mix Module cannot be used but, individual FX rack/PC module bypass is available. Also PDC may be overridden on the live track using the PDC button in the Mix Module.

Share this post


Link to post
Share on other sites

Thanks guys. It is ASIO (Goliath interface). I decreased the buffer in Cakewalk Driver settings to fastest. I will see if that helped. The roundtrip is 3.9 ms   170 samples.

Clicking the ASIO Panel states: Safe mode engaged (which makes a big difference in output latency).  Thanks

Share this post


Link to post
Share on other sites

If the buffer is too small you may get clicks and pops. So you may need to make the buffer a little larger depending on whether or not you've optimized your computer for audio performance. Good luck.

Share this post


Link to post
Share on other sites

Thanks rsinger. I'll be watchful.

Jim, No I was not using headphones.  I have wondered about the zero latency for Goliath, as it is printed on their hardware. So it is when monitoring via headphones (good to know)?

I think I'm good now: just sliding the buffer all the way to fast worked (from  RT 23.3 ms to 3.9 ms).

Share this post


Link to post
Share on other sites
9 hours ago, Kawika said:

Jim, No I was not using headphones.  I have wondered about the zero latency for Goliath, as it is printed on their hardware. So it is when monitoring via headphones (good to know)?

I think I'm good now: just sliding the buffer all the way to fast worked (from  RT 23.3 ms to 3.9 ms).

Zero latency is also called direct monitoring - you hear the input to the audio interface, not the output from the DAW so you wouldn't hear any plugins. Glad that worked.

  • Thanks 1

Share this post


Link to post
Share on other sites

I may be getting greedy, as there are no issues, currently, but I was wondering :

 

I have 2 buffers chosen in "buffers in playback Que".....and after clicking ASIO Panel I noticed I am in the "safe" mode. Should I keep both as is?

Share this post


Link to post
Share on other sites
Posted (edited)

I don't know the answer to that. I have 2 buffers chosen in "buffers in playback Que". The various asio drivers I have don't seem to have a safe mode option.

If you want to get greedy you can use higher sample rates. The higher the sampling rate the more samples there are per second so the same number of samples are smaller units of time. Depending on your current sampling rate you could try going up to 96k hz or 192k hz. 

Edited by rsinger

Share this post


Link to post
Share on other sites

Hi, Back on a quest for least latency. On my antelope Goliath there is a choice between USB and Oven. I don't know if this is relevant to latency, but I noticed with Sonar I was able to use "Oven". With BL it kicks back to USB (and then back to "oven when I'm out of Cakewalk (on youtube for example). Does anybody know what "oven " means in this context?

 

thanks,

 

Kawika

Share this post


Link to post
Share on other sites
Posted (edited)
13 hours ago, Kawika said:

On my antelope Goliath there is a choice between USB and Oven. I don't know if this is relevant to latency, but I noticed with Sonar I was able to use "Oven". With BL it kicks back to USB (and then back to "oven when I'm out of Cakewalk (on youtube for example). Does anybody know what "oven " means in this context?

I have an Orion 32+ and I asked Antelope support about this a couple years ago. I forget the technical reason they gave for the difference in the display but the bottom line was to just ignore it. When the clock display shows "USB" it is still using the internal (Oven) clock. In addition, the clock source will have no effect on latency.

For lower round trip latency, get a thunderbolt card. With USB the lowest I can set the buffer is 128 and that is with small projects. With thunderbolt I can set the buffer at 64 and still run a fairly large project. For me that is all just experimental. My front end is all analog so I don't care about latency. I leave the buffer at 512 and run all the channels and FX that I want.

 However, round trip latency should have no bearing on the latency of the hardware FX in your Goliath.

On 6/16/2021 at 11:30 PM, Kawika said:

When using a guitar plug-in and echo -on, there is a very short delay, almost imperceptible, but there.

Easiest to hear when I can hear the  guitar acoustically and the plug-in sound at an even level.

My interface does not have the guitar FX that the Goliath has but it does have some fantastic sounding EQ's and Compressors. So if I run a Bass through a channel on the Orion with comp and EQ and then blend it with the direct signal in my analog mixer there is a very small delay. This just the nature of digital audio. The higher the sample rate is the less noticeable the delay will be.

 

Edited by Base 57

Share this post


Link to post
Share on other sites

I never monitor off any onboard effect when I do an audio take. All of my guitar effects are before the input and that is where I monitor. If your machine is kind of old as mine is, this is one possible approach. The negative is that the effect is baked in and can't be taken out.

On the other hand you could monitor the effect & record a dry out then put the effects in later.

I realize this is kind of a low tech solution but it works for me.

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, rfssongs said:

Yea, I have done  a lot of the following: "you could monitor the effect & record a dry out then put the effects in later." And, trying to get away from that. I do have Thunderbolt, so I will try that. I know they, Antelope, were working the bugs out of the TB-software for the initial Goliath.   So TB makes a big difference?  Oh and thanks for the "oven" info; appreciate it.

I think the key, the exact question (for Antelope) is stated in the Cakewalk help module when you hover over the input echo "Many audio interfaces have an option to do this (input monitoring) automatically at the hardware level."

 

thanks!

Quote

 

 

Edited by Kawika

Share this post


Link to post
Share on other sites

If you find that temporarily bypassing all effects makes a noticable difference with latency, that means that one or more of the effects loaded into the project, are introducing enough latency to produce noticable lag between playing a note and hearing it. (the FX button on the right of the Transport Module, acts like a toggle, to have all effects either engaged or bypassed).

There are some types of effects that are meant for mixing, rather than use in tracking/recording.  Linear-Phase effects, which were noted in an earlier post above, and also convolution reverb effects are both notorious for this.

A couple of quick and dirty workarounds are to either: Bypass the effects until done with recording and moving on to mixing, or temporarily swap out the effect(s) that need larger buffer sizes to process properly (convolution reverb and linear-phase types), with less resource hungry equivalent effects (different reverb plugin or non linear phase effect), until done with tracking, and then swap the other effects back in, where you can mix with a giant ASIO Buffer Size without needing to worry about the lag in playback, because you are no longer trying to play notes when the lag is present.

I hope the above makes sense, and that it helps. 

Bob Bone

  • Like 1

Share this post


Link to post
Share on other sites

^^^ Well said, Bob.

Input/Output buffering isn't the only source of latency. Some plugins necessarily introduce large latencies due to the way they work, and should be applied only after tracking is complete. If you need to add another track late in the mix process, that's the main reason the Global Bypass feature is there.

Btw, the reference to "oven" comes from having interface clock circuits literally placed into a warm box to prevent the oscillator from varying due to heat changes. This makes the clock frequency very stable, and is the reason internal clocks outperform even very sophisticated external clocks.

 

  • Like 1

Share this post


Link to post
Share on other sites

Thanks guys, but I'm not mid-project and therefore have the luxury of experimenting with min variables: Just one track with  a midi instrument or one track with guitar plug i.e., S-gear.

How do I monitor via the interface thus not engaging the input echo as stated in the Cakewalk help module when you hover over the input echo "Many audio interfaces have an option to do this (input monitoring) automatically at the hardware level" ?

 

thanks!

Share this post


Link to post
Share on other sites
1 hour ago, Kawika said:

How do I monitor via the interface thus not engaging the input echo as stated in the Cakewalk help module when you hover over the input echo "Many audio interfaces have an option to do this (input monitoring) automatically at the hardware level" ?

This is done in the Goliath's Control Panel. Use it's routing matrix to route your guitar input to one of the FX and then to one of the mixers.

Share this post


Link to post
Share on other sites

Hey   B57,

Route to one of the FX?....Even though I'm not using an Antelope Effect?

thanks,

 

Kawika

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...