Jump to content
Alvaro Diez

Extremely long mixing times

Recommended Posts

Dear all, 

Any of you may have the same problem: once updated to the last Cakewalk version available, mixing times are taking too long (i.e.: 3 minutes song, with 5 midi-tracks and 1 audio-track is taking more than 24 hours to complete the audio mix)

Is anybody having the same trouble? Does anybody how to fix this? 

Regards, 

Álvaro

  • Sad 1

Share this post


Link to post
Share on other sites

Are you talking about rendering the mix to an audio file?  Sounds like something is being a bottle neck. Maybe try disabling a synth at a time to see if one of them is what is making it take so long.  Another option, create a new project and move the midi and audio tracks over and try rendering in the new project.

Share this post


Link to post
Share on other sites
8 hours ago, RobertWS said:

That sounds like a wetware issue, not software.

 

I wish I could do the mix with my wetware but I'm afraid that I need the software

  • Haha 1

Share this post


Link to post
Share on other sites
2 hours ago, reginaldStjohn said:

Are you talking about rendering the mix to an audio file?  Sounds like something is being a bottle neck. Maybe try disabling a synth at a time to see if one of them is what is making it take so long.  Another option, create a new project and move the midi and audio tracks over and try rendering in the new project.

Yes, I talking about rendering the mix to an audio file... Wave format (also tried with MP3), full mix, enabling and disabling all possible combinations of plugins, effects, etc...

It also happens with simple two audio tracks projects, raw tracks, with no effects on... 

Share this post


Link to post
Share on other sites

Creating mp3 files will take longer than wav files but a 3 minute project with 5 or so tracks tracks should take seconds to render. With fast bounce disabled and audible bounce enabled it should create the export in 3 minutes.

Is is possible the real length of the project is much more that 3 minutes?  IOW, some data far to the right on the timeline causing the export to create a very large file.

Select All tracks and look at the selection time in the export module.

  • Like 1

Share this post


Link to post
Share on other sites

Obviously nobody else experiences this.  Even huge complicated projects only should take a minute to export on a modern computer.

On the rare time I've seen this issue it was either a weird plug in, ( you tested this )  or as scook has pointed out a song with no end,  or your computer is bunged up because the hard drive you are writing to is either full or faulty.   

Share this post


Link to post
Share on other sites

Ahhh, when you said:  "mixing times are taking too long (i.e.: 3 minutes song, with 5 midi-tracks and 1 audio-track is taking more than 24 hours to complete the audio mix)"

It is interpreted to mean balancing the volumes, effects, pans, etc.   So you really meant Rendering or Exporting.

Do you have any antivirus software that may be aggressively checking every byte that gets written to the disk?

Are you exporting to an external device?   Are there any other processes running?

Share this post


Link to post
Share on other sites
21 hours ago, Alvaro Diez said:

Dear all, 

Any of you may have the same problem: once updated to the last Cakewalk version available, mixing times are taking too long (i.e.: 3 minutes song, with 5 midi-tracks and 1 audio-track is taking more than 24 hours to complete the audio mix)

Is anybody having the same trouble? Does anybody how to fix this? 

Regards, 

Álvaro

24 HOURS? Is that a typo? Did you mean to type 24 "minutes"? Well no matter, my alarm bells would start chiming after 1 minute. When and or If Ever was the last time you ran computer tune up maintenance app? Like registry cleaner? Driver updater? Defrag? Upgrade to Windows 10 yet? Physically blow the dust out?

Freezing MIDI synths before "exporting" the tracks to audio GREATLY reduces the computer's processing workload, which greatly reduces CbB's export times. As does freezing audio tracks with lots of Audio FX running. It is quite possible that you are overwhelming your computer's CPU, and resources. The harder the CPU has to work, the HOTTER it gets, and the hotter it gets the SLOWER it gets due to cooling process known as "Thermal Throttling". However that should only slow your export/rendering times by minutes, never hours.

Kind of sounds to me like you may just have a serious hard drive problem? Mechanical failure? Maybe it's just too full of old stuff scattered all over the place and can't find enough space for writing new stuff, and so maybe the problem is simply due to lack of free space and fragmentation?

Share this post


Link to post
Share on other sites

This is unlikely to have anything to do with updating. Have you checked what the duration of the project you are uploading is?
The exported region is shown in the dialog title bar. Sometimes projects have an automation node or event far in the future causing it to try and render a very long file.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks all for your comments. 

I think that I have identified the problem and some kind of work-arround to solve it.

I'd try to explain while answering your comments back: 

10 hours ago, Steev said:

24 HOURS? Is that a typo? Did you mean to type 24 "minutes"? Well no matter, my alarm bells would start chiming after 1 minute. When and or If Ever was the last time you ran computer tune up maintenance app? Like registry cleaner? Driver updater? Defrag? Upgrade to Windows 10 yet? Physically blow the dust out?

1) No, it is not a typo. Actually, to make a test, I let cakewalk rendering the mix of "what I supposed to be a 3 minutes length" to a wav file at Monday, 22.00 and next day by 20.00 it haven't ended yet...

10 hours ago, Noel Borthwick said:

This is unlikely to have anything to do with updating. Have you checked what the duration of the project you are uploading is?

 2) Then, I wrote to support@cakewalk.com telling about my issue and quite quickly they asnwered back (lit): "Thanks for reaching out. So sorry for the trouble. We are in the midst of investigating all the bugs reported so far with the new update and working to release a new hotfix for it soon. For now, please revert back to version 2021.01 by running the rollback installer". And so I did: rolled back the update, but the problem wasn't solved

On 5/10/2021 at 11:50 PM, scook said:

Select All tracks and look at the selection time in the export module.

3) Finally, as both Noel and scool said, I made the Export Module visible in the modules bar (I use to work on a Surface so I usually have most of the modules hidden due to lack of space in my screen) and, surprise: what was supposed to be a 3 minutes length project, actually is 08:26:41:14!!!!!!!

So, easy way to have the project's mix rendered to a file is just selecting the section that you want to export and voilá!, mix is renderd in less than half a minute.

Now, my question is: I've been using cakewalk for almost 20 years... (since it was named Cakewalk Pro Audio v6, before SONAR1...) and I can't remember a single time I've had to worry about selecting the length of the project before rendering it (as usually happens with other DAWs such as ProTools or Logic) so why is it now happening that Cakewalk is extending the project duration so much?

10 hours ago, Noel Borthwick said:

Sometimes projects have an automation node or event far in the future causing it to try and render a very long file.

I haven't been able to find out any event by the end of the last recorded data...

Hope this helps.

Thanks again for you comments.

Regards, 

Á

Share this post


Link to post
Share on other sites

@Alvaro Diez Cakewalk is not extending the project duration. Some event such as a tempo event or an envelope node got added (likely a bug) as a result of some operation. If you send your cwp file we can tell you what the issue is and how to fix it. 

Share this post


Link to post
Share on other sites

The most common way this happens is if you import in a WAV file that has a timestamp embedded, and you have Always Import Broadcast Waves at Their Timestamp checked in preferences. It's not uncommon to load in some sound effect or whatever that gets dumped on your timeline an hour along, and even if you delete it, there's a good chance there may be a rogue envelope node still left behind where the clip used to be. That'd certainly catch a lot of people out.

  • Like 1

Share this post


Link to post
Share on other sites

I have a habit of adding markers Start and End to every project, then select everything between them for export. Then again, I always also export from my Master bus, and don't use the other options ("What you hear" etc.). Maybe it requires a few clicks more, but the export is always what I want it to be, at least in regards to what portion of the project to export.

Now, if CbB only remembered the export settings for a project better, I'd be a happy camper... 😁

Share this post


Link to post
Share on other sites

@Alvaro Diez - this was indeed a bug in the tempo track. It was adding a tempo node at the uncropped end of the project, rather than at the cropped end.

The official 2021.04 Update 1 release (soon to be released) will fix that.  Tempo nodes will no longer be added at the end of the project.

  • Like 2

Share this post


Link to post
Share on other sites

j/k: Cakewalk could at least throw a warning dialog if the project length to be rendered is greater than a week. I must wonder, if Alvaro had let it finish, how long it would have taken and what the file size would have been.

  • Like 1

Share this post


Link to post
Share on other sites

Thats not far fetched. We should throw a warning to confirm if export length exceeds some reasonable size.

  • Like 3
  • Great Idea 2

Share this post


Link to post
Share on other sites

It might be better to check if there are automation nodes, events or such, well past the last audible stuff (midi/audio clips) in the project, which would cause the export be longer than the user might expect if he/she just selects all and fires away with exporting.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Myself if I start an export of a 3 min song and the progress bar isn’t trotting along at the expected speed I stop the process and investigate what’s wrong. 
I know that’s not much help but it has happened many times to me that a 3 min song has extra info past the end and yep 99% of the time it is due to a volume envelope. 
A big huge marker that says “ End” would be a nice feature. 

Edited by John Vere

Share this post


Link to post
Share on other sites

"Select: all" quickly highlights everything and will quickly show you at a glance if there is anything beyond the presumed end of your project.

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...