Jump to content
Philip G Hunt

Latest release of CbB choking system

Recommended Posts

8 minutes ago, Philip G Hunt said:

The fact that most people haven't experienced this does not negate the fact that it is happening.

No, but it does rule out that it's independent of the environment in which it's running, and the project content (i.e. Spitfire synths).

41 minutes ago, Philip G Hunt said:

Rolling back fixed most performance problems.

Hmmm... that's quite different from "The worst thing about this is that even after rolling back, I'm still having issues with drop outs on Spitfire's OPW... now all of a sudden it's killing my projects. and  "I'm getting serious choking even after rolling back."

If rollback did in fact resolve the issues, and they are all related to Spitfire then you should report that in the 21.04 Feedback thread. I reported an issue with Izotope Iris 2 during EA that turned out to be related to the large number of automatable parameters it exposes interacting badly with the new automation code. But that was fixed, and was only noticable on my system at very low buffer settings of 32 samples. Even then, it wasn't causing 'serious choking', just crackles and pops showing up sooner than expected.

In any case, it sounds like something about Spitfire synths, specifically, is also causing an issue with that new code in which case the Bakers will need to look into it. It will help if you report the symptoms and conditions in detail.

Share this post


Link to post
Share on other sites
7 hours ago, David Baay said:

No, but it does rule out that it's independent of the environment in which it's running, and the project content (i.e. Spitfire synths).

Hmmm... that's quite different from "The worst thing about this is that even after rolling back, I'm still having issues with drop outs on Spitfire's OPW... now all of a sudden it's killing my projects. and  "I'm getting serious choking even after rolling back."

If rollback did in fact resolve the issues, and they are all related to Spitfire then you should report that in the 21.04 Feedback thread.

 

I've already reposted my original post here in the feedback thread, about a week ago (at Noel's request). I've also shared my projects with the team to find the issue. 

As to rolling back, yes, it seems to have resolved 'most' issues... meaning, I can now get some work done. But the performance is not as good or stable as it was before.

All this was reported in the feedback page.

Share this post


Link to post
Share on other sites

I got a crash with Spitfire BBC Orchestra. The resulting minidump called out the plug-in. It's been forwarded to the bakerz.

  • Confused 1

Share this post


Link to post
Share on other sites
42 minutes ago, Starship Krupa said:

I got a crash with Spitfire BBC Orchestra. The resulting minidump called out the plug-in. It's been forwarded to the bakerz.

Have you tried multiple instances of BBCO or other Spitfire instruments??

Are you able to load more than three with stable performance?

If you've got any AAS programs, are you able to load multiple instances of these?

Thanks

Share this post


Link to post
Share on other sites

Don't use many sampled based synths. No Spitfire stuff installed.

Here is CbB 2021.04 build 147

running three instances of VST2 AAS Lounge Lizard v4.3.1 (I have not updated AAS in a while)

on Win10 20H2 build 19042.964

 

mlMTapV.gif

 

Share this post


Link to post
Share on other sites
14 minutes ago, scook said:

...running three instances of VST2 AAS Lounge Lizard v4.3.1 (I have not updated AAS in a while)

This is interesting - AAS had an update recently of all plugins - I wonder if this could be an issue.

Share this post


Link to post
Share on other sites

It's a possibility

Take a look at

 

Share this post


Link to post
Share on other sites
1 hour ago, Philip G Hunt said:

This is interesting - AAS had an update recently of all plugins - I wonder if this could be an issue.

Hi Philip, I am in the final stages of finishing a new song. I have to mix and master (not my strong suit) the whole shebang. I am a bit afraid to roll back the update until I am finished. I have been very fortunate, lately. I have several radio stations that play my music every day, one being WBXO Radio in New York who also stream. In the past year they have aired 8 of my songs. I am working on number 9. My computer is old and has died on me many times, but when it is stable, it is a thing of beauty. 

This Spitfire issue is crushing me right now, but I am working around it by freezing synths. I have also noticed a couple of very strange new issues. The cursor doesn’t always go where it is supposed to go and I have been having the strangest doubling of midi notes in my 2 Spitfire tracks. I sometimes use the CAL function Undupe (I think that’s the name) and it helps most of the time. That’s annoying, but several times it reappears like bad magic.

Besides the Cakewalk update I did one wrong thing. I updated AAS Swatches. Bad on my part, it requires Win 10. I’m still using 7. I have to see about rolling that back. I see someone mentioned they had an issue with something from AAS. We’ll get to the bottom of this. I also need a new, powerful computer.

  • Sad 1

Share this post


Link to post
Share on other sites
Posted (edited)
10 minutes ago, Michael Richards said:

Besides the Cakewalk update I did one wrong thing. I updated AAS Swatches. Bad on my part, it requires Win 10. I’m still using 7. I have to see about rolling that back. I see someone mentioned they had an issue with something from AAS. We’ll get to the bottom of this. I also need a new, powerful computer.

I'm performing a culling of AAS instruments as we speak - I'll be reinstalling the older versions as soon as I finish my Zoom meetings today.

Yes, you're right - on Win 7, you probably shouldn't update AAS or CbB anymore. 

I'll let you know how it goes.

BTW: Congrats on the airplay. :D

Edited by Philip G Hunt

Share this post


Link to post
Share on other sites

@Philip G Hunt I haven't tried multiple instances of BBCO, but I am a regular user of A|A|S player. A tip about Chromophone and other A|A|S patches: some of them have humongous long releases and effect tails, which results in voices piling up big time. In Player, I limit my voice count to 8 rather than the default 12, which has no audible effect (the tails and releases are stepping on each other anyway).

@Michael Richards, congrats on the airplay indeed! Can you link to a Soundcloud or Bandcamp so we can check out what the New Yorkers have been grooving to?

Share this post


Link to post
Share on other sites

As for the issue where CbB is still ganked even after rolling back, the only thing that comes to mind is that the new version is overwriting the .INI files, and the rollback isn't restoring them.

I suggest that anyone with these issues tweak their .INI file(s) per the instructions in this thread, then back them up before doing any further installs or reinstalls.

I've already turned my decimation up to 15mS, because, um, I'm not sure what it does, so I guess I can sacrifice some of it for performance' sake. 🤔

Share this post


Link to post
Share on other sites
5 hours ago, Starship Krupa said:

As for the issue where CbB is still ganked even after rolling back, the only thing that comes to mind is that the new version is overwriting the .INI files, and the rollback isn't restoring them.

I suggest that anyone with these issues tweak their .INI file(s) per the instructions in this thread, then back them up before doing any further installs or reinstalls.

I've already turned my decimation up to 15mS, because, um, I'm not sure what it does, so I guess I can sacrifice some of it for performance' sake. 🤔

I suspected the same thing as you. I wonder what else may have been changed in the .INI files. I wish I had taken note of the previous parameters before updating so as to compare.

I've now clean installed a much earlier build from 2020 and it it's performing better. They was an issue with the latest AAS VSTs not working as should with CbB. I have rolled then back to the previous install. 

Now, I've just got to figure out why Spitfire plugins are causing drop outs. I've tried a repair, but I might have to do a reinstall. 😢

  • Like 1

Share this post


Link to post
Share on other sites
On 5/6/2021 at 2:59 PM, Starship Krupa said:

@Michael Richards, congrats on the airplay indeed! Can you link to a Soundcloud or Bandcamp so we can check out what the New Yorkers have been grooving to?

Starship Krupa, thank you for asking. Here is the SoundCloud link: https://soundcloud.app.goo.gl/MkPz8Jnc9GLkBbv78

We also have a Christmas album that is streamed on YouTube, Amazon, Spotify, etc., under The Road Home for Christmas by the Curtin Richards Project. Here is the YouTube link: https://youtube.com/playlist?list=OLAK5uy_mJUq1Zptd48txKYuuGrXRLK7I1PbVqZvg

 

  • Like 1

Share this post


Link to post
Share on other sites
On 5/6/2021 at 4:32 PM, Michael Richards said:

This Spitfire issue is crushing me right now, but I am working around it by freezing synths. I have also noticed a couple of very strange new issues. The cursor doesn’t always go where it is supposed to go and I have been having the strangest doubling of midi notes in my 2 Spitfire tracks. I sometimes use the CAL function Undupe (I think that’s the name) and it helps most of the time. That’s annoying, but several times it reappears like bad magic.

 

Michael, I have some good news for you.

I got on to Spitfire and they confirmed that there is an issue with their VST3 versions of Spitfire instruments in CbB. I double checked the Preferences in the new build and saw that the VST3 migration is set by default to Replace VST2 instruments with VST3. You need to uncheck that box and then go back into your session and replace your Spitfire instruments with the VST2 versions (if they have been replaced with VST3).

I'm including a screen grab of where you will find this setting in CbB

image.thumb.png.61c40eb92e5b7ec133b6157a82e73bf6.png

Spitfire support suggested another work around if this doesn't work for you. 

"Please try deleting the VST3 plugin files altogether. That way, Cakewalk will only have the VST2s to load after it rescans. 

As you have been advised, the default location for the VST3 version is here: 

VST3: C:\Program Files\Common Files\VST3

Cakewalk should rescan the next time it's restarted and will then load only the VST2 going forward. Please note, if you perform a repair in the meantime, the VST3 plug-in will be reinstalled as part of the repair and you will need to remove this again."

 

I hope this remedies your problem and you can get back to making music as before. ;)

  • Like 2

Share this post


Link to post
Share on other sites
On 5/11/2021 at 12:04 PM, Philip G Hunt said:

Michael, I have some good news for you.

I got on to Spitfire and they confirmed that there is an issue with their VST3 versions of Spitfire instruments in CbB. I double checked the Preferences in the new build and saw that the VST3 migration is set by default to Replace VST2 instruments with VST3. You need to uncheck that box and then go back into your session and replace your Spitfire instruments with the VST2 versions (if they have been replaced with VST3).

I'm including a screen grab of where you will find this setting in CbB

image.thumb.png.61c40eb92e5b7ec133b6157a82e73bf6.png

Spitfire support suggested another work around if this doesn't work for you. 

"Please try deleting the VST3 plugin files altogether. That way, Cakewalk will only have the VST2s to load after it rescans. 

As you have been advised, the default location for the VST3 version is here: 

VST3: C:\Program Files\Common Files\VST3

Cakewalk should rescan the next time it's restarted and will then load only the VST2 going forward. Please note, if you perform a repair in the meantime, the VST3 plug-in will be reinstalled as part of the repair and you will need to remove this again."

 

I hope this remedies your problem and you can get back to making music as before. ;)

Philip, thank you. I know that I only loaded Spitfire as vst3 plug-ins. When I get a chance I am going to create a new file and load multiple Spitfire plug-ins and see where the problem occurs. On my recent song, it happened with the 3rd plug-in. 
Is Cakewalk going to fix this since it is a confirmed bug?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...