Jump to content

Recommended Posts

Posted (edited)

Hi, 

Long time Sonar user. Thanks very much for taking the torch and carrying this great platform forward. 

Since installing and using Cakewalk by Bandlab, when ever I export a project, the resulting 44.1 or 48k wav or mp3 files are clipping and distorted on louder parts or even all the way through a song if the content is pretty loud. Everything sounds and looks fine while mixing and monitoring, no peaking or even near peaking levels. I've never had this problem with Sonar producer or platinum versions. 

I try using export profiles that I've saved and used over and over, or default profiles but that doesn't help.

"What You Hear" profile has the same issues. 

If I choose to export busses, it will export each bus into separate files. 
If I mute the FX bus, and export just the master, the level is lower (noticeably lower than it should be) and there is no clipping but there is no reverb fx either.
If I choose just the master it's fine, (lower but no clipping, and of not F/X reverb on the vocals....)
I have my FX bus sending its output to my master so I should be able to export just the master buss and have a good mix with reverb, Right?

I've read online that deleting the aud.ini file so cakewalk will rebuild it will fix this sort of problem but that had no effect either. 

Did Cakewalk change the way things are exported when they took over Sonar?

I have to get a mix out for a music video this weekend on Saturday!


Please help!


Bruce Searl

 

Edited by Bruce Searl

Share this post


Link to post
Share on other sites

Well there is a new way to Export and I personally like it a lot because finally!! It remembers by preference for 16 bit for CD's. The old dialog always defaulted to 32 bit. 

 Go to the "Export"  dialog box. It's new from an update a few months ago. If you don't see it look in your Modules / Control bar and make sure and check it. 

Choose "Presets" then "Master Mix" 

Set your Sample and Bit Depth and save. 

This will export your master buss 100% the way your seeing and hearing it. 

Just a little tip.. I always put the BT Brickwall limiter on my Master buss set at -04 db I have exported over 100 songs this way and all are perfect. ( the audio quality, not the playing)   When checked in Wave Lab none will show as having any overs. 

Always mute your master buss with a song playing to check if any tracks or busses are not directed there. 

Share this post


Link to post
Share on other sites
Posted (edited)

Hi Cactus, thanks for the help.

I've tried your suggestion, exporting from the export button rather then file/export and using the Master Mix Preset, and I have the Boost11 Plugin on my master buss, with the output set to -.04db  The reduction that boost11 is saying it's doing is only -1.4db so it's not exactly having to slam the lid down on things.

I've also lowered the boost value on the input side of Boost11 to 5.4db (from 6db before).

It has helped but the problem still persists the same as using what appears to be the same presets as before, but without the options checkboxes. 

The resulting file seems to always be about 3db hotter than my normal mix. playback level.

I have my master fader set to -3.0db and it just occasionally goes into the red, but down about -4db from peaking on the meter. It never peaks for me while paying in the DAW, not even close, or any other channel. There is only a vocal track, a stereo piano track, and the reverb buss so there is not a lot of hidden sources to hide some peaking signal in. 😉 It really just like I've always done it with out any problems. 
I also mute the master and there are no other channels playing that are still heard or getting through. 

There is zero distortion when playing back in the DAW... only when I export to the mixdown file. wav or mp3 both reflect the problem and it's louder than my DAW play back. Its like the changed I make don't change anything. 

Got any other ideas?

Thanks!

Bruce Searl

Edited by Bruce Searl

Share this post


Link to post
Share on other sites
Posted (edited)

I had an issue once where I set up a monitor mix going to different hardware outs on my interface. My main mix went to outputs 1/2 and I set up a headphone mix going to 3/4. All fairly basic.

What I found was the on this particular project, so long as the 3/4 outs were assigned tracks, muted or not, and despite having 1/2 as the only thing I was apparently exporting from, it would clip the export. I had to delete the headphone buss / 3/4 entirely to get it to export correctly.

This isn't a regular thing - I've happily exported from a master bus with the headphone mix muted and it's worked as expected but this project was odd.

Are you running everything to a single master buss and that going to a single hardware out?

If not, see if you can track down whatever is not going there and either delete the out or reassign it to your master / 1/2 output.

I can't think of any other reason other than something is running after your limiter (eg: a Pro Channel module set to Post FX) that would cause this kind of issue.

Edited by Lord Tim

Share this post


Link to post
Share on other sites
12 hours ago, Bruce Searl said:

Since installing and using Cakewalk by Bandlab, when ever I export a project, the resulting 44.1 or 48k wav or mp3 files are clipping and distorted on louder parts or even all the way through a song if the content is pretty loud. Everything sounds and looks fine while mixing and monitoring, no peaking or even near peaking levels. I've never had this problem with Sonar producer or platinum versions. 

Check to make sure your tracks go the the master bus, All buses go to the master bus and that the Master Bus goes to the Main Outs 1/2.

 

6 hours ago, Bruce Searl said:

porting from the export button rather then file/export and using the Master Mix Preset, and I have the Boost11 Plugin on my master buss, with the output set to -.04db  The reduction that boost11 is saying it's doing is only -1.4db so it's not exactly having to slam the lid down on things.

Do not use presets. Set it yourself. The person who made that preset did not have your song in mind.

Also, ware are you playing it back in?

Share this post


Link to post
Share on other sites
1 hour ago, CJ Jacobson said:

Check to make sure your tracks go the the master bus, All buses go to the master bus and that the Master Bus goes to the Main Outs 1/2.

 

Yes. The most common mistake is exporting a project where something is routed to multiple hardware outputs. If you have a hardware out muted externally outside of the DAW's mixer the project will sound fine when playing but when you export it will clip.

To troubleshoot solo your master bus in CbB and play. Does it sound correct? If so export with source category buses and choose ONLY that bus.

  • Like 2

Share this post


Link to post
Share on other sites
Posted (edited)

Hey All! Thanks for the help. I was out shooting the video yesterday and so I just got back to this to try to figure out my audio problem so I can start editing the thing together. 

CJ Jacobson - I playing either form the DAW, through the Focusrite 18i8 1/2 Outputs to my monitors, or the exported file, from my Windows Media Player through the Focusrite 18i8 1/2 Outputs to my monitors. I've set the volume levels on both the interface and the windows media player to 90 so they sound that same. That helped my level issue but not the distortion problem. 😉 

I double checked all my channels went to my master.  All did with the exception of Phones, PhonesFX and PhonesInstr which route to the Focusrite 3/4, 5/6, and 7/8 for artist to hear while tracking. These it appears are the problem as per:

Lord Tim and Noel Borthwick for the win!

When I mute those three outputs (that should have zero effect on, "What You Hear" mix down... the distortion and clipping go away. so they are in fact being summed into the master buss on mix down. Seems like a bug to me. I also notice, and this jogged my brain... with the update to Cakewalk from older Sonar product, the "Master Mix" preset, with Entire Mix selected, has source hardware outputs 1/2, 3/4, 5/6, 7/8 all selected with no way to deselect the extra outputs. I think that is the change that happened that started screwing things up. I assumed that since those out's were only used for phones back to the artist while tracking, and it was a master mix or what you hear mix going to my exported file... it would not include them... why should it? and when I tried "what you hear" I can deselect busses but the results were way to low output or no FX. If I kept FX and Master, it would go find and sum in the phones FX too!

So it definitely seems like a bug to me. 

Thank you so much to each you who helped me on this!

I'll post a link to the music video when its' up so you can know what you helped make possible!

Bruce

Edited by Bruce Searl
  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, Bruce Searl said:

CJ Jacobson - I playing either form the DAW, through the Focusrite 18i8 1/2 Outputs to my monitors

If you are playing back through the DAW with the same effect chains you exported it out to, you are going to clip. 

 

2 hours ago, Bruce Searl said:

with Entire Mix selected, has source hardware outputs 1/2, 3/4, 5/6, 7/8 all selected with no way to deselect the extra outputs.

I use entire mix as the source with Bandlab Cakewalk and do not have a clipping issue. As long as your master bus goes to your main outs 1/2, it doesn't matter if 3/4 or 5/6 are also selected. Nothing is going there. It will not make things clip.

Share this post


Link to post
Share on other sites

When I do entire mix and everything goes to master on 1/2 out... it will clip and distort. If I mute the other three stereo busses, that do not rout to master 1/2 anyway, it will not clip... so it seems to be a bug.  Or some operator error on my part that I don't understand. It's a new thing, I've tracked probably 25 projects setup the same with no issues until Bandlab took over.

 

Share this post


Link to post
Share on other sites

Another question. When I used to export my mix to wav or mp3, they were both of the same volume level. Now, with bandlab, the mp3 is a lot quieter, about 6-9db no matter the settings. my WAVs are 48K 24bit for video DVD use, but the MP3's have always been as loud, at least I think they have? 

When I open the Wave in Sound forge and convert it to an MP3 it gets softer too... so am I just now realizing that mp3 are not as loud as a wav file? I have always thought the same same for CD quality 44.1K 16 wav to mp3, but maybe it's different coming down from 48K/24bit to 48K/16bit or 44.1K/16bit MP3? I thought the volume level as supposed to stay the same?

I think I'm losing my mind on this project! ;-)

Thanks

Share this post


Link to post
Share on other sites
Posted (edited)
12 hours ago, Bruce Searl said:

When I do entire mix and everything goes to master on 1/2 out... it will clip and distort. If I mute the other three stereo busses, that do not rout to master 1/2 anyway, it will not clip... so it seems to be a bug. 

I do not see that behavior on my DAW. We have the same DAW. Check all your routing and im sure there is something going on that you are not seeing to one of your other main outs..

I've exported hundreds of audio files in the past week with the latest Bandlab Cakewlak (what ever its called, i just downloaded it last week) and im exporting exactly what i am seeing going out of my master and onto main outs 1/2.

If it was a bug, Everyone would see this, not just you.

Quote

When I open the Wave in Sound forge and convert it to an MP3 it gets softer too... so am I just now realizing that mp3 are not as loud as a wav file?

The volume should be the same. Its routing issue, as you are having volume/Gain issues on 2 different DAW's

Edited by CJ Jacobson
  • Thanks 1

Share this post


Link to post
Share on other sites
18 hours ago, Bruce Searl said:

Hey All! Thanks for the help. I was out shooting the video yesterday and so I just got back to this to try to figure out my audio problem so I can start editing the thing together. 

CJ Jacobson - I playing either form the DAW, through the Focusrite 18i8 1/2 Outputs to my monitors, or the exported file, from my Windows Media Player through the Focusrite 18i8 1/2 Outputs to my monitors. I've set the volume levels on both the interface and the windows media player to 90 so they sound that same. That helped my level issue but not the distortion problem. 😉 

I double checked all my channels went to my master.  All did with the exception of Phones, PhonesFX and PhonesInstr which route to the Focusrite 3/4, 5/6, and 7/8 for artist to hear while tracking. These it appears are the problem as per:

Lord Tim and Noel Borthwick for the win!

When I mute those three outputs (that should have zero effect on, "What You Hear" mix down... the distortion and clipping go away. so they are in fact being summed into the master buss on mix down. Seems like a bug to me. I also notice, and this jogged my brain... with the update to Cakewalk from older Sonar product, the "Master Mix" preset, with Entire Mix selected, has source hardware outputs 1/2, 3/4, 5/6, 7/8 all selected with no way to deselect the extra outputs. I think that is the change that happened that started screwing things up. I assumed that since those out's were only used for phones back to the artist while tracking, and it was a master mix or what you hear mix going to my exported file... it would not include them... why should it? and when I tried "what you hear" I can deselect busses but the results were way to low output or no FX. If I kept FX and Master, it would go find and sum in the phones FX too!

So it definitely seems like a bug to me. 

Thank you so much to each you who helped me on this!

I'll post a link to the music video when its' up so you can know what you helped make possible!

Bruce

@Bruce Searl I think there is some confusion about how the bounce presets work and there has been no change in behavior. You will get the same result in any version of SONAR if you export the what you hear preset, or choose entire mix in the mix options.

Cakewalk presently has no way to distinguish a headphone/cue mix from the master mix. What your see as the master bus in your project is simply a bus named *master* that came from the default template when the project was created. It could have been called main/mix/speakers or anything you want.

The entire mix setting in the bounce options instructs the mixdown process to sum ALL bus outputs to a single stereo mix. This option should not be used when you have sub mixes in the project going to different outputs because it will result in a higher gain output. Instead, for this use case you should explicitly export just the bus you want which in your case would be master. Another way would be to solo the master bus before exporting with the entire mix setting enabled.

In short this is not a bug. That said we could do better to warn the user when using the entire mix option if we detect that included buses are going to different hardware outputs.

  • Thanks 1

Share this post


Link to post
Share on other sites

@CJ Jacobson

The volume change from WAV to MP3 doesn't seem like a routing issue if I take the loud WAV file that I exported and convert it with SoundForge. There is no routing options for SoundForge. it's a simple open, convert, save process. 

I can see how it could be a routing issue in Cakewalk as I'm obviously floundering about there a bit! ;-) but now that I'm muting the other busses on export at least the main issue seems behind me.

So if the volume of and exported or converted WAV to MP3 should be the same, but it's not, could that be a windows media player issue?

I can upload the master WAV file to DistroKid and let them do the conversion to MP3 for iTunes, Google Play and other online stores but it would be nice to figure out what I'm doing wrong. 

Thanks so much for you help on this. :-)

Bruce

Share this post


Link to post
Share on other sites
5 minutes ago, Bruce Searl said:

The volume change from WAV to MP3 doesn't seem like a routing issue if I take the loud WAV file that I exported and convert it with SoundForge. There is no routing options for SoundForge. it's a simple open, convert, save process. 

Its not a simple open and save. Routing involves your Cue Mix also. . I Own and use SoundForge. I get the same gain level when exporting wave files to MP3's.

The only difference is with the lower bitrates, you can get some high end frequencies cut off. so you should use 320 bitrate or 256 bitrate

Your common denominator between your gain issues is your Cue Mix. Your troubles may lie in there. As there is no bug. Its a setting on your part. You just need to find it and correct it.

  • Thanks 1

Share this post


Link to post
Share on other sites

Yes there could be something going on in there, if you are having issues with 2 different DAW's. But with Cakewalk, what Noel said is Spot On!!

Share this post


Link to post
Share on other sites

There is no extra gain staging  applied when exporting to mp3 within Cakewalk. We're passing the same audio data that is written to a wave file  after bit reduction since the mp3 encoder doesn't support higher floating point but depths.

As CJ said mp3 encoding can create artifacts depending on the algorithm and bit rates chosen so make sure you are picking high enough settings. Also some people have found that if you have inherent phase problems in your mix encoding can make it sound different from the wave file. In any case you can eliminate any gain staging problems by importing the final wave file into a empty project and exporting just that to mp3. Then compare the two.

Since we've established that this is not a problem you may want to add solved to your thread title.

Share this post


Link to post
Share on other sites

I think I found another clue... I've been checking the wav file in windows Media player... but I've been checking the playback of the MP3 with the file explorers "Windows Media Player Rich Preview Handler" which is quite a bit softer level than when the WAV file is played on the regular Windows Media Player App... 

And... when I play the MP3 on the Windows Media Player App... the MP3 is FINE! Duh! This is a clear case of Operator Error! As soon as I can find the operator, I'll fire them... Oh, wait, maybe I'll give them a raise! They obviously deserve it after all the frustration they have been through. ;-)

So my MP3 files are fine... it's the players that are causing the discrepancy.

No idea where to fix that... the mixer is at 100% level on the Rich Preview Handler App already.

Thanks Guys... next post will be the results of all your hard work trying to get me in line!

Bruce

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Here you go! 

Thanks for all your help guys! I can't include a link... so...

 

Search YouTube:
Call Me Young from MILAGRO A New Musical (Cover) - Jessica Searl

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×