Jump to content
AdK Studios

Some issues that needs to be rectified as soon as possible

Recommended Posts

I didn't know this feedback loop thingy existed. Or else I wouldn't have made a video pointing out the most obvious problems I have been facing in Cakewalk. I was waiting for the comments to accumulate to see the opinion (and other suggestions) of others before reaching out to the social handles of Bandlab. And it is from the comments I came across this feedback loop. These are the points I stated in that video. These are the issues that were mentioned in it.

  1. No MIDI Clip isolation
  2. Automation Issues
  3. Exporting issue with track outs

MIDI Clip isolation

Cakewalk must be the only DAW that I have used, that doesn't let us isolate or MIDI data inside a MIDI clip. From the comments, I figured many users actually prefer having to see the entire MIDI data in a track, even though it might be even above 10 minutes. So, I hope it can be brought in like an option that can be turned ON and OFF like the Clip outlines I showed in the video.

Automation Issues

There are too many automation issues that it can be a post of its own. I strongly suggest watching the video to see the obvious issues like unresponsive automation, delay in automation timing, and weird sound output. Apart from it is hard to carry out simple copy and paste with automation data.

Exporting issue with track outs

When we export track outs, the bus effects does not get applied to the tracks. I talked to someone who had used Cakewalk from 1998 and he said it wasn't like that. Back when Cakewalk was Sonar, the bus FX did get applied to individual track outs. This is necessary when we are working with other people.

Hope you look into these as soon as possible, at least the second and third issues.

-AdK

Share this post


Link to post
Share on other sites

I personally love if midi isnt isolated because i can be more creative and i have used  many DAWS where clips isolated and it destroyed my creativity, I changed my habits from FL Studio and Studio One, Cubase and i can do all good and i like how all is in CbB.  I can think out of box. Maybe need change some habits and starting to think in different way how Cakewalk DAW is suppose to do things not how other DAWS do. Cakewalk Does all well need to change habits from other DAWS : ) We don't need copy all DAWS we need be more creative, unique.

Edited by solarlux
  • Like 2

Share this post


Link to post
Share on other sites

AdK's 9 minutes and 3 seconds video does a good job of highlighting how users that create electronic based music use CbB differently than users that use CbB to make more traditional recordings.

I believe CbB needs to adapt its tools and tool set to accommodate a more diverse user base so I welcome comments from users like AdK, Xel Ohh and E-Woof Music!

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
15 minutes ago, Jim Fogle said:

AdK's 9 minutes and 3 seconds video does a good job of highlighting how users that create electronic based music use CbB differently than users that use CbB to make more traditional recordings.

I believe CbB needs to adapt its tools and tool set to accommodate a more diverse user base so I welcome comments from users like AdK, Xel Ohh and E-Woof Music!

Yes but Cakewalk is very good for electronic music. I have used Cubase , Ableton, Studio one, Fl studio and i can say CbB works best for me. I know some things need to be improved but totally not need copy all DAWS but need to improve power of Cakewalk WHat lives inside : ) In electronic music best is one synth with many accessable sounds and can fast reach every sound what you want to use and sonics matter for example if you have something like VSTI Nexus, Massive, Omnisphere, Vital, Serum, Phase Plkant or etc.  where easy accessable much sounds fastly can be used and then ideas born.  My opinnion much sound base what i can use for electronic music matters not midi issolation or something like that. For example FL studio comes with bunch of synths and can be fast accesable much sound that is reason why FL is full with sounds but i can download much stuff for Cakewalk also and no problem with that

Edited by solarlux
  • Like 2

Share this post


Link to post
Share on other sites

@solaelux,

I'm not disagreeing with you, Cakewalk is great and getting better every release.  The current development team has done an admirable job  of making the product much more stable while adding new features.  My point is not to minimize their accomplishments.  I'm hoping to encourage new users to share their thoughts concerning the product.

  • Like 3

Share this post


Link to post
Share on other sites
2 hours ago, AdK Studios said:

I didn't know this feedback loop thingy existed. Or else I wouldn't have made a video pointing out the most obvious problems I have been facing in Cakewalk. I was waiting for the comments to accumulate to see the opinion (and other suggestions) of others before reaching out to the social handles of Bandlab. And it is from the comments I came across this feedback loop. These are the points I stated in that video. These are the issues that were mentioned in it.

  1. No MIDI Clip isolation
  2. Automation Issues
  3. Exporting issue with track outs

MIDI Clip isolation

Cakewalk must be the only DAW that I have used, that doesn't let us isolate or MIDI data inside a MIDI clip. From the comments, I figured many users actually prefer having to see the entire MIDI data in a track, even though it might be even above 10 minutes. So, I hope it can be brought in like an option that can be turned ON and OFF like the Clip outlines I showed in the video.

Automation Issues

There are too many automation issues that it can be a post of its own. I strongly suggest watching the video to see the obvious issues like unresponsive automation, delay in automation timing, and weird sound output. Apart from it is hard to carry out simple copy and paste with automation data.

Exporting issue with track outs

When we export track outs, the bus effects does not get applied to the tracks. I talked to someone who had used Cakewalk from 1998 and he said it wasn't like that. Back when Cakewalk was Sonar, the bus FX did get applied to individual track outs. This is necessary when we are working with other people.

Hope you look into these as soon as possible, at least the second and third issues.

-AdK

+1 for adjustable Clip outlines. Because i think its theme case, in some themes i see it better than in darker themes. Maybe would be good adjustable midi clip outline colors : )  Automations also can be fixed. I hope Bakers will fix automation problems

Edited by solarlux
  • Thanks 1

Share this post


Link to post
Share on other sites

@AdK Studios  Write about automations to Bakers but midi isolation option maybe in future will be available but now i see more important is automations and maybe write them and talk more about your problem because i think they will fix it because i asked one thing and they fixed it fast, They are very responsive and they fixing all issues. Ab out midi issolation i make loop where i editing my midi and i see all is fine.

Edited by solarlux
  • Great Idea 1

Share this post


Link to post
Share on other sites

@AdK Studios - can you retry automation with the latest hotfix?  Please let us know if you're still having problems with this.

We're aware of the "Show Clip Outlines" issue in the Tungsten theme (Mercury theme doesn't have this issue). I'll try to get it bumped up the to-do list.

I'll discuss the other issues with the team.

  • Like 2

Share this post


Link to post
Share on other sites
28 minutes ago, msmcleod said:

We're aware of the "Show Clip Outlines" issue in the Tungsten theme (Mercury theme doesn't have this issue). I'll try to get it bumped up the to-do list.

I'll discuss the other issues with the team.

If you make brighter of the default background color of the clips in Tungsten theme, this issue will be solved automatically.

However, the colors of the grid lines may need to be changed with the new background color.

Share this post


Link to post
Share on other sites
25 minutes ago, murat k. said:

If you make brighter of the default background color of the clips in Tungsten theme, this issue will be solved automatically.

However, the colors of the grid lines may need to be changed with the new background color.

Yes but would be good opportunity in colors to change color of midi clip outline and all would solve issue individually for piano roll colors which they have : )

Share this post


Link to post
Share on other sites
15 minutes ago, solarlux said:

Yes but would be good opportunity in colors to change color of midi clip outline and all would solve issue individually for piano roll colors which they have : )

I am sorry I didn't get it. If you are talking about changing the clip's background color individually, you can do from the Clip Properties section. When you change the clip's background color, you see that it will also change in the PRV View. But if you are talking about selecting clips in PRV for changing color or some different needs, it would be nice.

  • Thanks 1

Share this post


Link to post
Share on other sites
15 minutes ago, murat k. said:

I am sorry I didn't get it. If you are talking about changing the clip's background color individually, you can do from the Clip Properties section. When you change the clip's background color, you see that it will also change in the PRV View. But if you are talking about selecting clips in PRV for changing color or some different needs, it would be nice.

Thank you so much you solved this issue.

 

 

thanks.jpg

Edited by solarlux
  • Like 1

Share this post


Link to post
Share on other sites

I am glad that you solved your issue. Also you can easily bring the Background Color Menu over the selected clip with Capslock + Left Click by Cakefolk™.

 

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, murat k. said:

I am glad that you solved your issue. Also you can easily bring the Background Color Menu over the selected clip with Capslock + Left Click by Cakefolk™.

 

Would be nice focus feature, when transport line inside midi clip midi clips bacground  color red and when out than old default color back.

Share this post


Link to post
Share on other sites
On 1/26/2021 at 3:53 PM, msmcleod said:

@AdK Studios - can you retry automation with the latest hotfix?  Please let us know if you're still having problems with this.

We're aware of the "Show Clip Outlines" issue in the Tungsten theme (Mercury theme doesn't have this issue). I'll try to get it bumped up the to-do list.

I'll discuss the other issues with the team.

The automation problem still exists even after the updation. FYI, I tried different audio driver modes and varied buffer size (not sure that will actually help). Is there anything more I should try? Am I the only one who is experiencing this issue with automation?

Clip Outlines has improved. But, still we can't differentiate between adjacent MIDI clips.

Share this post


Link to post
Share on other sites

@AdK Studios thanks for the feedback.

Some of the automation issues reported were bugs already fixed in the latest 2021.01 release. ESP the freeze issue. The plugin automation issue with pitch riser is also the identical issue. The bug was that in 2020.11 freeze or bounce could cause envelopes to get orphaned. If you had  hovered over the envelope he would have noticed that it showed a tooltip saying “orphaned”.  When automation doesn’t render this is the issue 99% of the time.

Regarding clip based workflow our piano roll is currently not particularly tailored for that but well consider allowing a mode to show only selected clips. Its not something that most of our users have requested in the past.

Regarding automation accuracy, its not clear what your buffer size is. You are running a VST2 plugin and in VST2 automation is only accurate to the buffer size, unlike VST3 which is sample accurate. If you want sample accurate automation you should only use VST3 plugins or run at a very low latency.  This could also be something specific with the plugin since I have not encountered this specific issue. If you share a simple project file with a repro we can look into it.

Quote

When we export track outs, the bus effects does not get applied to the tracks. I talked to someone who had used Cakewalk from 1998 and he said it wasn't like that. Back when Cakewalk was Sonar, the bus FX did get applied to individual track outs. This is necessary when we are working with other people.

This is inaccurate. Its by design that bus effects are not applied and has been this way in every version of Cakewalk going back all the way to 2003. As far as stems go its intentional that source category tracks does NOT include bus automation since this is the typical use of track stems. If you want bus stems you should export with source category buses and make specific buses for the stems that you wish to deliver. Alternatively you can simply solo tracks you want and export with source category set to buses to get the results you want.

I do agree that when source category is set to tracks, we need to gray out the bus options. That’s just a UI oversight.

  • Like 1
  • Thanks 2

Share this post


Link to post
Share on other sites
42 minutes ago, AdK Studios said:

The automation problem still exists even after the updation. FYI, I tried different audio driver modes and varied buffer size (not sure that will actually help). Is there anything more I should try? Am I the only one who is experiencing this issue with automation?

Clip Outlines has improved. But, still we can't differentiate between adjacent MIDI clips.

Which automation problem are you referring to? Can you provide a project file or a step by step recipe?
 

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, AdK Studios said:

The automation problem still exists even after the updation. FYI, I tried different audio driver modes and varied buffer size (not sure that will actually help). Is there anything more I should try? Am I the only one who is experiencing this issue with automation?

Clip Outlines has improved. But, still we can't differentiate between adjacent MIDI clips.

Use also Arranger track in combination with piano roll and track pane and made loop where you want focusing. Maybe in future will be available function for each arranger track section to hide tracks without clips in section range would be cool in inspector arranger view when inside in piano roll you can click right click on section and there option to hide unused tracks without clips in section range. My logic is if you have one clip near another why you cant make 1 clip instead of 2 clips near each other? I made seperate clips and i can see outlines because i use second clip not near but in situation where notes near each other i made 1 clip. Arranger track is for focusing on many things. Also you can make loop in clip and see where is your individual midi clip if you have one clip near other clip.Send specific cases about automation problems because problems only can be solved if is possible replicate them.

Edited by solarlux

Share this post


Link to post
Share on other sites
1 hour ago, Noel Borthwick said:

@AdK Studios thanks for the feedback.

Some of the automation issues reported were bugs already fixed in the latest 2021.01 release. ESP the freeze issue. The plugin automation issue with pitch riser is also the identical issue. The bug was that in 2020.11 freeze or bounce could cause envelopes to get orphaned. If you had  hovered over the envelope he would have noticed that it showed a tooltip saying “orphaned”.  When automation doesn’t render this is the issue 99% of the time.

Regarding clip based workflow our piano roll is currently not particularly tailored for that but well consider allowing a mode to show only selected clips. Its not something that most of our users have requested in the past.

Regarding automation accuracy, its not clear what your buffer size is. You are running a VST2 plugin and in VST2 automation is only accurate to the buffer size, unlike VST3 which is sample accurate. If you want sample accurate automation you should only use VST3 plugins or run at a very low latency.  This could also be something specific with the plugin since I have not encountered this specific issue. If you share a simple project file with a repro we can look into it.

This is inaccurate. Its by design that bus effects are not applied and has been this way in every version of Cakewalk going back all the way to 2003. As far as stems go its intentional that source category tracks does NOT include bus automation since this is the typical use of track stems. If you want bus stems you should export with source category buses and make specific buses for the stems that you wish to deliver. Alternatively you can simply solo tracks you want and export with source category set to buses to get the results you want.

I do agree that when source category is set to tracks, we need to gray out the bus options. That’s just a UI oversight.

Thanks about info.

Share this post


Link to post
Share on other sites
14 hours ago, Noel Borthwick said:

Regarding clip based workflow our piano roll is currently not particularly tailored for that but well consider allowing a mode to show only selected clips. Its not something that most of our users have requested in the past.

I understood that from the comments in the video. Therefore, if I may ask, will it be possible to just represent something to differentiate between the individual MIDI clips. Don't want the other MIDI clips to disappear. Just a means to understand the boundaries of each MIDI clip. It will be great for drum programming, or anything that has a "loop" nature.

15 hours ago, Noel Borthwick said:

Regarding automation accuracy, its not clear what your buffer size is. You are running a VST2 plugin and in VST2 automation is only accurate to the buffer size, unlike VST3 which is sample accurate. If you want sample accurate automation you should only use VST3 plugins or run at a very low latency.  This could also be something specific with the plugin since I have not encountered this specific issue. If you share a simple project file with a repro we can look into it.

My Cakewalk buffer size is 512 Samples (10.7msec). It does change from that value <Under driver settings>
Number of Buffers 64 <Under playback and recording>
Driver Mode = ASIO

I'm attaching a project that can demonstrate my automation issue in Cakewalk. It also has rendered output tracks from some other DAWs too for reference.
More detail on it will be in the 'notes' in Cakewalk itself.

15 hours ago, Noel Borthwick said:

This is inaccurate. Its by design that bus effects are not applied and has been this way in every version of Cakewalk going back all the way to 2003. As far as stems go its intentional that source category tracks does NOT include bus automation since this is the typical use of track stems. If you want bus stems you should export with source category buses and make specific buses for the stems that you wish to deliver. Alternatively you can simply solo tracks you want and export with source category set to buses to get the results you want.

Thanks for clearing that up. But, the solution is quite not a practical one when we have upwards of 100 tracks. Guess I'll have to find the work around for that myself. My apologies.

Automation issue.zip

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...