Jump to content
  • 0
Alun Crewe

Why don't MIDI notes below B2 play on my bass track?

Question

Hi, forgive another newbie question but I have a bass track in my project which plays fine if I'm using the default TTS-1 instrument but if I switch the track to a VST instrument (Sampletank 4, Kontact or even the SI bass) all the notes below B2 (one note below c3) don't play. Am I missing a setting somewhere? According to the individual instrument ranges I should be fine. Thanks for your help.

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

A lot of DAWS number the keyboard with octave numbers starting at -2. Cakewalk starts at 0. So when you play E3 on Cakewalk's piano roll, in an different DAW it would say E1.

Share this post


Link to post
Share on other sites
  • 0

Hi Nigel, OK, I can see that but then the notes it does play would sound two octaves too low wouldn't they? The ones it is playing sound at the right pitch.

Share this post


Link to post
Share on other sites
  • 0

Exactly. On the VST GUI click on the open E. Plays correct note.

On the piano roll click on E3. Plays the correct note. A different DAW would call that very exact same note E1. Which is what you want to call it. It is just that Cakewalk calls it E3.

EXTRA
If it is vital that Cakewalk calls it E1, do this:
Edit -> Preferences -> Customization -> Display.
Right at the bottom change Base Octave for Pitches to -2. (Pay attention to the minus.)

Now when you click on E1 you will get the note you expect.

Cakewalk just names the octaves differently to most, that is all.

Making that change can often help with VSTs that use keyswitches for articulations because most of them use -2 as the base number for octaves. But some don't, so you have to keep your wits about you.

BUT ...
     if you use Articulation Maps to trigger keyswitches, then you can keep Cakewalk as standard, because the correct note numbers are in the maps.
AND ...
    if you change the base number, then almost all Articulation Maps you download will be wrong.

 

Choose your evil ...      😀

Edited by Nigel Mackay
  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Thanks Nigel. As usual the depth of functionality makes finding the right switch for the function you're looking for really tough sometimes... but it's definitely worth the effort. 🙂

I changed the setting and it changes the numbers displayed on the keyboard as you described... but the notes I had problems with still don't play

Share this post


Link to post
Share on other sites
  • 0

With the new numbers try E1. It should be the open E string.

If it doesn't sound, what happens if you play E2. Is it open E string or 2nd fret on the D string.
If the latter you have a MIDI filter somewhere stopping those notes.
New project, insert only the SI-Guitar. What happens?

Share this post


Link to post
Share on other sites
  • 0

Hi Nigel. Yes, that works. I can play an E1 open string and it plays fine, but the notes in my MIDI track still don't play with the notes with the change. The answer is just to transpose the entire track up one octave and it actually sounds OK so I think, for whatever reason, my track got imported an octave too low and I thought it sounded correct 😱

Anyway, thanks for all of your help. I learned a lot from just playing with the controls. 🙂

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

TTS-1 is a GM synth and maps pitched instruments across all 128 MIDI notes.

Most soft synths do not do this.

It is not unusual for soft synth to restrict the playable range of the instrument.

This is especially true for sample-based synths like the Studio Instrument Suite (note: SampleTank and Kontakt fall into this category too).

SI-Bass note range is determined by the sfz files used in the programs.

Most of them start at MIDI note 36.

The range may be extending by modifying the sfz files. Extreme modification may require additional samples.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Thanks scook I realise that that sample-based synths are limited in their note range (Sampletank actually displays this range on the preview keyboard)  but looking at where (I thought) the notes were in the bass line they should have played OK. I think the final answer was in the disparity between the 2 octave offset that Nigel pointed out and that (for some reason I don't fully understand) the bass line was imported an octave lower than it should.

Anyway, moving the whole track up an octave fixed it. 

Thanks for the reply!

Share this post


Link to post
Share on other sites
  • 0

Just a bit of forum info. When you mention a fellow user in a post, if you precede their username with an ampersand, they get notified that you tagged them. Type @ and then start typing their user name and a list pops up and you can select them.

  • Like 2

Share this post


Link to post
Share on other sites
  • 0

This is normal to have to transpose up one octave. Example is play your part on a real bass and drag that to a midi track. Melodyne will convert the audio to midi. Now assign the track to SI bass or Ample bass or Dim Pro. It will play an octave lower than the audio track. 

Download a GM midi file and open it in Cakewalk TTS-1 will load and play the song if you don't have any midi outputs selected in Preferences. The Bass part will play perfectly the way the composer wanted it to. 

Now insert the SI ( or any Sample type Bass VST)  and you will have to transpose up +12.  So Melodyne and GM midi follow a correct note assignment but for some reason a lot of Sample based VST's do not. And just so you know, the Samples on a Bass won't go below low B as in a 5 string Basses lowest note. 

Edited by John Vere
  • Like 1

Share this post


Link to post
Share on other sites
  • 0
47 minutes ago, Nigel Mackay said:

Just a bit of forum info. When you mention a fellow user in a post, if you precede their username with an ampersand, they get notified that you tagged them. Type @ and then start typing their user name and a list pops up and you can select them.

Will do @Nigel 😉

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...