Jump to content
  • 0
Paolo Porro

How to assign a VST plugin to an existing midi

Question

Hello everybody,

since I'm probably the most unable of the Cakewalk user, please forgive me immediately for my basic question. I also don't know if the title I gave to it is really correct and if it's really pointing out to what I need... Anyway, I'm really new to home recoding (it's a week I have Cakewalk installed...), and I will use the software just in order to record some sample for my bandmates.

This is my problem: I use to write songs and tab them using Guitar Pro, so I already have drums and bass tracks written that I can export as MIDI tracks. So, once I have exported singularly a drums midi track and a bass midi track and imported them in a new Cakewalk project, it would be cool to assign some "real sounds", but I really can't do it.

Substantially, I don't have to write a drums or a bass part using a map, I've them already done: I need to "transform" them in something "real", just to gave the best idea of the song.

827165669_Cakewalkstamp2.thumb.jpg.979b51530761dbe5aeb6e2b3b30ced5e.jpg

569404002_Cakewalkstamp.thumb.jpg.787fa814d5d351bcdeec27f4f7841d18.jpg

I don't know if this helps, but above is what I can see in the new project and in the piano roll (this is a drum midi already imported in the project). 

Since now, a friend of mine helped me recording some material with GarageBand, but I can remember a simple midi drag and drop to get an automatic assignment to various parts of the drums set (kick, hi-hat, snare, etc.), but this doesn't seem to be possible with Cakewalk.

Hope my question is clear, I'm sorry if I can't use any technical term to better explain contents (really a total newbie)... if someone of you can show me how to do, many thanks in advance!

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 1

Do not use import. This is designed to import clips into an existing project. It strips tempo information from the MIDI file.

To create a new project with an existing MIDI performance:

  • make sure there is no MIDI Output device selected in Preferences > MIDI > Devices
  • open the MIDI file using File > Open

This will cause the DAW to add TTS-1 to the project and have it ready to play.

Then add plug-ins as desired re-routing the MIDI tracks to the new synths.

When adding the synths use one of the methods that provides the Insert Soft Synth Options dialog such as

  • drag and drop the synth from the plug-in browser
  • Insert > Soft Synth from the main menu

and select one of the audio output options in the dialog.

 

Share this post


Link to post
Share on other sites
  • 0

Let's do the drums. Use Views -> Browser or press b on the keyboard to open the browser.
You will see something very similar to this:
872712120_2020-08-0407_44_48-Window.jpg.081f0f7a7caab111778534cc9149a3b4.jpg
Click on the icon that looks like a tiny keyboard. You will see something like this:
348006161_2020-10-2617_46_33-Window.jpg.9eea3f1d17b9f016dddbd672d77872ab.jpg
Click on the + next to Drums, click and drag the SI-Drums under the tracks that are in the track pane.
Looking at your bottom screenshot, on the extreme left is the channel strip for the midi track. At the bottom is O for output. It currently seems to be going to the Microsoft General Midi Wavetable.
Click on the drop-down and select SI-Drums.
Press Play.

Now do the same thing for the bass MIDI, except use the SI-Bass Guitar. Make sure you point the bass midi channel strio to the guitar, don't accidentally reassign the drums. 😀

 

Share this post


Link to post
Share on other sites
  • 0

@Nigel Mackay, @scook, I was able to follow your instructions, thanks a lot again!

Of course it's not ALL ok, infact I can't find the SI-Drums under "Instruments" in the Plugins menu (only under "FX"), I can't understand why. I tried to check all folders, but I still don't know why I can't see it, do you have any suggestions? Thanks in advance

In the meanwhile, I'm using a plugin I found some days ago called "MT-PowerDrumKit", in order to verify if now my midi drums works (and it works!)... it's all ok, except for the fact that I can't adjust the kick volume: I can turn it up and down while the midi/track is playing using the Mt-PowerDrumKit mixer, but when I stop it, the volume is back to the starting level and I can't understand how to change it definitively

Share this post


Link to post
Share on other sites
  • 0
24 minutes ago, Paolo Porro said:

I can't find the SI-Drums under "Instruments" in the Plugins menu (only under "FX"), I can't understand why. I tried to check all folders, but I still don't know why I can't see it, do you have any suggestions?

The scanner got the plug-in type wrong, run a VST reset from preferences

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Paolo Porro said:

In the meanwhile, I'm using a plugin I found some days ago called "MT-PowerDrumKit", in order to verify if now my midi drums works (and it works!)... it's all ok, except for the fact that I can't adjust the kick volume: I can turn it up and down while the midi/track is playing using the Mt-PowerDrumKit mixer, but when I stop it, the volume is back to the starting level and I can't understand how to change it definitively

In the track there is a command to set the volume. With the track selected, open the event view (Views -> Event List, or Alt-8). Look for anything that isn't Kind Note.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

There might be a volume cc event look in the event list or pvr 

just a little tip for those looking for a better free drum VST. Get the Steven Slate demo kit for free  I just found out about this deal today on another thread similar to this one and it’s a very advanced VST for free. Blows away SI and Power 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

A follow up= Was playing with the Steven Slate drums last night and had to give up on it as it just doesn't cut through. I'll have the VST level meter in the red and the level is way below other drum VST's.    I tried turning all the parts and the faders for the Room and Overhead but it seems to make no difference and just made the output level redder. 

Used the Replace synth feature to return to Addictive drums and there was a huge difference. Loud and level meter is within the safe levels.. So much for that. 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...