Jump to content
  • 0
Who-Me

How do I remove the solid bar coloring in my MIDI tracks

Question

How can I remove the solid bars in all my midi tracks? Would prefer notes or dots when active in a measure/

Share this post


Link to post
Share on other sites

17 answers to this question

Recommended Posts

  • 0

I am using Cakewalk MIDI to control 6 synths (Ensoniq TS-10, 3 Korg m1rs. Emu Proformance Pro1, and an Alesis HR-16 I bought in 1988), with no audio.

On the original Cakewalk Sonar I bought in 2016 each track showed squiggly lines when there were notes to be played.

With this BandLab version there is just a solid bar all the way across the tracks even when nothing is playing.

Just wondering if I can replace the bars with something else like on the original Sonar so I can see what's happening in each track

or if I can get the bars to just turn to black  in a measure when nothing is playing.

But I have searched and can't find any mention of this.

Dennis

Edited by Who-Me

Share this post


Link to post
Share on other sites
  • 0

All of the MIDI tracks show as soon as I start Cakewalk and open an existing song. They are saved as a .mid file on my hard drive.

I have noticed whenever there is an audio track it shows the sound waves inside the tracks but when there is MIDI it only shows a solid colored bar across the screen.

Edited by Who-Me

Share this post


Link to post
Share on other sites
  • 0

I finally figured it out !!!!!!!!!!!!!!!!!!!!!

Had to expand each track, then clicked on "Clips" and changed it to "Notes". Talk about hidden!

Have to do each track, of each song, individually. Wish there was a way to make this the default setting!

Just had to play with it awhile!

Share this post


Link to post
Share on other sites
  • 0

The default edit filter setting for new tracks is Clips.

Unlike Cakewalk projects, MIDI files cannot retain edit filter settings or any non-MIDI data.

Opening MIDI files results in new track creation every time.

It is possible to use quick groups to change edit filter settings on selected tracks.

Select the tracks, hold down the CTRL key and change one of the selected track's edit filter. The other selected tracks will change too.

 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Who-Me said:

I finally figured it out !!!!!!!!!!!!!!!!!!!!!

Had to expand each track, then clicked on "Clips" and changed it to "Notes". Talk about hidden!

Have to do each track, of each song, individually. Wish there was a way to make this the default setting!

Just had to play with it awhile!

If you can switch between Notes and Clips it means you are using Simple Instrument Tracks. That has audio and MIDI on one track, so you need to decide if you are looking at audio or MIDI. If you are looking at the MIDI you could say the audio is "hidden" because you have to change from Notes to Clips.

Save you project.
Right-click on a track.
Select Split Instrument Track.
You now have 2 tracks - one is MIDI one is Audio.
If you prefer that do it for all tracks.
If you don't like it, use Undo. And remember that you have audio and MIDI on one track and need to switch between Notes and Clips to work with MIDI and Audio. Remember, 99.99% of the world uses MIDI to generate audio, so they need both.

You can split all your tracks and delete all the created audio tracks, and then you never have to switch. And in the future just insert MIDI tracks into your project.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
7 minutes ago, Nigel Mackay said:

If you can switch between Notes and Clips it means you are using Simple Instrument Tracks. That has audio and MIDI on one track, so you need to decide if you are looking at audio or MIDI. If you are looking at the MIDI you could say the audio is "hidden" because you have to change from Notes to Clips.

Are you sure about this?

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, scook said:

Are you sure about this?

An SIT is the only track type I can find where you switch between Clips and Notes.

Share this post


Link to post
Share on other sites
  • 0

Here is an image of a MIDI track and a simple instrument track first set to Clips then set to Notes.

dFm356C.png

AFAIK both support clips and inline PRV. At least until the simple instrument track is frozen.

Share this post


Link to post
Share on other sites
  • 0

There are so many ways to customize CbB it is difficult to know exactly what a user sees on their screen.

That and word choice can make problem solving challenging.

 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

When I first start Cakewalk BandLab and open a .mid file this is what I see. There is no audio, just MIDI data in the song.

I just wish I could have BandLab default to open with the MIDI notes showing instead of the solid bars all the way across the screen.

I got the notes to show by clicking Edit - Select All. Then opening up the first track, holding down the CTRL key and clicking Clips and finally Notes. When I save the file and re-open it, it still defaults to the solid colored bars in the tracks.

Cakewalk Print Screen.jpg

Cakewalk Print Screen 2.jpg

Edited by Who-Me

Share this post


Link to post
Share on other sites
  • 0

To get rid of the colored bars - Click "View" directly above the tracks - Then Click "Display" - Then Click "Display Clip Contents".

Remains in effect when opening a new song or when shutting down and restarting CbB. Happy Happy Joy Joy!!!!!!!!!!

Share this post


Link to post
Share on other sites
  • 0

I thought that was the default setting???

When notes are displayed, you can 1) left-click and drag up or down on the frame between the controller and clip panes to increase or decrease note size, or 2) right-click the frame and select Fit Content.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...