Jump to content
Cédric Lawde

Why Cakewalk creates a large number of wave files

Recommended Posts

Hello,
Every time I create a project, Cakewalk automatically creates a significant number of wave files as soon as I insert a VSTi. The program erases them and recreates them regularly.

Take a look :

1152903112_Capturedcran2020-09-24180844.thumb.jpg.19bc57470d838411d4aa6c1f4722afdd.jpg

Sometimes it is long. After a long time of work I can arrive at numbered files close to 9999! It bothers me when I work on an SSD because it "unnecessarily" uses my disk ...
Not to mention that the erasure and creation time is sometimes one minute between the PLAY key and the playback of the song? It's annoying.

 

I've also make a screen video:

 

Share this post


Link to post
Share on other sites

Interesting. I have never seen this and it doesn't do this on my system. The only things I can think of is to check your path settings and make sure things look like they are pointing to correct locations. Maybe it is specific to your language version?

Edited by reginaldStjohn

Share this post


Link to post
Share on other sites

Hi🙂

Very strange! Could you try to delete these _ before Caches or give another directory for it on the original place on drive C?

Without _ at the beginning!!!! Sometimes Dirs with an underscore at the beginning are seen as hidden and perhaps Cakewalk can't find it correctly....and writes these picture files anywhere else.

Which vst are you usi g if you have this behaviour?

Bassman.

Edited by Heinz Hupfer

Share this post


Link to post
Share on other sites

This is caused by the "Always Open All Devices" setting in Preferences\Audio\Playback and Recording and lots of audio tracks with input assigned.

Share this post


Link to post
Share on other sites

So, I've delete these "_" before "Caches directory". Nothing different happens.
I've verify the "Always Open All Devices" parameter, it's uncheck. Unfortunately, nothing different happen. Again.

There are always about fifty files created before reading. I do not find the manipulation that forces to rewrite them? In any case, it certainly happens every time I load a new VST.

Take a look to my others preferences :

1.jpg.d39f7c9cdec430320c1164a28dc54e7c.jpg2.jpg.5a6edec008630d9873cbd3ebb0c881a4.jpg3.jpg.ab40b5f8703787b9d92699e877b72b6a.jpg

 

Share this post


Link to post
Share on other sites

Hmm - I was sure that was it.  I also thought (but can't find) there was a setting that said something like "Allow record enable during playback" that may have been the candidate...

Does your project have a number of audio tracks equal to the number of "test" wavs that get created?

Share this post


Link to post
Share on other sites

@Cédric Lawde this behavior has been improved for the 2020.10 release. 
Simply adding a synth or loading a project shouldn't be triggering the creation of those files since they are only used during recording so that issue has been addressed.

Some notes for others reading this topic later. With regard to the Allow Arm Changes topic please read the help for the Recording Options.  In most cases you should always leave the two sub options "Only for Inputs in Project" and "Exclude Synth Inputs" checked because otherwise you can get a very large number of files created if you have many audio inputs available. This will make starting the transport sluggish.  3 files are created preemptively for every input on the system without those options checked. So if you have 16 hardware inputs and 10 synths in the project each with 8 recordable outputs, you will get a massive number of files created each time.  96*3 = 288 files! While these files are very small, file creation takes time and it will unnecessarily overload the system.

By leaving "Only for Inputs in Project" checked this will greatly reduce the number of anticipated inputs and be much more efficient while still allowing you to arm on the fly. Another general performance tweak is to only select audio device inputs in preferences that you actually use and leave others unselected. This will also help reduce unnecessary inputs.  

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...