Jump to content
Jon White

Audio overload in Cakewalk

Recommended Posts

Posted (edited)

Created drum track in Superior 3, guitar raw input from mic'd amp, bass same, then sang a track.  Three minute song, with a TrueVerb bus, Tony Maserati vocal plugin and Ozone 5 in the master bus.

Added VocalSynth and immediate popping and clicking for three of the five types of effect.  Rebooted, tried again, same.

Setup same song in Sequoia, same add of VocSyn afterwards.  Beautiful.  Added VocSyn to the guitar track for fun.  Smooth as silk.

Went back to Cake and added VocSyn to guitar track -- immediate audio dropuout upon hitting play.  Won't even play.

 

Please consider that asking me for specifics on my resources and all misses the comparison point.  I'm quite sure that Reaper and the wonderful Nuendo would have smiled through this, too.   Cakewalk, you must know something about how you are handling audio in detail.  What is it?  It's got to be fixed before anyone but hobbyists, if even they, would feel comfortable even starting a project with it.  Imagine a studio!

Edited by Jon White

Share this post


Link to post
Share on other sites
Posted (edited)

You had this and everybody else must have too?

Last time I had crackle in Cakewalk was when I reached 48 tracks, and sends and stuff everywhere. And this was a mistake due to that Prochannel had activated two plugins on every track, 96 instances.

Removing those I now am on 80 tracks in same project and still no crackles.

I run RME HDSP 9632.

What is your reference with any other daw and tracks and so on?

Maybe your interface is on the verge already doing what you did, and just that bit better working with other daws.

So which interface is it, or your feedback is futile?

 

Edited by LarsF

Share this post


Link to post
Share on other sites
1 hour ago, Jon White said:

Please consider that asking me for specifics on my resources and all misses the comparison point.  I'm quite sure that Reaper and the wonderful Nuendo would have smiled through this, too.   Cakewalk, you must know something about how you are handling audio in detail.  What is it?  It's got to be fixed before anyone but hobbyists, if even they, would feel comfortable even starting a project with it.  Imagine a studio!

So, you're just here to bitch?

  • Like 2

Share this post


Link to post
Share on other sites

Any chance you enabled the non-default  'aggressive' ThreadSchedulingModel=3 in AUD.INI (Preferences > Audio > Config File) despite warnings that it's experimental? Many who have tried it had a result like you describe, and many of those promptly forgot they had made the change and blamed the update... as usual. ;^)

 

Share this post


Link to post
Share on other sites
Posted (edited)
32 minutes ago, David Baay said:

Any chance you enabled the non-default  'aggressive' ThreadSchedulingModel=3 in AUD.INI (Preferences > Audio > Config File) despite warnings that it's experimental? Many who have tried it had a result like you describe, and many of those promptly forgot they had made the change and blamed the update... as usual. ;^)

Maybe it was the 'aggressive' ForumPostSchedulingModel = 3 that was enabled by mistake in AUD.INI by the OP?

I'm not saying things can't be improved, but manners could. 😉

Edited by GreenLight

Share this post


Link to post
Share on other sites

Ozone 5 and all Ozone versions are very CPU intensive. In many years past I used it on a mixed down stereo track in a mastering template due to my computer would have trouble otherwise. I still, more or less, do that even though I have a system that is very capable. 

One  trick to try is up your latency enough so you no longer have problems. You can put it back for recording. 

 

Edit to add. A rundown of your system would be useful. 

  • Haha 1

Share this post


Link to post
Share on other sites
On 6/18/2020 at 2:21 PM, LarsF said:

You had this and everybody else must have too?

Last time I had crackle in Cakewalk was when I reached 48 tracks, and sends and stuff everywhere. And this was a mistake due to that Prochannel had activated two plugins on every track, 96 instances.

Removing those I now am on 80 tracks in same project and still no crackles.

I run RME HDSP 9632.

What is your reference with any other daw and tracks and so on?

Maybe your interface is on the verge already doing what you did, and just that bit better working with other daws.

So which interface is it, or your feedback is futile?

 

Lynx audio card.  Again, though, what hits me is that other DAWs have no issue.

Share this post


Link to post
Share on other sites
On 6/18/2020 at 5:22 PM, GreenLight said:

Maybe it was the 'aggressive' ForumPostSchedulingModel = 3 that was enabled by mistake in AUD.INI by the OP?

I'm not saying things can't be improved, but manners could. 😉

Thank you for the tip.  I've covered that one prior, hoping for better luck long ago.  I appreciate the response.

  • Like 1

Share this post


Link to post
Share on other sites
On 6/18/2020 at 4:50 PM, David Baay said:

Any chance you enabled the non-default  'aggressive' ThreadSchedulingModel=3 in AUD.INI (Preferences > Audio > Config File) despite warnings that it's experimental? Many who have tried it had a result like you describe, and many of those promptly forgot they had made the change and blamed the update... as usual. ;^)

 

No, I remembered.  Thanks for the response.

Share this post


Link to post
Share on other sites
On 6/18/2020 at 2:28 PM, Colin Nicholls said:

So, you're just here to bitch?

Hmm.  What does "bitch" mean?  If I guess correctly, that's what you're doing regarding my posting, correct?

Share this post


Link to post
Share on other sites
On 6/18/2020 at 5:34 PM, John said:

Ozone 5 and all Ozone versions are very CPU intensive. In many years past I used it on a mixed down stereo track in a mastering template due to my computer would have trouble otherwise. I still, more or less, do that even though I have a system that is very capable. 

One  trick to try is up your latency enough so you no longer have problems. You can put it back for recording. 

 

Edit to add. A rundown of your system would be useful. 

Thank you, John.  It's a puzzle.  Much of my thoughts on this center on the number of issues with Cake audio when compared to other systems.  I use Pro Tools, too, and it skates through this stuff.

Share this post


Link to post
Share on other sites
3 hours ago, Jon White said:

Lynx audio card.  Again, though, what hits me is that other DAWs have no issue.

Different daws may set different ASIO latency, and some have special features like Cubase/Nuendo ASIO guard or whatever it was. Reaper and StudioOne add processing buffers apart from ASIO buffer setting etc. So many things may differ in what daw have as load. Larger latency give more headroom before crackles and pops.

Did you look in task manager what cpu load is and what is ASIO buffer setting?

(With and without last plugin, and depending on preset you used)

The example I mentioned it was added cpu, and when at 55-60%(task manager) or so, some crackles can appear. I run 64 samples ASIO buffers, and a 10 year old quadcore i7 (benchmarking at 5000, where modern cpu i9-9900k of today rate about 20 000) so old cpu in this regard.

If not related to cpu, something close to what you suggest - something wrong with audio engine - may be relevant.

I did not bother with 64-bit engine yet, if that matters.

This is another setting that may differ between daws what is default.

 

For me with Cakewalk the default threadscheduling worked the best in that it distribute even on 8 cores(4 physical with hyperthreading give 8 logical).

Another setting made it use 4 cores only(don't remember which one), so changed it back.

 

And my reasoning with what is the largest project that runs normally?

Thinking that some special plugin here really raise cpu. It could be running a mono plugin on stereo interleave track or other way around. Page 191 in manual mention some special settings that are in plugin manager in how mono is handled.

 

Overall thinking is that some default settings in Cakewalk does not make optimal result on your system.

Share this post


Link to post
Share on other sites

All DAWs have different preferences. It's unfortunate that you have to be a rocket scientist to make music these days, but I'm afraid that's the case.  Think of all those preference parameters as a combination lock - get the numbers right, and things work...and then there are all the Windows variables. 

I still don't miss tape, though :)

  • Like 3

Share this post


Link to post
Share on other sites
Posted (edited)
22 hours ago, Craig Anderton said:

All DAWs have different preferences. It's unfortunate that you have to be a rocket scientist to make music these days, but I'm afraid that's the case.  Think of all those preference parameters as a combination lock - get the numbers right, and things work...and then there are all the Windows variables. 

I still don't miss tape, though :)

Wow, yes.  What insight and wisdom you show here, Craig.  Truly.

I had a Tascam deck (4-ch), and it was, although a privilege in the early eighties, a challenge.  15-ips was the blessing, I thought!  But we innovated and got our art down!

Edited by Jon White

Share this post


Link to post
Share on other sites
On 6/20/2020 at 4:05 PM, LarsF said:

Different daws may set different ASIO latency, and some have special features like Cubase/Nuendo ASIO guard or whatever it was. Reaper and StudioOne add processing buffers apart from ASIO buffer setting etc. So many things may differ in what daw have as load. Larger latency give more headroom before crackles and pops.

Did you look in task manager what cpu load is and what is ASIO buffer setting?

This was my thought too.  You have not told us what buffer settings you have set in CW.  It could well be that out of the box, CW used more aggressive buffer settings than your other software.  You need to tell us which driver mode (ASIO, WASAPI, etc) and what audio buffer settings you are using before anyone here can help.  Telling us that "as usual" the audio engine is not up to par and then leaving out probably the most important information is just going to rile people up (which I see, it already has).

We're here to help, but at least make a reasonable effort to help us help you before telling us the software we all use is not up to par.  Otherwise you kinda come off as a bit of a troll (which I'm sure you're not).

Share this post


Link to post
Share on other sites
On 6/20/2020 at 12:05 AM, LarsF said:

Different daws may set different ASIO latency, and some have special features like Cubase/Nuendo ASIO guard or whatever it was. Reaper and StudioOne add processing buffers apart from ASIO buffer setting etc. So many things may differ in what daw have as load. Larger latency give more headroom before crackles and pops.

Did you look in task manager what cpu load is and what is ASIO buffer setting?

(With and without last plugin, and depending on preset you used)

The example I mentioned it was added cpu, and when at 55-60%(task manager) or so, some crackles can appear. I run 64 samples ASIO buffers, and a 10 year old quadcore i7 (benchmarking at 5000, where modern cpu i9-9900k of today rate about 20 000) so old cpu in this regard.

If not related to cpu, something close to what you suggest - something wrong with audio engine - may be relevant.

I did not bother with 64-bit engine yet, if that matters.

This is another setting that may differ between daws what is default.

 

For me with Cakewalk the default threadscheduling worked the best in that it distribute even on 8 cores(4 physical with hyperthreading give 8 logical).

Another setting made it use 4 cores only(don't remember which one), so changed it back.

 

And my reasoning with what is the largest project that runs normally?

Thinking that some special plugin here really raise cpu. It could be running a mono plugin on stereo interleave track or other way around. Page 191 in manual mention some special settings that are in plugin manager in how mono is handled.

 

Overall thinking is that some default settings in Cakewalk does not make optimal result on your system.

What a thorough and detailed response.  Thank you!

I'm always at 48KHz/24-bit/128 samples.  I use the Lynx ASIO driver that works with my soundcard.  I use two of eight stereo outputs and inputs on that interface.  All of my drives are SSDs.  My system crackles when the Cake resouce meters show the cores bouncing around 25%, and always fails when higher.  I did find that my CD/DVD port was causing latency, so I disable that when using Cakewalk (Latency Mon showed me that), but, again, no issues in any other DAWs.

I truly think Cake does something different in some ways that ends up being problematic for the audio engine.  Just years of experience with it amidst other products.  You make great points, though, as do others.

Share this post


Link to post
Share on other sites
9 hours ago, Bill Ruys said:

This was my thought too.  You have not told us what buffer settings you have set in CW.  It could well be that out of the box, CW used more aggressive buffer settings than your other software.  You need to tell us which driver mode (ASIO, WASAPI, etc) and what audio buffer settings you are using before anyone here can help.  Telling us that "as usual" the audio engine is not up to par and then leaving out probably the most important information is just going to rile people up (which I see, it already has).

We're here to help, but at least make a reasonable effort to help us help you before telling us the software we all use is not up to par.  Otherwise you kinda come off as a bit of a troll (which I'm sure you're not).

Bill, thank you.  Very diplomatic interaction!  Yes, my frustration bubbles a bit.  I've also done this for so long that I make the mistake that everyone knows that we veterans do everything right and know what we're doing!  Great cooperative spirit in your post, and exemplary of the best in community cooperation in these days of seeing much turmoil between souls.

Share this post


Link to post
Share on other sites

@Jon White I understand frustration when things dont work right, but you are making some pretty wild assumptions here.  Because something doesn't work as expected the problem isn't always the DAW.  DAW's live in a complex ecosystem of hardware, software, plugins and drivers.  We have thousands of users (including complete noob's) with no issues like what you describe.  This is not to say that the problem may not be in Cakewalk, but your troubleshooting so far isn't conclusive at all. Many plug-in and driver vendors test their stuff exclusively on Mac's, and perform poorly under certain conditions in Windows. They also choose to test in only a subset of DAW's out of familiarity or resource constraints. As a result a symptom that shows in one DAW may not show up in others depending on how the DAW communicates with the device. This doesn't automatically make it a DAW problem does it?

You mentioned using Lynx. Are you running their latest drivers? Very recently they had a bug with MMCSS which would cause major issues when the DAW had MMCSS enabled. I reported this and it was fixed by them. Turn off MMCSS in preferences and see if that  helps. If not, try playing the same project with a different audio interface (preferably USB) if you can find one. You can also use the onboard audio device for the test. If the problem goes away that would typically isolate the issue to the audio interface driver.  If you indeed find this, let us know and I can follow up with Lynx who we communicate with often. PS generally, don't use WASAPI mode with pro audio devices. Most pro audio drivers completely suck with WASAPI since they never test with it.

  • Like 3

Share this post


Link to post
Share on other sites

Hi Noel, and thank you for posting.  I've talked to Lynx, and you posted here as well to one of my posts a few months ago regarding this.  

I had the updated Lynx driver, but was confused as to which one of the "Enable MMCSS" toggles (or both) I should turn off, because both Cakewalk and Lynx offer the on/off option.  I called Lynx and asked and they said they did not know that Cakewalk had a toggle.

To make short of that story, if I have both of the new codes (yours and Lynx'), do I need to turn it off?  It's not a fatal issue like the posting you referenced, just a performance problem.  Are you pretty confident I can use it now?  I don't want to shut it off it it's supposed to work.  If it should be shut off, should I cut both the Cake and the Lynx toggles?

Also, again, it's the comparitive issues with Sonar/Cakewalk (to other software) that stands out here.  

 

Share this post


Link to post
Share on other sites

128 samples seems reasonable, depending on how large the project is.  Does the problem improve if you bump it up?  I would also add that DPC latency can cause crackle.  You might want to check it with the tool here: https://www.resplendence.com/latencymon

I had one occasion where the Asus AI Suite was generating high latency and this resulted in crackle during playback.  Killing it off completely fixed the problem.  CPU power saving can also cause crackling as the CPU steps through speed levels.  Setting your power profile to High Performance can resolve crackling issues if this is the problem.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...