Jump to content
jsg

Windows 10 and Fast Startup

Recommended Posts

I was having several problems after upgrading to Windows 10. Both involved drivers; an ethernet MIDI over LAN driver (ipMIDI and MIDI over LAN) and a MOTU microlite MIDI interface driver.

The culprit, I am 99% certain, is a feature called "fast startup", which I didn't know about as I was using Windows 7 for many years and this feature wasn't implemented until Windows 8.

After doing some online research I learned that this feature can cause problems with updates, drivers and other problems. If you go to your power settings in control panel, you'll see the function. Turn it off.

Power Options-Choose What the Power Buttons Do-Change settings that are currently available-uncheck fast startup.

If you find drivers are not loading correctly and if you do a restart (not shutting off the machine, just restarting) fixes the problem, it's most likely because of fast startup. Your boot time might increase by 1 second or so (no big deal) but your system will be stable and drivers will then load correctly from a cold boot.

Jerry

 

  • Thanks 1

Share this post


Link to post
Share on other sites

I've been looking into disabling this too as I occasionally get a failed boot up with a black screen and cursor - I understand that this is a possible fix as it is possibly interfering with my graphics driver - though it has only been happening for a few months and usually occirs if I have been using the other profile on my PC and switch back to my main one. It always restarts ok when I force a restart but a bit of a pain. Interesting it only takes a second or so longer to boot if you disable it

Share this post


Link to post
Share on other sites

True, the time saved, only a second or two, is definitely not worth having an unstable system.  I found that 2 of the 3 problems I was having are now resolved simply by turning off fast startup.

The problem of Sonar getting stuck in memory also seems to be resolved by turning fast startup off, but not 100% sure,  I'll know more in a week or so but so far so good.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the heads up about "fast startup."  I have an older version of Windows 10, so perhaps I don't have a setting for that. Not sure its related, but I did find my Power Options > High Performance was set to Allow Hybrid Sleep = On.  Not sure what that does (more research needed).

image.png.775015518f94e548c8ec37bb03674f93.png

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...