Jump to content
Gill20

can the sensitivity of the SMART grid be adjusted

Recommended Posts

This discussion has introduced me to this "Secondary Snap" idea. HOWEVER, I can not get it to engage.

Whenever I press and hold the N key it simply machine-gun toggles snap on and off many times while I hold it. I can't even move my mouse in order to go to the module to choose secondary settings while holding N down(or any key for that matter).

How is this accomplished?

Share this post


Link to post
Share on other sites

Hmmm... I had forgotten about the 'hold N' gesture, but it works here. Possibly you have a 3rd-party/wireless keyboard driver that's generating the repeat...?

The alternative is to use Ctrl+Shift+N, or bind some other shortcut to 'Swap primary and secondary snap settings' in Global Bindings.

Share this post


Link to post
Share on other sites
31 minutes ago, David Baay said:

Hmmm... I had forgotten about the 'hold N' gesture, but it works here. Possibly you have a 3rd-party/wireless keyboard driver that's generating the repeat...?

The alternative is to use Ctrl+Shift+N, or bind some other shortcut to 'Swap primary and secondary snap settings' in Global Bindings.

Nope. No Third party keyboard driver here. Just standard Windows 10 on a laptop.

Ctrl-Shift-N seems to be for switching between Primary and Secondary. But in order to set it up to begin with, you are meant to press and hold N, then drag the mouse to Snap module for choosing those secondary settings, then release the N.

Pressing N, or any key, and holding is just the same as pressing the key repeatedly over and over, however. It is this way on every computer keyboard I've ever worked on...  So it just toggles the Snap function on and off quickly and repeatedly.

Does it not do that for you?

Share this post


Link to post
Share on other sites
5 hours ago, winkpain said:

But in order to set it up to begin with, you are meant to press and hold N, then drag the mouse to Snap module for choosing those secondary settings, then release the N.

Not sure where you're getting that. Just right-click the snap value and choose the one you want. then Ctrl+Shift+N, and choose value for the other setting.

5 hours ago, winkpain said:

Does it not do that for you?

No, that's why I asked about your keyboard driver. I just checked, and Ctrl+Shift+N does continue to alternate between primary and secondary snap, but N (enable/disable snap) does not.

Share this post


Link to post
Share on other sites
Posted (edited)
14 hours ago, David Baay said:

Not sure where you're getting that. Just right-click the snap value and choose the one you want. then Ctrl+Shift+N, and choose value for the other setting.

Right-clicking the Snap value and choosing sets the Primary snap value. This functions as normal.

Pressing N, for me ,toggles Snap (primary, I assume) on and off, as it should. Ctrl-Shift-N does apparently nothing, for me. But then I don't have a Secondary value set-up, which in order to do, it says in the manual (page 317 in downloaded Cakewalk Reference pdf):

"To assign the secondary Snap to Grid settings, hold down the N key while selecting the desired snap settings in the Control Bar’s
Snap module.

To momentarily apply the secondary Snap to Grid resolution, hold down the N key while dragging or editing data that is snapping to
the grid. When the N key is released, the main global snap settings are restored.
To swap the primary and secondary Snap to Grid settings, press CTRL+SHIFT+N.

Note: To enable/disable Snap to Grid, press the N key quickly. To assign or use the secondary Snap to Grid resolution, keep
the N key pressed
"

 

Don't know what to say about keyboard driver. It's the default Standard PS/2 Microsoft keyboard driver. And I was curious if, for you, pressing and holding a key did not make it repeat as long as you held it down. I don't how to make it not do that, on any computer.

And I suppose I'm more curious how you get into the choosing of the Secondary Snap settings if not by pressing and holding N, which is the only way the manual mentions to do so....

 

 

Edited by winkpain

Share this post


Link to post
Share on other sites

... Anyone else out there who has success or not with using the above mentioned "Secondary Snap" set-up procedure and usage??

I just can't get it working.

Share this post


Link to post
Share on other sites

I got the Ref. Guide method to work once, but on subsequent attempts to change the value while holding N, the button did not respond to right-clicking to get the dropdown list. Also the mouse pointer stops responding to movement intermittently. That looks like a bug.

But the method I outlined of simply switching to the secondary snap value with Ctrl+Shift+N and changing it works fine. 

Holding N to temporarily get the secondary snap value with snap enabled also works, but I continue to have the mouse pointer become intermittently unresponsive while holding N which renders it largely unusable.

Share this post


Link to post
Share on other sites
1 hour ago, David Baay said:

I got the Ref. Guide method to work once, but on subsequent attempts to change the value while holding N, the button did not respond to right-clicking to get the dropdown list. Also the mouse pointer stops responding to movement intermittently. That looks like a bug.

But the method I outlined of simply switching to the secondary snap value with Ctrl+Shift+N and changing it works fine. 

Holding N to temporarily get the secondary snap value with snap enabled also works, but I continue to have the mouse pointer become intermittently unresponsive while holding N which renders it largely unusable.

Interesting. So you got it to work once so you could set up the secondary settings in the "official" way?

Tell me, don't you find that pressing and holding any key will stop the mouse from working?  That is how it is for me. Pressing and holding any key will repeatedly toggle whatever function (if any) is bound to it as long as I hold it and the mouse will not respond at all while doing so. I'm not sure if this is a bug 'tho, because it is exactly how the keyboard/mouse functions in any other program I run as well - holding a key repeats that key and mouse functions cease while doing so.

Unless.... CW is meant to bypass somehow this otherwise "normal" keyboard/mouse protocol to allow for these special functions? And it is not doing so for me. 

An interesting clue, perhaps, is that in the video I've attached here to try and show what happens when I press Ctrl-Shift-N (nothing), and then press and hold N (repeated toggle of Snap), my keyboard keystrokes, which are set to be indicated in the lower left corner of the video do not display when I'm capturing from CbB. My keystrokes DO display when recording from any other program.

Again, I have the default keyboard/mouse drivers installed with Windows 10 on an HP laptop and no 3rd party keyboard/mouse apps, and a fresh (one day old now) re-install of CbB.

I think this is one for Bakers' support....

Share this post


Link to post
Share on other sites
51 minutes ago, winkpain said:

Tell me, don't you find that pressing and holding any key will stop the mouse from working?  That is how it is for me. Pressing and holding any key will repeatedly toggle whatever function (if any) is bound to it as long as I hold it and the mouse will not respond at all while doing so. I'm not sure if this is a bug 'tho, because it is exactly how the keyboard/mouse functions in any other program I run as well - holding a key repeats that key and mouse functions cease while doing so.

Unless.... CW is meant to bypass somehow this otherwise "normal" keyboard/mouse protocol to allow for these special functions? And it is not doing so for me. 

It's very dependent on how the application is programmed.  For example, in Wordpad, I can hold a letter key down and enable/disable the italics button in the ribbon bar while it's repeating, and the font will  change as expected.

It seems clear the the Bakers programmed the primary-secondary 'temporary swap' function to ignore key repeats, and it does for me. But something's gone wrong with the right-click functionality to present the resolution dropdown.

Share this post


Link to post
Share on other sites

I still don't use these features, but I am trying to understand them because maybe then I might use them.  

The other day I tried David's sample project and I was able to shift between two states that had different duration lines in Track View.  Today, I tried to create my own toggle states. Toggling between two states seems to work for me and seems to work whether I have Snap on or off.  It also seems to me that the toggle not only switches between two resolutions, but between the Snap On/Off state. As well, the Note Draw Duration toggles between two states. Evidently the To/By Snap State also toggles.

Last week (before I did this), I tested both Workspaces and Screensets. I just tested them again (just now) and it seems that the two states change regardless of Workspace or Screenset unless I didn't do it right. However, it seems to me that the two states (current and secondary) were saved with my test project.

I am not sure how this was different in other versions.

So, if my understanding (as I have written it up here) consistent with that others are seeing?  Or am I missing something regarding this Ctrl+Shift+N toggling feature?  For example, are there other things that get toggled?  

Still not sure if I will use this feature; just trying to understand it.  Thanks.

 

image.png.1dcf7920ec685c312270837d7c42dae0.png 

 

Share this post


Link to post
Share on other sites

And I wish now that I hadn't learned about this feature, because I would very much like to use it 😉  but am prevented from doing so.

1 hour ago, User 905133 said:

Today, I tried to create my own toggle states. Toggling between two states seems to work for me and seems to work whether I have Snap on or off.

How were you able to create your own toggle states, I wonder. Did the pressing and holding N while mousing to the settings and choosing work for you?

And, on a lighter note, how did you get "Engineered in Boston" to show on your tool module??

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, winkpain said:

And I wish now that I hadn't learned about this feature, because I would very much like to use it 😉  but am prevented from doing so.

How were you able to create your own toggle states, I wonder. Did the pressing and holding N while mousing to the settings and choosing work for you?

And, on a lighter note, how did you get "Engineered in Boston" to show on your tool module??

I was afraid someone was going to ask how I managed to get the second state in the first place!  I got so into figuring out the other things, I forgot how I got to state 2!

2 hours ago, winkpain said:

How were you able to create your own toggle states, I wonder.

Just now, when I opened  up a New Project (either "Blank" or "Empty," Ctrl+Shift+N allowed me to toggle.  Not sure I did anything special. (With my previous post, I did the tests with a tune-in-progress.)

2 hours ago, winkpain said:

Did the pressing and holding N while mousing to the settings and choosing work for you?

I did not try using the mouse yet, but I did manage to figure out the non-repeating key issue--it repeats in Notepad (for example), but not here (Cakewalk). As these screen shots show (I hope), (1) I opened a project with Snap off. (2) When I initially pressed N, Cakewalk turned Snap on. (3) After about a second while holding N down, the alternate settings showed up temporarily.  

image.thumb.png.7d4ca4ab60ad9eed861dd32172682aec.png

2 hours ago, winkpain said:

And, on a lighter note, how did you get "Engineered in Boston" to show on your tool module??

Yeah--I noticed that Engineered in Boston, MA!  My usual theme didn't show the track view snap lines very well, so I looked for others, and grabbed Boston Flowers!  Perfect for the spring time!

----------------------------------------------------------------------------------------------------------

Clarification 1: Ctrl+Shift+N seems to swap two snap/grid states on a non-temporary basis. (Let's call them "State A" and "State B" for now.)

Upon rebooting a saved project, "State A" becomes the state the project was saved with if the project was re-saved.   

----------------------------------------------------------------------------------------------------------

Clarification 2: "N Held Down" seems to be a temporary state. [See screen shot (3) above.]

So the Initial N press turned Snap On. [See screen shot (2) above.]

Holding N down for more than 1.225 seconds gave me State B temporarily.  [See screen shot (3) above.]

Releasing N returned to State A. [See screen shot (2) above.]

----------------------------------------------------------------------------------------------------------

 

Edited by User 905133
(2) to reformat and rephrase the post; (1) to add an edit re: toggling states

Share this post


Link to post
Share on other sites
18 minutes ago, User 905133 said:

I did manage to figure out the non-repeating key issue. It repeats in Notepad (for example), but not here (Cakewalk).  

What did you figure out by this? Or do you mean you just noticed those differences but had no influence on it yourself?

Are you also on Windows 10?  I wonder if these repeated keystrokes when holding key down behaves differently in different OS versions, or...... something

And then (sorry for all the pesky questions!)  you say "Ctrl+Shift+N allowed me to toggle. " but then in your image (3) it seems that you're saying N Held Down is toggling the Secondary snap. Or is it just temporarily activating Secondary snap only while you hold it?

And can you move your mouse while holding the N down??

Share this post


Link to post
Share on other sites

Good questions!

1 minute ago, winkpain said:
31 minutes ago, User 905133 said:

I did manage to figure out the non-repeating key issue. It repeats in Notepad (for example), but not here (Cakewalk).  

What did you figure out by this? Or do you mean you just noticed those differences but had no influence on it yourself?

Earlier (a few days ago), I tested whether or not all keys on my Windows 10 PC repeated in programs such as Notepad. They did--when held down. Today, after re-reading parts of the thread, I specifically looked at the discussion points raised, including what what happens when the N is held down.  So for me it was a personal discovery that Cakewalk (at least on my PC) treats the N being held down as meaning shift-to-alternate-snap/grid-settings (while being held down).  

So it was just a personal discovery; I did not change anything in Cakewalk or on my PC. Holding down N in a text space [such as here] does this: NNNNNNNNNNN. 

1 minute ago, winkpain said:

Are you also on Windows 10?  I wonder if these repeated keystrokes when holding key down behaves differently in different OS versions, or...... something

I am on a desktop PC with Windows 10 (1809). I have not tried this on my laptop. Not sure if I have some special setting (Ease of Access, Sticky Keys, etc.) that affects this.

1 minute ago, winkpain said:

And then (sorry for all the pesky questions!)  you say "Ctrl+Shift+N allowed me to toggle. " but then in your image (3) it seems that you're saying N Held Down is toggling the Secondary snap. Or is it just temporarily activating Secondary snap only while you hold it?

Sorry about the confusion.  I started to make a spreadsheet based on what the Reference Guide said, but got into the various tests instead of laying it out more clearly in a spreadsheet.

The (1), (2), (3) picture just relate to the use of N, not Ctrl+Shift+N.  Putting the "EDIT:" section where I did was not a good place.  (I was originally going to use a footnote. I will fix that. 

1 minute ago, winkpain said:

And can you move your mouse while holding the N down??

Yes.  I just tested by resizing track widths, sliding around clips, and a few other things that worked. However, trying to change Workspaces while  while holding the N down caused my cursor to rapidly go through all my Workspaces starting with N.  

 

Share this post


Link to post
Share on other sites
59 minutes ago, winkpain said:

And then (sorry for all the pesky questions!)  you say "Ctrl+Shift+N allowed me to toggle. " but then in your image (3) it seems that you're saying N Held Down is toggling the Secondary snap. Or is it just temporarily activating Secondary snap only while you hold it?

And can you move your mouse while holding the N down??

You gotta give up on holding N and changing the secondary setting; I think we've confirmed it casues isues with mouse pointing and clicking.

Just switch to the secondary setting by hitting Ctrl+Shift+N (briefly, not held). Then set the resolution as usual by right-clicking, Then you can toggle between the two settings by Ctrl+Shift+N. I don't usually use 'B' to open the browser, so I assigned that to swap them since it's conveniently right next to N.

  • Like 2

Share this post


Link to post
Share on other sites
30 minutes ago, David Baay said:

You gotta give up on holding N and changing the secondary setting; I think we've confirmed it casues isues with mouse pointing and clicking.

Ain't that the truth! Thanks for the splash of cold water!

I just got pulled into it, cuz, well, the manual says it so many times....

Share this post


Link to post
Share on other sites
Posted (edited)

.....However! And Holy Bejeweled Mother of Fudge! For those of you following my, apparently private saga, bless your little hearts!.....

I seem to have gotten somewhere - and it doesn't have to do with Workspaces for once! This virus quarantine solo cabin fever workflow makes one dive deep!

 

In order to have a clean slate to troubleshoot with, and inspired by @User 905133's tenacity in sharing my woe,  I opened New>Empty project, set Workspaces (just to be sure) to None, and (here's the kicker!), zapped all in my Preferences>Customization>Keyboard shortcuts (or Key Bindings) in order to have a clean slate there as well.

And this last thing is what shed the scales from my eyes! I have run into problems before with Key Bindings and am surprised that I didn't think of this before now.

Simply put, Cakewalk allows you (mistakenly, I would say) to bind the same keystrokes to multiple functions as well as having a single function bound to multiple keystrokes! Doing so causes no end of confusion and wasted time. I have been through this before and spent literally days going through my decade-long built up custom bindings and eradicating (or so I thought) all the double (or even triple) binds to try and deal with that problem back then. Since there are multiple context windows to go through with many functions and many many key combinations,  it takes quite a while.  Perhaps a better approach would be simply Zapping All and starting all over again, but as I say, years of custom bindings that are now so ingrained...

I wished (and requested) then and I wish even more now that CW would simply not allow you to create multiples of any of these bindings/functions, or at least warn you that you are about to do so. This is the way it is, after all, in other programs, so it seems an oversight.

 

Anyway, with the Keyboard Shortcuts settings it would appear that IF you should happen to bind N to anything anywhere else in all the different contexts, and despite its still being bound to and successfully  functioning as the Snap on/off toggle, the keystroke looses what I now see is called its "Toggle Extended" status, which seems to account for its ability to be held down without repeating its action. And IF you should happen to to bind Ctrl-Shift-N to anything anywhere else in all the different contexts it will cease functioning as the Secondary Snap toggle even though it still shows that it is bound to that function.  Both of these things I had done at some point over the years and both of these things exactly cause the issue I have been brooding on about here!

So sorry!

Now I have a functioning Secondary Snap Scenario! Although while the over-mentioned holding down of the N key no longer repeats its toggling action over and over,  neither does it allow anything else to be done with mouse or otherwise. This last point seems to be the case on laptops using recent Synaptics touchpad drivers which don't allow simultaneous keyboard and touchpad use, or in other words won't let "Smart Sense" be turned off completely.

For me now Ctrl-Shift-N successfully toggles between two Snaps where I can just make any settings in the normal way once in each of the alternates, and that is what maintains. There is no indication that you are in a "Primary" or "Secondary" snap however, so it is technically possible to have the exact same settings in each and not know that you are in the alternate. Toggling will show no difference in this case. Once I got Ctrl-Shift-N working, the default for the second snap was at "1 tick", so it was definitely obvious.

Thanks all for bearing with me!

 

 

Edited by winkpain
new info
  • Like 1

Share this post


Link to post
Share on other sites

Glad you got it figured. I did briefly wonder whether you had non-standard bindings in that area, but figured that was the first place you would have looked if you were big into custom bindings. I tend to leave mine default unless it's something I use frequently that requires a lot of modifiers or an awkward one-handed reach, or I'm restoring some long-time binding that the Bakers changed. 

  • Great Idea 2

Share this post


Link to post
Share on other sites
5 hours ago, David Baay said:

Glad you got it figured. I did briefly wonder whether you had non-standard bindings in that area, but figured that was the first place you would have looked if you were big into custom bindings. I tend to leave mine default unless it's something I use frequently that requires a lot of modifiers or an awkward one-handed reach, or I'm restoring some long-time binding that the Bakers changed. 

Yeah, I feel a little slow for not copping to that at first as well, especially since I've been through a similar thing before. I did check the key bindings right off but found N and Ctrl-Shift-N to have the appropriate default bindings. It's just that they had, at some point, gotten bound to additional  commands in different contexts, which is enough to knock it all off kilter.  The multiple bindings don't make themselves clear unless you really comb through the menus and hunt them down.

For me custom bindings are an absolute workflow game-changer and the basic defaults are never sufficient. But even still, I see no reason at all to have more than one binding to the same command or vice-versa, and it causes such turmoil. Further reason why there should be a stop gap to prevent such a set-up.

For sure, though, the protocol to chase down CbB issues at this point should always begin with setting Workspaces to "none" (this seems to be #1 now), zapping all key bindings, and by-passing all FX while you're at it, and then begin to troubleshoot.

Share this post


Link to post
Share on other sites

Not sure why but CbB binds certain keys to functions but does not always show them as bound in Preferences.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...