Jump to content
Andy Drudy

Exported track appear to boost gain.

Recommended Posts

Hi,

When I export tracks, there seems to be a 3-4 db gain boost. I am exporting individual tracks. The fader reads 0.0, the gain reads 0.0, and the master fader bus reads 0.0. However when I open the exported track into Sound Forge, the track is peaking. I cannot see where there is any gain staging. There are no additional busses. No effects. Nothing. I am using every available option in the drop down box. I would have assumed "raw tracks" would have exported the track in its raw form, but it appears to boost the gain.

 

This is driving me nuts!

 

A

 

  • Like 1

Share this post


Link to post
Share on other sites

Do you export to identical word length and sample rate?

If your tracks are really hitting 0dBFS (which they shouldn't until you want a master for physical CDs, you may have inter-sample peaks. Cakewalk's meters aren't True Peak so they show only the sample level, not the reconstructed analog signal meter. There's a free TP meter at youlean (and many others), if you place it on the master bus you will see if you have IS peaks or not.

Share this post


Link to post
Share on other sites
Posted (edited)
19 hours ago, Bristol_Jonesey said:

What options are you choosing in the Export dialog?

How may pairs of outputs are routed out of your interface?

I have tried all of them an get the same result. I only route to two outputs to my MOTU 828Mk3 (or a steree pair)

Edited by Andy Drudy

Share this post


Link to post
Share on other sites
9 hours ago, Andy Drudy said:

I have tried all of them an get the same result. I only route to two outputs to my MOTU 828Mk3 (or a steree pair)

I admit to not knowing anything about MOTUs, but with all the interfaces I have used, none had mono outputs. I suppose there could have been a setting in their software to switch between mono and stereo, but I never looked.

Are you sure that these aren't stereo outputs being summed to a higher dB than your master bus is showing?

Share this post


Link to post
Share on other sites

Your audio interface plays no role in exports, unless you're using external inserts.

First thing I'd do is import one of those files back into the project and verify that its level has really changed, as opposed to being altered by SoundForge. 

Just to be sure, you're exporting these tracks as 24- or 32-bit wave files, right? 

Share this post


Link to post
Share on other sites
14 hours ago, bitflipper said:

Your audio interface plays no role in exports, unless you're using external inserts.

First thing I'd do is import one of those files back into the project and verify that its level has really changed, as opposed to being altered by SoundForge. 

Just to be sure, you're exporting these tracks as 24- or 32-bit wave files, right? 

Hi,

Yes, I did that. I exported out and then imported to a new track to verify. And yes, the 3db boost was still there. I am using 24bit. Wave files.

I wasn't sure if the audio interface played any part, so thanks for that.

I cannot understand it. There are no effects in this project. All faders are set to 0.0. Track and master. Pro channel is turned off.

It makes no sense..

A

 

 

Share this post


Link to post
Share on other sites
16 hours ago, 57Gregy said:

I admit to not knowing anything about MOTUs, but with all the interfaces I have used, none had mono outputs. I suppose there could have been a setting in their software to switch between mono and stereo, but I never looked.

Are you sure that these aren't stereo outputs being summed to a higher dB than your master bus is showing?

Hi,

No, mono track exported to mono wav files.

Share this post


Link to post
Share on other sites
On 3/12/2020 at 2:02 PM, Andy Drudy said:

This is driving me nuts!

Me too!

Working with mono tracks is sometimes very cumbersome in CbB. I have especially problems with virtual instruments that output to a mono audio track (e.g. bass). If you look at the peak during play, it is sometimes completely different when frozen and then when you export anyway! If you copy the frozen audio to a new audio mono track, then the export is no more +3dB, very strange! To me it is not transparent anymore in what case there is a +3dB gain!

So I had invested some time in creating a sample project that shows the troubles and sent it to the support in December. They said they have logged it for review/changes and I still hope it is being fixed one day! 😄

Share this post


Link to post
Share on other sites
Posted (edited)

I've run into this problem before and brought it up many times, IIRC it has to do with the interaction of CbB being inherently stereo so it treats mono as existing in both channels, then sums as it exports. I've found four solutions.

1. Don't use the export function. Instead, drag the file into the desired folder in the browser.

2. Drop the Gain by -3 dB before exporting.

3. Export the mono file as stereo (although of course then you end up with a stereo file)

4. Export as Split Mono. This creates two mono files, just delete one of them.

Edited by Craig Anderton
  • Like 1
  • Great Idea 1

Share this post


Link to post
Share on other sites

I'm not sure this part is correct: "In summary, whenever the track output interleave is mono and the data interleave is stereo, mono data will be increased in level by 3 dB."  I've had mono samples in a track with mono interleave, and the level increase still happens when exported, but not when dragged into the Browser.

  • Like 1

Share this post


Link to post
Share on other sites
13 minutes ago, Craig Anderton said:

I'm not sure this part is correct: "In summary, whenever the track output interleave is mono and the data interleave is stereo, mono data will be increased in level by 3 dB."  I've had mono samples in a track with mono interleave, and the level increase still happens when exported, but not when dragged into the Browser.

Thanks Craig. That is most helpful. I will investigate that tomorrow. I cannot tell you how much this is driving me around the bend.

Share this post


Link to post
Share on other sites
3 hours ago, marled said:

Me too!

Working with mono tracks is sometimes very cumbersome in CbB. I have especially problems with virtual instruments that output to a mono audio track (e.g. bass). If you look at the peak during play, it is sometimes completely different when frozen and then when you export anyway! If you copy the frozen audio to a new audio mono track, then the export is no more +3dB, very strange! To me it is not transparent anymore in what case there is a +3dB gain!

So I had invested some time in creating a sample project that shows the troubles and sent it to the support in December. They said they have logged it for review/changes and I still hope it is being fixed one day! 😄

Ahh. So I'm not alone! That makes me feel a little better. It feels like some kind of bug to me.

Share this post


Link to post
Share on other sites
3 hours ago, Craig Anderton said:

I've run into this problem before and brought it up many times, IIRC it has to do with the interaction of CbB being inherently stereo so it treats mono as existing in both channels, then sums as it exports. I've found four solutions.

1. Don't use the export function. Instead, drag the file into the desired folder in the browser.

2. Drop the Gain by -3 dB before exporting.

3. Export the mono file as stereo (although of course then you end up with a stereo file)

4. Export as Split Mono. This creates two mono files, just delete one of them.

1. Don't use the export function. Instead, drag the file into the desired folder in the browser.

 

I had no idea you could do that!!! But still louder.

Share this post


Link to post
Share on other sites
24 minutes ago, Craig Anderton said:

I'm not sure this part is correct: "In summary, whenever the track output interleave is mono and the data interleave is stereo, mono data will be increased in level by 3 dB."  I've had mono samples in a track with mono interleave, and the level increase still happens when exported, but not when dragged into the Browser.

BINGO!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

When you export as a stereo file, the gain remains as I recorded it!!! However it is now a stereo file.

When I select "Split mono" in the channel Format drop down box, it delivers 2 mono channels at the original gain.

 

Many thanks for taking the time to repond my friend.  You saving me from insanity!

Share this post


Link to post
Share on other sites
Posted (edited)
16 hours ago, Craig Anderton said:

The track interleave needs to be mono when you do this. If it's set to stereo, yes, the dragged file will be louder.

The Browser can do all kinds of cool stuff. There are several tips in The Huge Book of Cakewalk by BandLab Tips, as well as in my  Sound on Sound column.

Blimey. I didn't even know such a thing as the "track interleave button" existed or what it does!!

Did as you said and YES it worked. The dragged file is  at the correct gain.

Many thanks. You are a font of knowledge. I will be buying your book!

Edited by Andy Drudy

Share this post


Link to post
Share on other sites

I'm curious - could any of this involve the Stereo Panning Law setting, from Preferences?  The mentioning of '3 db', in the above posts, made me wonder, so I thought I would ask. 

(I changed the Stereo Panning Law settings eons ago, from the default, to the -3dB center sin/cos taper, constant power setting, from some long ago tip from @Craig Anderton).

(and, just as general observation - I found some of the help doc on the Panning Law settings, a bit murky - for example, it indicates that the panning law settings are applied once for tracks, but it does not say when it actually does apply it ).

Here is some of the text from the Configuring Panning Laws doc:

"In the Stereo Panning Law field, choose one of these options:

(Default) 0dB center, sin/cos taper, constant power. This choice causes a 3 dB boost in a signal that’s panned hard left or right, and no dip in output level in either channel when the signal is center panned.

-3dB center, sin/cos taper, constant power. This choice causes no boost in a signal that’s panned hard left or right, and 3 dB dip in output level in either channel when the signal is center panned.

0dB center, square-root taper, constant power. This choice causes a 3 dB boost in a signal that’s panned hard left or right, and no dip in output level in either channel when the signal is center panned.

-3dB center, square root taper, constant power. This choice causes no boost in a signal that’s panned hard left or right, and 3 dB dip in output level in either channel when the signal is center panned.

-6dB center, linear taper. This choice causes no boost in a signal that’s panned hard left or right, and 6 dB dip in output level in either channel when the signal is center panned.

0 dB center, balance control. This choice causes no boost in a signal that’s panned hard left or right, and no dip in output level in either channel when the signal is center panned.

Pan Law compatibility mode

When using a non-default pan law with floating point or 24-bit audio, Cakewalk would previously apply the pan law twice; once at the clip level and once more at the track level.

In SONAR 8.5.2 and later, pan laws are only applied once at the track level and only for mono tracks. Any clip pan envelopes will continue to work, but behave strictly as a balance control.

If you have existing projects that use a non-default pan law (i.e. other than 0dB center sin/cos taper), the mix might sound louder in Cakewalk. To address backwards compatibility with projects that were mixed in previous versions of SONAR, the following Aud.ini variable is available to set the pan law compatibility mode:

PanLawCompatMode=<0 or 1> (default=0)

This variable should be set in the [Wave] section. For example:

[Wave]

PanLawCompatMode=1

When the value is 0 (default), non-default pan laws are not applied at the clip level. Clip pan envelopes always use the 0dB center sin/cos taper law.

When the value is 1, pan laws are applied at the clip level. It is not recommended that you use this value unless you need to retain backwards compatibility with pre-SONAR projects that use a non-default pan law." 

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...