Jump to content
  • 0
Koyaanis

Problem with ASIO Drivers

Question

Hi guys,

I have a problem with ASIO Drivers and can't figure it out by myself..

I connected my Roland FP-7 Keyboard with an USB cable to my computer. It gets recognised and works with MME (32-Bit). But of course with a huge latency. So I switched to ASIO in Playback and Recording. Now I can no longer hear anything. I can see it recording, but no audio is played back.

Specs:

Windows 10, i7 3.6 GHz, RAM 16GB, Soundcard: Soundblaster Z (up to date drivers)

I attached some screenshots of the preferences tab

every help is very appreciated!

Koyaanis

Cakewalk preferences 1.png

Cakewalk preferences 2.png

Cakewalk preferences 3.png

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
Posted (edited)

Hi Koyaanis and welcome to the Cakewalk forums.

Are you playing your MIDI through a VSTi soft synth?  Is Input Echo on?  Are you using a single MIDI track, MIDI and Audio track or an Instrument track?  Is the output set to your Master Bus?  And, is your Master Bus output set to your ASIO output?

As long as your speakers are connected to the front outputs on your PC, your settings look correct (although, it appears you're not using the latest version of Cakewalk).

Kind regards,

tecknot

Edited by tecknot
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

Hi tecknot,

thank you for your response!

I'm playing  MIDI through a VSTi Soft synth, Input Echo is on. I tryed using single MIDI tracks and combined with Audio tracks. No difference. My output is set to Master (you might want to doublecheck on my attached screenshot. None of these options in the drop down menue got any results).

I'm using "behringer" speakers connected via USB and the latest Cakewalk version -at least it tells me

Kind regards, and thank you for your help,

Koyaanis

Cakewalk Master.png

Cakewalk Master preferences.png

Share this post


Link to post
Share on other sites
  • 0

May need to setup the Sound Blaster for stereo operation to use the ASIO Driver.

I believe this is done in the Sound Blaster Z-Series Control Panel software supplied with the card.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, scook said:

May need to setup the Sound Blaster for stereo operation to use the ASIO Driver.

I believe this is done in the Sound Blaster Z-Series Control Panel software supplied with the card.

Hi scook,

I tried every option in this panel, but none of them worked..

Sound Blaster Tab.png

Share this post


Link to post
Share on other sites
  • 0

I have never owned any Creative Software devices so I can only suggest solutions based on info provided in other threads.

Stereo Direct has been reported before as a problem. The Stereo (2.0/2.1) is likely the one to choose.

There have been problems reported with 64bit drivers in the past. I do not know if they were ever resolved.

IIRC, SB used to default to 48kHz sample rate. Make sure Windows and CbB are set to the same sample rate. May want to experiment with setting both to 48kHz.

As an alternative, try WASAPI then WDM driver modes in CbB. If they don't work or prove unsatisfactory try ASIO4All. I would uninstall the factory ASIO driver before installing ASIO4All.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

I'm not quite sure what happend, but I think since I've set my speakers to 48kHz I no longer have any latency with MME 32-Bit. I guess this was the fix I needed. Strangely without ASIO

Thank you very much @scookand @tecknot for your time and help!!

stay healthy
Koyaanis

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...