Jump to content
Benjamin Huang

Midi input triggered but no sound?

Recommended Posts

Hi,

Relative midi noob here, but today I pulled up my Sonar professional and my midi keyboard inputs are not longer triggering the sounds on my instrument tracks (Omnisphere, sessiondrummer, etc.).   My midi keyboard is checked in the preferences, input in instrument track is using all Omni (tried changing that to my specific keyboard with no difference).  What's odd is that in the step sequencer view in those instrument tracks, it senses my midi keyboard inputs.  For example I have F#3 key assigned to hi-hats, and when I manually fill in the steps with my mouse it triggers the sound and plays back normally, when I press F#3 key on my keyboard it shows the little green light in the step sequencer as if it recognizes the input command, but no sound.

Must be something really dumb I accidentally changed.. any help appreciate!!  

Share this post


Link to post
Share on other sites

All I can suggest is to double check that you have input echo enabled on the track you have selected so that the midi notes are "echoed" through the midi track to the instrument. If you can add midi notes manually to the PRV or Step Sequencer and the instrument is heard then that connection seems to be correct.

  • Like 1

Share this post


Link to post
Share on other sites
On 2/9/2020 at 4:31 PM, Benjamin Huang said:

Hi,

Relative midi noob here, but today I pulled up my Sonar professional and my midi keyboard inputs are not longer triggering the sounds on my instrument tracks (Omnisphere, sessiondrummer, etc.).   My midi keyboard is checked in the preferences, input in instrument track is using all Omni (tried changing that to my specific keyboard with no difference).  What's odd is that in the step sequencer view in those instrument tracks, it senses my midi keyboard inputs.  For example I have F#3 key assigned to hi-hats, and when I manually fill in the steps with my mouse it triggers the sound and plays back normally, when I press F#3 key on my keyboard it shows the little green light in the step sequencer as if it recognizes the input command, but no sound.

Must be something really dumb I accidentally changed.. any help appreciate!!  

Ben, what I found is that if you go into Cakewalk and don't have your sound system on first, it doesn't recognize that you have turned it on after you go into Cakewalk. That was my problem. Maybe this will help.   Rick

  • Like 1

Share this post


Link to post
Share on other sites

So if you have a separate midi track from the synth track (I recommend this), you see level on the midi track bouncing but no level on the track with the synth on it...

Then I recommend checking properties > Midi > control surfaces and make sure no surfaces are checked. This will route the midi to the controller not to the instrument track you thought you were routing it to.

  • Like 2

Share this post


Link to post
Share on other sites

Is it possible that you have changed which USB-connected devices are connected to which USB ports on the computer?

You could try:

1) In the project having this issue, go into Preferences > MIDI > Devices > and uncheck that midi keyboard from Input Devices and Output Devices, and click on Apply.

2) Then save the project, and close the project and open it again.

3) Now, go back into Preferences > MIDI > Devices, and check the boxes to add that midi keyboard back in as an Input Device and as an Output Device, and click on Apply.

4) Then, if you can hear notes triggered by the midi keyboard, Save the project again, and you will hopefully be back in business. 

Bob Bone 

  • Like 1

Share this post


Link to post
Share on other sites

 

3 hours ago, Gswitz said:

So if you have a separate midi track from the synth track (I recommend this), you see level on the midi track bouncing but no level on the track with the synth on it...

Then I recommend checking properties > Midi > control surfaces and make sure no surfaces are checked. This will route the midi to the controller not to the instrument track you thought you were routing it to.

Thanks all for the help!! Gswitz got it right.  It was routing to the controller.  Once I deleted that from the Midi menus it worked again. 

SI thought the keyboard was meant to be both a control surface (has transpose commands on here like play stop pause etc), so how can I have it be a control surface and a instrument keyboard??

  • Like 1

Share this post


Link to post
Share on other sites

I can't specifically answer the question, but I can say that I have a Nektar MIDI keyboard that has faders and transport controls, and the only way it can work as both a MIDI controller and a DAW controller is to install a specific driver. So you might check with the manufacturer of your keyboard and see if there is such a driver for it.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...