Jump to content
Robert Bone

Virtual Controller Resize

Recommended Posts

OK - I have two cats trapping me in my bed, whilst I run through a bunch of software installs - plugins, mostly, and so I cannot currently play notes on my not-as-handy-as-it-was-supposed-to-be midi controller.

This being the case, and the cats being too cute and cuddly to vanquish, I am using the CbB built-in Virtual Controller, for the 1st time, to allow me to sound some notes on the new Hybrid Synth plugin I just installed.  To do this, I assigned the Virtual Controller as the midi Input device in the midi track for the synth, in Track Inspector.

I then clicked on View > Virtual Controllers > Piano Keyboard, and as expected, got the pop-up window with the Piano Keyboard.

Problem - the window size is not large enough to properly display the Piano Keyboard.  I have not thus far been able to figure out how to resize the window to display all the controls and the correct number of octaves.  I will paste in a screen clip of the entire window, in all of its glorious smallness.

Anybody know how I can get this to display properly?

Thanks - Bob Bone - picture below:

image.png.58a74352644fd612f596c5f98a97a695.png

Share this post


Link to post
Share on other sites

Yours looks very different from mine.  Is your display at 100%? I ask because the "Hold" lettering and the computer keyboard seem magnified while the lower keyboard seems distorted.  Not sure if there are ways to change display settings within Cakewalk

image.png.ad2c01150a93dd9a9029754b530ea5a9.png

Edited by User 905133

Share this post


Link to post
Share on other sites

UPDATE - 3840 x 2160 (Recommended) Scale of text, apps, and other items is set to 200%

It seems my scale alteration to make text and such appear at 200% seems to have not been gracefully handled by the CbB automatic sizing of the displayed Piano Keyboard for the Virtual Controller.

When I changed the Windows Scale size back to 100%, then went back into CbB and closed/opened the Virtual Controller Piano Keyboard, it properly displayed, although it is absolutely unusable at that size, on my HDTV.

Because I am disabled, I spend large numbers of hours in bed, I use a 65" HDTV as a computer display monitor, at the foot of the bed, and this allows me to do a lot of CbB work while more comfortably positioned then my sitting in my office chair.

Because I use the recommended Display Setting resolution of 3840 x 2160, all text and icons and well, everything, shown on the screen at that resolution is WAY beyond too tiny to be usable, so I bump up the Scale to 200% and everything is wonderfully visible and usable.  Until now, that is.

Do I have to vanquish the cats and move to the office chair, and use a different HDTV with a smaller resolution to get the Piano Keyboard window to auto-detect a size that works for it, in CbB?

OR, do I have to find some other resolution for Windows, where I do not need to change the Scale to 200%?

OR, is this something the Cakewalk tech support folks can tweak?

Bob Bone

Share this post


Link to post
Share on other sites
3 minutes ago, User 905133 said:

Yours looks very different from mine.  Is your display at 100%? I ask because the "Hold" lettering and the computer keyboard seem magnified while the lower keyboard seems distorted.  Not sure if there are ways to change display settings within Cakewalk

image.png.ad2c01150a93dd9a9029754b530ea5a9.png

I was finishing up typing my update post, when yours posted.  The issue seems to be caused by my changing the Windows resolution settings page's Scale size from its normal 100% up to a value of 200%, because I use a giant HDTV, and its recommended Resolution setting of 3840 x 2160 then renders all icons, text, and everything else, far too small for me to use.  

CbB seems to lose its mind, when it auto-detects the display size of the window it generates to display the Piano Keyboard, and that is where it is at, at this point.

SO - looks like I have to kick the cats out of bed, and move to use a different HDTV I have set up next to my real midi controller used for recording, or muck around with trying to find a Windows screen resolution setting where I don't have to change the Scale value to 200% of normal.

Bummer

Bob Bone

Share this post


Link to post
Share on other sites

I was testing different display settings when your posts came in. The max I can do it 175%, which shows some distortions, though not as bad as yours.  I looked in the theme editor quickly and did not see any images to tweak that might help. Maybe there is a third-party virtual keyboard plug-in that can be resized?

Hope you can find a solution that works for you; I can relate to needing workarounds for vision issues.

 

Share this post


Link to post
Share on other sites

Well, I went to the Display Settings (right-clicked on Desktop, then clicked on Screen Resolution), and displayed the choices.

The recommended resolution is at noted above, 3840 x 2160, which is why I had to bump up the Scale to 200%.

When I left it at that resolution, but reduced Scale back to 100%, then even though nothing was of a usable size, the Piano Keyboard DID display properly then, but the entire screen was too small to be able to do anything at all.

SO, the displayed alternative resolutions included one that was precisely HALF of the recommended resolution - 1920 x 1080, and that seemed reasonable, even medicated, I can divide by 2, and that should be the instant solution to my woes.

Not the case.

With the screen resolution set to 1920 x 1080, and the Scale set to 100%, even after logging off of Windows and logging back in, then opening a brand new CbB project, inserting a soft synth, assigning the midi input to use Omni mode of the Virtual Controller, when I then clicked on View > Virtual Controllers > Piano Keyboard, it STILL displays like that messed up image I had posted originally, with the incorrect displayed octaves, and not all controls displayed, etc....

SOOOOO - Support Folks - I will open a ticket, and supply all the details, and perhaps someone could take a look at tweaking the auto-display logic for the Piano Keyboard window for Virtual Controllers, it does not appear to properly auto-detect at a Windows Screen Resolution of 1920 x 1080, with Scale set to 100%, and the same for higher resolution settings with the Scale bumped up beyond 100%.

I don't normally use the virtual controller, but I do have about 137 soft synths and effects to install, (I was good all year), and I would endure quite a bit of pain to sit in the office chair long enough, to test out everything, by the time I would cycle through checking things out, and the cats like to take LOTS of naps, so if there is any way to tweak that auto-detect logic, it would SURELY make a huge and beneficial difference to me.  10 herniated discs kind of limits the amount of physical moving around - even to just sit upright for any length of time in a chair.  (I would put in a bunch of good words with Santa, on your behalves......)  The cats could mostly care less, either way, but deep down (OK it might be WAY WAY WAY deep down), they would thank you too, or not - they are very aloof.

Bob Bone

 

Share this post


Link to post
Share on other sites

Yes, it is probably 32bit but is a freestanding program that connects to the DAW with a virtual MIDI cable.

Before Cakewalk added their virtual keyboards, it was a solution I used to post on the old forum. There are a couple of other virtual keyboards that work the same way. Don't have a 2/4K Monitor to test.

 

Share this post


Link to post
Share on other sites
3 minutes ago, scook said:

Yes, it is probably 32bit but is a freestanding program that connects to the DAW with a virtual MIDI cable.

Before Cakewalk added their virtual keyboards, it was a solution I used to post on the old forum. There are a couple of other virtual keyboards that work the same way.

 

Thanks - I am looking at a 64-bit plugin on KVR.  I will still let tech support know of the error in their auto-sizing logic, in case they want to fix it, now that folks the world over are starting to snag giant HDTV's at remarkable prices.  I saw a 55" Ultra High-Def HDTV from Samsung (I think) for less than $300.  a 4k Smart TV with a built-in HDR, for less than $300 - wow.

Anyways - I will see what I can find that will work.  I figure a good 2 days of testing out all of the new plugins, and sounds, etc.... so this will be well worth it.

Bob Bone

Share this post


Link to post
Share on other sites

If you are going to use a plug-in, you could use the keyboard in the PRV Notes pane.

 

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...