Jump to content
David Rubenstein

Step Record Issue

Recommended Posts

I am having an issue with Step Record. I choose "Follow Step Size", The parameters "% of note value" is set to 100 and "Randomize by" is set to 0, although they are grayed out.

Nevertheless, I am getting randomization; sometimes the notes advance a bit more than the step size, and sometimes a bit less. Any ideas how to turn off this randomization of the step size?

Share this post


Link to post
Share on other sites

I am sorry, I tried to reproduce the problem but it appears to work OK. I tried both enabling Follow Step Size (which ignores the % of note value and Randomize by settings) and disabling Follow Step Size with % of note value set to 100 and Randomize by set to 0. These should be functionally the same and they are for me.

Have you tried running Step Record in basic mode with Follow Step Size enabled? To invoke Basic mode, click the Bas. button in the bottom right of the Step Record dialog.

 

Share this post


Link to post
Share on other sites

scook, yes I have tried all of those things.  (The problem does not show up when stepping whole notes or half notes--only quarter, eighth, etc.) 

But, since you mention that you cannot duplicate the problem, I tried it on my second computer--with no problem. Step record works correctly on my second computer.

So, perhaps it is an issue of a setting?  I cannot figure it out.

Share this post


Link to post
Share on other sites

I am not familiar with any setting in CbB that messes with Step Recording.

Have you tried opening a project made on the computer with the problem on the second computer? Are the notes misaligned on the second computer?

 

Share this post


Link to post
Share on other sites

I haven't used Step recording in years but is it possible it follows global snap value ? Or possibly overriding PRV snap value.

Edited by chuckebaby

Share this post


Link to post
Share on other sites

I have an idea about the problem. I have been comparing all of the settings between my two computers. On my second computer (which does step recording correctly), the "Navigation" readout (which is in the lower-left corner of the step record window in Basic mode, and near the lower right in Advanced mode) shows the Now Time in terms of MM:BB:TTT (Measures/Beats/Ticks).  For example, if the Now Time is at the beginning of the 2nd beat of the 5th measure, it shows 05:02:000.

However, on my first computer (which messes up step recording), the Navigation shows the Now Time, but not in MM:BB:TTT, but in HH:MM:SS.SS, that is to say, in Hours/Minutes/Seconds.  I think this is the cause of my problem.  There is not enough precision in a 1/100'th of a second fraction to end up exactly at the right number of ticks when the step advances. 

So, how do I change the Navigation read-out to be in terms of Measures/Beats/Ticks instead of Hours/Minutes/Seconds?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...