Jump to content
klbailey3

Sample Rate buffer size changing on the fly

Recommended Posts

Sample Rate and buffer size changing on the fly and at random. I have a UAD Firewire. Before I start cakewalk its at 44k/512 buffer. I start cakewalk and it changes to 192k/256 buffer. I have to close cakewalk and try again and hope it work. Than when I does start at the right sample rate, the buffer will still drop audio at random and change the buffer of my apollo after. I have to change it back in apollos console settings and start and stop audio playback.

ps..the setting in cakewalk are always at 44k 

Very weird....please help

Share this post


Link to post
Share on other sites

I agree, very weird.  It seems to me this can only be some sort of hardware/driver problem or interference from 3rd-party software. I'd recommend a cold boot if you haven't done one recently, and maybe re-installing drivers or trying the interface on another machine or with some other DAW software to see if it reproduces.

EDIT:  And just to be clear, this is ASIO driver mode, right? The only thing I can imagine trying Cakewalk to correct it other than just verifying Timing Master and other audio settings would be to rename AUD.INI and let it build a new on on launch.

Edited by David Baay

Share this post


Link to post
Share on other sites

Sonar PLAT working just fine...

 

ASIO driver mode YES

APOLLO clock source (Internal)

I had a session open i'm working now and during mixdown at about 85% to go it just closed..no error message no nothing. now when I go to open cakewalk back its not finding my apollo..

I'll try reinstalling my driver..seems to be one thing after another

Edited by klbailey3

Share this post


Link to post
Share on other sites

take a look at the manual page 1458, it appears that projects may hold the sample rate info that it was recorded with, and in turn CW will change the sampling rate on the fly to accommodate the project defined sample rate... I had a similar issue at one point that when opening older projects I started with a 48khz would freeze and I would hear a slight pop, then the project would load.  I could be wrong, but the section on " to change the sample rate of a project" on page 1460 makes me think this is the case. in your case, if this is blank/new project, I would think the default template may have the 192khz 256 buffer settings saved in it.

 

Peace,

Blindeddie

  • Like 2

Share this post


Link to post
Share on other sites

There are two ways CbB sets the sample rate for a project.

  1. If the project does not contain any audio clips, the sample rate is read from the Default Settings for New Projects - Sample Rate in preferences
  2. If the project contains audio clips, the sample rate is read from one of the audio clip headers.

CbB does not set the audio I/O buffer when running in ASIO mode. There is no way for CbB to do it. This is set by the ASIO control software supplied by the interface manufacturer.

  • Like 2

Share this post


Link to post
Share on other sites
7 minutes ago, Blindeddie said:

take a look at the manual page 1458, it appears that projects may hold the sample rate info that it was recorded with, and in turn CW will change the sampling rate on the fly to accommodate the project defined sample rate... I had a similar issue at one point that when opening older projects I started with a 48khz would freeze and I would hear a slight pop, then the project would load.  I could be wrong, but the section on " to change the sample rate of a project" on page 1460 makes me think this is the case. in your case, if this is blank/new project, I would think the default template may have the 192khz 256 buffer settings saved in it.

 

Peace,

Blindeddie

Other than installing the latest update nothing have changed. I'm not trying to change the sample rate. Its just changing. 

Share this post


Link to post
Share on other sites
2 minutes ago, scook said:

There are two ways CbB sets the sample rate for a project.

  1. If the project does not contain any audio clips, the sample rate is read from the Default Settings for New Projects - Sample Rate in preferences
  2. If the project contains audio clips, the sample rate is read from one of the audio clip headers.

CbB does not set the audio I/O buffer when running in ASIO mode. There is no way for CbB to do it. This is set by the ASIO control software supplied by the interface manufacturer.

I would think it would be and issue with my interface. Other than this all started with the last update to cakewalk and it still works fine in Sonar Plat.

Share this post


Link to post
Share on other sites

There are no changes to audio processing in the July release that could have impacted anything like this. Also Cakewalk never sets the audio buffer size directly except through the control panel so its not even possible to change. Its coincidental that your problem occured at the same time. Did you do any Windows updates?

What is possible is that the driver is changing the buffer size based on the project sample rate. If its switching to 192K when loading CbB its because your default sample rate in CbB is set to 192K or you are loading a project already saved at that setting. Its completely normal for CbB to switch sample rates in that scenario. 

  • Like 1

Share this post


Link to post
Share on other sites

Well an interesting thing, this behavior is happening for me now.  My interface (Presonus Firestudio project) will switch sample rates to 96Khz when I open CbB...no default project even loaded.   This started happening a day or two ago after CbB crashed.  Here are the details of what happened.

I loaded an Instrument into the synth rack, (AAS -Lounge Lizard Session) I chose MIDI Source and First synth Audio output (not simple Instrument Track) then I attempted to delete the MIDI source track and got the dreaded "Fatal Exception error"

Re-opened Cakewalk and tried loading the synth again (simple Instrument track this time) put in some midi notes, and it played at double speed (the project indicates that the sample rate is 44.1 khz.  Looked at the Control panel for the Interface and it was reporting that the sample rate was 96Khz.

Windows was updated about 2-3 weeks ago to the latest build, but I had not seen this behavior until just the other day.  I have a minidump from when I get the error, so if that might help see what might have gone wrong, I can provide that file.

Not a complete show stopper, as the sample rate change does not happen consistently, I just have to check to see what the Sample rate the Interface is reporting and if it is wrong, close CbB adjust sample rate of Interface, then restart CbB.  Takes one or two tries, but eventually I can get them synced up.

Any info or assistance would be great

Peace,

Blindeddie

 

 

Share this post


Link to post
Share on other sites

 

22 minutes ago, Blindeddie said:

Re-opened Cakewalk and tried loading the synth again

How did you start the project after re-launching Cakewalk? From template chosen in the New Project view of the Start Screen or by File > New or by Ctrl+N or... something else?

And what is the value of Sampling Rate under 'Default Setting for New Projects' in Preferences >  Audio > Driver Settings?

Share this post


Link to post
Share on other sites

and if this is the only audio device used by Windows make sure the sample rate setting is the same in Windows and CbB.

Share this post


Link to post
Share on other sites

Default settings- 44.1khz and match Windows settings exactly.

 

After relaunch, I loaded Start Screen ->"Empty Project" then set up synth track from scratch... but the Sample rate reported by the interface had switched to 96Khz before even opening up the template...🤔

Granted this is an older unit that is discontinued and the drivers have not been updated in several years. I am leaning towards a windows/driver issue rather than a CbB issue here.  One thing I did do recently that I just thought of, was hook up an NI Rig Kontrol I had lying around (latest drivers for that) that has a low end WDM audio Interface built in, maybe a conflict going on there as well...will have to remove that and get back to where everything was prior to that.  

I just love all the Technical Crap that gets in the way of making music...NOT...maybe I will just break out my old 4 track Portastudio and be done with computers!!!😋

Peace,

 

Blindeddie

Share this post


Link to post
Share on other sites
58 minutes ago, Blindeddie said:

Default settings- 44.1khz and match Windows settings exactly.

Although it may not be relevant to this issue, I have always felt that using WDM driver mode, and letting Windows have access to your audio interface is asking for trouble. I prefer to use ASIO mode, and set Cakewalk not to share drivers or release them when not in focus.

I leave my onboard sound active for use by Windows, browsers and generic multimedia apps so that they all keep their mitts of my audio interface, and patch the soundcard output to an outboard mixer so it can play through my studio monitors when desired.

Share this post


Link to post
Share on other sites

This is happening with the ASIO drivers for the interface.  Again, I am leaning towards old drivers and Windows update...something funny is going on, not sure what!

Peace,

 

Blindeddie

Share this post


Link to post
Share on other sites

Ok, after much fiddling around, I am changing my tune (Puns Intended) I decided to try CbB using theWDM drivers for my interface and the problem went away.  

I noticed that other Audio apps I use would exhibit the same behavior after I opened CbB  with ASIO drivers then closed it and opened other apps. The  Sample rate of the interface would change to Random sample rates with those apps as well.  If I didn't open CbB the other apps worked just fine.

So I set up CbB to use WDM then rebooted to get a fresh start. Started CbB and Sample rate stayed at its default Closed it, opened other apps that are using ASIO and no issues with Random Sample rate changes.

so I think something is going on with CbB and the ASIO drivers for my Interface.  Since all is working smoothly now I will just leave things the way they are, but if anyone has a similar issue or knows Why this would be happening, please share.

Peace,

Blindeddie

Share this post


Link to post
Share on other sites

Check the UAD forum as well.

I had a major fault ( as in -  I'm sending my Apollo Firewire  to UAD  tomorrow for diagnostics and possible repair )  when I updated to their latest console software. It may be that the latest install also updated the firmware and dis-conbobulated the firewire connection. My issue is complete lack of firewire connection. But, I did read about some other issues related to random switching sample rates.

As for the presonus on firewire - did you need to switch to legacy 1394 driver using it?  I tried using an  older presonus and couldn't get it working and had to use my old Roland FA-66 temporarily on a legacy  windows 1394 driver. Unfortunately I'm in the middle of 50 + audio track mix. not the greatest timing.

Share this post


Link to post
Share on other sites

Hi, i have a similar issue but not only with midi data, audio data have the similar issue. 

I need to change the buffer size and the sample rate several times before the audio comes normal.

If any of you have a solution please share, this is annoiyng.!!

 

Share this post


Link to post
Share on other sites

In ASIO mode when Cakewalk starts it enumerates all ASIO drivers installed on the system to check if they are valid. While doing this it goes through each of them and  sets the driver to the same sample rate as report back by the driver.  i.e. this should have no effect since its setting the sample rate to the same value.

Subsequently, if you create a new project it sets the driver to the default sample rate as set in preferences. 
Alternatively if you open an existing project it sets the driver to the sample rate as used by that project. 

These are the only 3 ways that the sample rate is set. However  if you have multiple ASIO drivers that use the same physical hardware it can cause confusion. 
For example in step 1 while enumerating drivers if one of the drivers reported 44100 and the other driver reported 96000 the sample rate will flip between the two. (Cakewalk has no idea that two different drivers access the same device)
It's not a good idea to have multiple drivers for the same device so if you have that its its best to uninstall any other generic drivers and only keep the native manufacturer's driver installed.

 

  • Like 2

Share this post


Link to post
Share on other sites

Still wrestling with this myself... I have tried everything I can think of, cannot find a resolution.... In my case, I think it is just old and outdated drivers (Presonus Firestudio which is a discontinued and non supported device). Drivers have not been updated since 2016... I refuse to purchase a new interface in the hopes that this will "Go Away" as it works just fine when it behaves...  This issue also presents itself in other DAWS...that will remain nameless...

Not much help...just venting...

Peace,

Blindeddie!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...