Jump to content

Recommended Posts

Posted (edited)

Something simple ...


Add the .midi extension to those recognized by Cakewalk when you try to open a midi file. These files come from the OSX platform. These are simple midi files but because of the extension are not visible when we try to open them through the Cakewalk application. You have to change the extension from .midi to .mid  so that it can be read by CbB..

Edited by Jean Corivo

Share this post


Link to post
Share on other sites

A great app for doing renaming is Advanced Renamer. It's free (there's a Donate button somewhere) and is regularly updated. Current version is v3.85 from 23 July. I've been using it for years. Lots of different renaming methods. Very handy.

https://www.advancedrenamer.com/

screen_aren.png

Share this post


Link to post
Share on other sites

You might want to change/add File associations on Windows.

  • Like 2
  • Great Idea 1

Share this post


Link to post
Share on other sites
On 8/3/2019 at 11:25 AM, HIBI said:

You might want to change/add File associations on Windows.

I know how to change file associations. 😉 This is not the problem... 
This is to open a file inside the Cakewalk app. CbB does not recognize this extension, and it doesn't appear in the files that Cakewalk recognizes..
I know we can open it from the file manager, but to speed up the process, it would be better if we could open it inside the CbB program

  • Like 2

Share this post


Link to post
Share on other sites
36 minutes ago, Jean Corivo said:

I know how to change file associations. 😉 This is not the problem... 
This is to open a file inside the Cakewalk app. CbB does not recognize this extension, and it doesn't appear in the files that Cakewalk recognizes..
I know we can open it from the file manager, but to speed up the process, it would be better if we could open it inside the CbB program

I see what you mean now. I renamed a .mid to .midi, and double clicking it launched CbB, but you are correct that the open dialog box does not recognize the .midi extension (it is not visible). That is a bug as far as I am concerned, since CbB can definitely open them.

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, Jean Corivo said:

I know how to change file associations. 😉 This is not the problem... 
This is to open a file inside the Cakewalk app.

On 8/2/2019 at 4:22 PM, Jean Corivo said:

These files come from the OSX platform. These are simple midi files but because of the extension are not visible when we try to open them through the Cakewalk application. You have to change the extension from .midi to .mid  so that it can be read by CbB.

Interesting: The standard *.mid file I renamed as *.midi (not OSX midi file) seems to open (1) by clicking on the file directly and (2) by reopening it from the start page (recently opened files), but not (3) by dragging it to the Cakewalk desktop or (4) by searching using the All Cakewalk File Browser.

Because I changed the association, Windows knows to open it with Cakewalk, but as you pointed out other ways of opening files don't presently work.

I just tested this with an old *.smf file -- the default extension for an old midi program. It opens using methods (1) and (2) but not (3) and (4).

Note sure it helps, but I figured as long as I explored this (and seem to have replicated your issue), I thought I'd share it.

Steve

 

 

midi file with midi extension.png

midi file with midi extension - Files Menu.png

midi file with midi extension - Open - All Cakewalk.png

midi file with midi extension - Properties.png

smf file Properties.png

Edited by MusicMan11712 (aka Dr. Steve)
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)
23 minutes ago, MusicMan11712 (aka Dr. Steve) said:

Interesting: The standard *.mid file I renamed as *.midi (not OSX midi file) seems to open (1) by clicking on the file directly and (2) by reopening it from the start page (recently opened files), but not (3) by dragging it to the Cakewalk desktop or (4) by searching using the All Cakewalk File Browser.

Because I changed the association, Windows knows to open it with Cakewalk, but as you pointed out other ways of opening files don't presently work.

I just tested this with an old *.smf file -- the default extension for an old midi program. It opens using methods (1) and (2) but not (3) and (4).

Note sure it helps, but I figured as long as I explored this (and seem to have replicated your issue), I thought I'd share it.

Steve

 

 

midi file with midi extension.png

midi file with midi extension - Files Menu.png

midi file with midi extension - Open - All Cakewalk.png

midi file with midi extension - Properties.png

smf file Properties.png

The problem is CbB does not recognize the .midi extension. There may be workaround, but it is better to have this feature directly implemented in CbB. On the other hand the  .midi extension is generated when we export midi files with Cubase, Nuendo as well as other software running on Mac (OSX)

Edited by Jean Corivo

Share this post


Link to post
Share on other sites
Just now, Jean Corivo said:

The problem is that CbB does not recognize the .midi extension. There may be workaround, but it is better to have this feature directly implemented in CbB. On the other hand the  .midi extension is generated when we export midi files with Cubase, Nuendo as well as other software running on Mac (OSX)

Not sure how it functions with bona fide OSX *.midi files, but on my computer Cakewalk by BandLab was successfully able to open files with both the smf extension and the midi extension using two specific methods.  Is there a website where I can download OSX midi files?  I didn't find one the other day. Maybe the good folks at BandLab can add an option so you can open *.midi files and I can open *.smf files by dragging them to the desktop and by using the file browser?

Share this post


Link to post
Share on other sites
1 hour ago, MusicMan11712 (aka Dr. Steve) said:

Maybe the good folks at BandLab can add an option so you can open *.midi files and I can open *.smf files...

It's the request, nothing complicated to set up... 😉

Share this post


Link to post
Share on other sites
9 hours ago, Jean Corivo said:

This is to open a file inside the Cakewalk app. CbB does not recognize this extension, and it doesn't appear in the files that Cakewalk recognizes..

Ah I see, talking about "Files of type" of the file open dialog window on Cakewalk.
Yes, .midi extension is filtered out. It's a problem. I believe it should be fixed easy.

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×