Jump to content
Sign in to follow this  
sjoens

[SOLVED mostly] Cakewalk Will Not Open

Recommended Posts

Yesterday I had CbB open for hours. Today for no known reason, ALL versions of Sonar and Cakewalk are closing right after the splash screen shows.

All my other DAWs are opening fine.

No Task Manager entries exist.

Several Registry entries for ASIO exist.

I uninstalled CbB and downloaded and installed it fresh but it still won't open.

What are my options?

Edited by sjoens

Share this post


Link to post
Share on other sites

I had a similar problem a few days ago (see thread "Cakewalk not opening - Solved"). For me it came down to a corruption in a control surface file, caused by trying to install a new controller. The crashes are probably creating dump files ( .dmp) and these can be sent to Cakewalk technical support ( see details in the other thread ). My experience was that they were pretty quick to try and help, so this might be a better route to go before major re-installation of Windows etc.

  • Like 2

Share this post


Link to post
Share on other sites

If you wish to test a few things while waiting for a reply I would first look at the ASIO registry entries.

The OP notes

On 10/7/2022 at 4:52 AM, sjoens said:

Several Registry entries for ASIO exist.

If one of these has gone bad it may cause all Cakewalk DAWs and CbB to fail at startup.

Export a copy of HKEY_LOCAL_MACHINE\SOFTWARE\ASIO from the registry.

Then remove all the entries from the registry and start the DAW.

If the DAW does not crash on startup, the problem is likely one or more of the ASIO drivers.

Add the HKEY_LOCAL_MACHINE\SOFTWARE\ASIO entries back one-at-a-time starting with the principal audio interface driver, testing the DAW after each one.

If the DAW crashes after adding an entry, try re-installing the driver or remove the entry and continue testing.

Share this post


Link to post
Share on other sites

After deleting each ASIO entry one-by-one while opening CbB, the culprit was the onboard Sound Blaster Recon3Di. I don't use it in CbB but CbB was listing it.

I deleted it and all the other listings not being used for CbB from Registry ASIO list and CbB now opens.

Curious why it's an issue all of a sudden... but I noticed a new Windows Redistributable 2015 entry when opening Windows Recovery around the same time the issue arose.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...