Jump to content
  • 0
david moyer

My virtual instruments arent working

Question

Posted (edited)

Im fairly new to cakewalk and I have my midi keyboard set up and i can hear it with the input echo, but when i go to use the piano roll or step sequencer and try to make music, or even trying to record with my midi keyboard, it only gets 1 beat from one measure and then completely stops playing, and everything i recorded with my midi keyboard is compiled into one measure.  It does the same thing if i try to use a sample track as well.  I can record audio with my microphone just fine and hear the playback exactly as it was, but for some reason with the virtual instruments I only get the one beat.

Edited by david moyer

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0

You need to give us some information about your set up.

What Audio interface? What sample rate, bit depth and buffer size.

See:  Preferences | Audio | Driver Settings

In Preferences | Audio | Devices, is your audio interface selected as an output device

In Preferences | Audio | Playback and Recording, what driver mode are you using (If possible, ASIO is recommended)

Are your virtual instruments set to a bus that is turned up.  In turn, Is your master bus set to a physical output and are all levels turned up?

Share this post


Link to post
Share on other sites
  • 0

I'm having a hard time parsing what you've tried, although I get that you're only hearing the first note on playback. What happens when you enter notes one by one into the Piano Roll?

Have you tried examining the Event List for your track(s) to see if there is something weird like an All Notes Off or zero velocity being inserted?

Are you using Instrument Tracks or split MIDI and Synth Tracks?

What audio interface are you using, and in what driver mode? ASIO? WASAPI? Exclusive or Shared? Are you using a separate connection for your MIDI controller or does it plug into your interface with a 5-pin DIN MIDI connector?

Share this post


Link to post
Share on other sites
  • 0

I would like to know what the name is of your virtual instrument.

Share this post


Link to post
Share on other sites
  • 0
11 hours ago, Starship Krupa said:

I'm having a hard time parsing what you've tried, although I get that you're only hearing the first note on playback. What happens when you enter notes one by one into the Piano Roll?

Have you tried examining the Event List for your track(s) to see if there is something weird like an All Notes Off or zero velocity being inserted?

Are you using Instrument Tracks or split MIDI and Synth Tracks?

What audio interface are you using, and in what driver mode? ASIO? WASAPI? Exclusive or Shared? Are you using a separate connection for your MIDI controller or does it plug into your interface with a 5-pin DIN MIDI connector?

no matter what i do it seems like nothing works, i am usin asio, even when i use the piano roll, or input one of the default sequences in the virtual instruments, i will drag and drop and it will put all the notes in like it supposed to but when i go to do play back it will only play the first beat of the first measure and nothing more, even though my voice recording plays back fine, im trying to submit a video too but i cant get the audio to work

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, Kurre said:

I would like to know what the name is of your virtual instrument.

all of them, the defaults that come with it and the ones from spitfire audio

 

Share this post


Link to post
Share on other sites
  • 0
14 hours ago, Promidi said:

You need to give us some information about your set up.

What Audio interface? What sample rate, bit depth and buffer size.

See:  Preferences | Audio | Driver Settings

In Preferences | Audio | Devices, is your audio interface selected as an output device

In Preferences | Audio | Playback and Recording, what driver mode are you using (If possible, ASIO is recommended)

Are your virtual instruments set to a bus that is turned up.  In turn, Is your master bus set to a physical output and are all levels turned up?

it unfortunately has nothing to do with any of the levels, i can hear it with the input echo just fine, but no matter what i do it only will play back 1 beat, it wont even attempt to make the timing marker move past the first beat

Share this post


Link to post
Share on other sites
  • 0
4 minutes ago, david moyer said:
14 hours ago, Promidi said:

You need to give us some information about your set up.

What Audio interface? What sample rate, bit depth and buffer size.

See:  Preferences | Audio | Driver Settings

In Preferences | Audio | Devices, is your audio interface selected as an output device

In Preferences | Audio | Playback and Recording, what driver mode are you using (If possible, ASIO is recommended)

Are your virtual instruments set to a bus that is turned up.  In turn, Is your master bus set to a physical output and are all levels turned up?

it unfortunately has nothing to do with any of the levels, i can hear it with the input echo just fine, but no matter what i do it only will play back 1 beat, it wont even attempt to make the timing marker move past the first beat

Still the rest of the information requested by @Promidi may be useful.

In addition to images of the requested audio preferences dialogs, consider including images of Preferences > MIDI > Devices and Preferences > MIDI > Playback and Recording.

Share this post


Link to post
Share on other sites
  • 0
43 minutes ago, scook said:

Still the rest of the information requested by @Promidi may be useful.

In addition to images of the requested audio preferences dialogs, consider including images of Preferences > MIDI > Devices and Preferences > MIDI > Playback and Recording.

 

Screenshot (19).png

Screenshot (20).png

Share this post


Link to post
Share on other sites
  • 0

Don't need to see the problem, the 2/3rds of the requested audio preference images are enough to suggest a solution.

Try setting UseHardwareSamplePosition to False in Preferences > Audio > Configuration File

AFAIK all Digidesign interfaces need this change.

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...