Jump to content
David Pollock

Bass jumps out of tune randomly

Recommended Posts

A midi bass line playing an EastWest bass will suddenly jump out of tune a few steps at random places. The only way to remedy the problem I have found is to restart Cakewalk. There are no plugins on the channel, but there are two automations for volume and panning. Otherwise, there is nothing I see in the midi to cause this. Perhaps this is an EW problem but thought I would start here for suggestions. 

Share this post


Link to post
Share on other sites
Posted (edited)

If you have a controller connected, perhaps the pitch wheel in it is going bad. I have had that problem with 2 different keyboards. 

Simple to rule out. Just disconnect the controller(s).

Edited by Base 57
  • Great Idea 1

Share this post


Link to post
Share on other sites
Just now, Base 57 said:

If you have a controller connected, perhaps the pitch wheel in it is going bad. I have had that problem with 2 different keyboards. 

Thanks. I'll play it back a bunch of times without my keyboard connected and see what happens. 

Share this post


Link to post
Share on other sites

Try to determine whether the symptom is random, intermittent, or both.  "Random" implies that the detuning occurs in various different places along the timeline, without consistency. If it's intermittent but not random, that means it occurs at the same place(s) but not all the time.

If truly random, hardware would be a prime suspect. A bad potentiometer on a cheap scroll wheel (iow what most of us are using) can generate spurious events just by rolling your chair nearby. If you hear the pitch shift while the controller's disconnected, then you can be certain that's not it.

You could also try selecting a different MIDI channel (anything but channel 1) for the bass track. That would effectively disconnect the controller. By default, new MIDI tracks are set to Omni, meaning they respond to any and all incoming MIDI commands.

  • Great Idea 1

Share this post


Link to post
Share on other sites
9 hours ago, bitflipper said:

Try to determine whether the symptom is random, intermittent, or both.  "Random" implies that the detuning occurs in various different places along the timeline, without consistency. If it's intermittent but not random, that means it occurs at the same place(s) but not all the time.

If truly random, hardware would be a prime suspect. A bad potentiometer on a cheap scroll wheel (iow what most of us are using) can generate spurious events just by rolling your chair nearby. If you hear the pitch shift while the controller's disconnected, then you can be certain that's not it.

I'd also check to see if there might be some automation coming from another track. Just solo the bass track and play it back. If the symptom never occurs when soloed, but returns when the whole mix is enabled, then it's probably another MIDI track on the same channel. Alternatively , you could disable Read automation or change the MIDI channel. Such things can appear to be intermittent, because it depends on where in the timeline you start playback.

It appears to be random. I am able to fix it (so far) by moving the scroll wheel around on my keyboard a few times. But it is only happening with the bass despite working on many other tracks of different instruments in the same time period. Most of those are strings, so perhaps there is something unique about bass? Time will tell I guess.

Share this post


Link to post
Share on other sites

It doesn't have anything to do with it being bass specifically. Easy workaround for the time being would be to just change the input MIDI channel on that track to something other than what your controller's set to (probably channel 1).

  • Like 1

Share this post


Link to post
Share on other sites

Not exactly sure which EW virtual instrument you're using, but it has helped me a lot to set the exact MIDI input device / channel (rather than 'omni') on the track where you have this issue. Preferably make it a habit to do this each time you add a new track.

Also, I've seen some plugins produce better results when using the 64-bit VST instead of the VST3 version. I saw this for example with Ample Bass P and Ample Guitar M, but also with various FX plugins.

  • Like 2

Share this post


Link to post
Share on other sites
Posted (edited)

You could also try a different VSTi on the same MIDI track which can eliminate one or both of those two.

When playing mid stream, pitch wheel events will also wreak havoc on note tuning when MIDI Events Chace on Play is not checked in Prefs, 

Random or not, I'd also check the Event List for erroneous data. - I've recorded outboard sequencer tracks into CbB only to find a host of unwanted MIDI data.

 

Edited by sjoens
  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...