Jump to content
Rostislav

Cannot copy or cut MIDI track content

Recommended Posts

I was editing a CWP file that had been edited many times before, without any difficulties. But suddenly one MIDI track stopped to handle copy and cut: if I select notes on this track and try to copy or cut them, nothing happens. This problem occurs in the Staff View as well as in the Piano Roll, and it is the same regardless of I copy/cut with the main menu or with Ctrl C / Ctrl X.

The problem affects only one track; the other tracks allow for copy and cut normally. I didn’t find any freezing effect or something like in the track’s properties.

Here is a video demonstrating the issue: 

Attached to this post is the CWP file itself. Track 6 causes problems.

How to fix this?

nonstop_band.cwp

Share this post


Link to post
Share on other sites

Had a similar problem just this morning with a Trilian Bass instrument track. Copy and paste failed to work, even the "Copy Special" and "Paste Special"  dialog boxes

wouldn't appear after I selected them from the menu. I finally got paste to work from the menu list that appears in the little  box at the end of the Midi track.  Tried closing the project figuring that might re-set the functions. Didn't help. Finally had to restart Bandlab to get going again. 

I'm running the latest version and this hadn't been a issue in the past. 

Anyone else seeing this?

 

 

Share this post


Link to post
Share on other sites

Probably that track is grayed out in the track view and it is not normal. That rarely happens, I think.
Anyway, press "e" key twice (meaning all FX bypass on and then off), the problem track will back to a normal condition.

Edited by HIBI
  • Thanks 1

Share this post


Link to post
Share on other sites

The issue is in the Piano Roll. 

Here's what I'm doing;

Open the drum (or any) Midi track in piano roll. Use the Selection Box and type in say 7 in the top 23 in the bottom. I can see the grey bar selecting measures 7 -23.

I use Edit Copy or ctrl C. I use G to go to measure 71. Select Copy Special, the dialog does appear with the proper measure (71), but the track number

isn't  in the dialog box. I click OK, nothing appears in the drum Midi track in question. What I do get is a bunch of tracks added to the bottom of the project. I'm attaching photos.

This has been my standard work process for ever and now it doesn't work. I can make a selection from the Midi track in track view and paste it, but the notes don't

align properly with the measures. I have to manually slide them in Piano roll view.

If I have some function switched on that I'm mot aware of please enlighten me. 

Thanks

extratracks.JPG

starting track.JPG

Share this post


Link to post
Share on other sites
3 hours ago, HIBI said:

Anyway, press "e" key twice (meaning all FX bypass on and then off), the problem track will back to a normal condition.

Thank you HIBI, it worked for me!

I pressed E twice, and the problem track got fixed, though I even don’t know what a FX bypass is and why does it affect copy and cut operations this way. (I don’t make music with Cakewalk, I only use it as a musical Notepad to write arrangements for a live band.)

Share this post


Link to post
Share on other sites

E or e doesn't work for me. I'm beginning to think the time Selection Box (see photo) is hosed up. I can drag over a selection of measures in a Midi track, copy and paste works as expected. Not as accurate as the time selection.

I've always used the Selection Box because it's accurate. Can someone else try it my way?

selectionbox.JPG

Share this post


Link to post
Share on other sites

@Rostislav thanks for the report. I was able to reproduce it. We'll investigate your project and see why it happens.
On first looks I can see that the selection somehow thinks that nothing is selected even though the UI is showing it. We'll investigate further.

  • Like 3

Share this post


Link to post
Share on other sites
3 hours ago, Rostislav said:

I pressed E twice, and the problem track got fixed, though I even don’t know what a FX bypass is and why does it affect copy and cut operations this way.

I don't know why "all FX bypass" is works for this issue. (I found this solution by chance before.)
See here for "all FX bypass", btw.
 

34 minutes ago, Noel Borthwick said:

I was able to reproduce it. We'll investigate your project and see why it happens.

I wonder why "all FX bypass" works for fixing this issue... It's a mystery.

  • Like 1

Share this post


Link to post
Share on other sites

Weird corner case. The real issue is that somehow track 6 had its edit filter state set to show an envelope.
However the actual envelope data stored was not correct. As a result the code was not setting the edit filter state properly. Although the track view showed it as "clips" internally it was still "envelope".

There is a rule for copy (not copy special) to reject note data when copying with the edit filter set to envelopes. Likely because we don't want to copy and paste data for the wrong type when the edit filter is asking for envelopes. As a result you saw this behavior that copy was ignored.

I have fixed it for the next release so that when the project is loaded we ignore a spurious edit filter setting of envelopes and set it back to "clips". This fixes your project and when it loads up the edit filter will now show clips. It would be interesting to know how it got into that state in the first place. Perhaps you might remember if at some point you had set the edit filter to envelopes and maybe something went wrong after...

You can make your project work again by setting the edit filter manually to something else and then back to clips. Then save the project.

  • Like 1

Share this post


Link to post
Share on other sites

Thank you @Noel Borthwick for your attention to my issue. Unfortunately I’m not sure that I fully understand what an envelope is, and how edit filter works. I definitely didn’t set the edit filter to anything deliberately, for I didn’t know that this filter exists at all. But I might have pressed some special hotkey by accident without noticing. I had similar experience some time ago when I pressed some key accidentally, and a guitar fingerboard suddenly appeared at the bottom of the window. It took me considerable time and effort to figure out how to dismiss it. Since then, I try to be careful and not to press any keys at all when working in Cakewalk. Sometimes my hand might shake and hit a keyboard, though.

Share this post


Link to post
Share on other sites

Hi @Rostislav this isn't your fault. It's hard to say what let the project to get saved in that state. The edit filter is the dropdown in the track strip that by default says Clips. By changing it you can select what data you wish to edit in the track. See the help for this here. You can easily switch your track to clips if it happens again.

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...