Jump to content
Michael Finnity

Cakewalk/Realtek/ASIO and Windows 11 🙄

Recommended Posts

While I don't consider myself a computer wiz, or an audio wiz for that matter, I've worked audio long enough to know that windows 11 and audio are just a massive headache. 

I searched the forum and read different topics regarding asio and realtek, but I'm 99% convinced it's windows 11. I've watched every YouTube video possible on how to delete/disable the the Realtek audio driver. While it can be deleted, it's only temporary. The second you restart or shut down the computer, the Realtek driver comes back. This wouldn't be an issue if it didn't freeze cakewalk and other vst's(ezdrummer) and I have to re start the computer constantly. Asio is the most steady driver, and I try to use that most often, especially if I'm using ezd in standalone mode. The most frustrating thing is, I can go on my old laptop with windows 10 and don't have any issues with the audio drivers. I contacted hp technical support and that was like talking to a brick wall. I guess I'm curious if anyone else had these issues with windows 11. The biggest thing for me is having the lowest latency possible. I run my roland drums into my laptop for ezdrummer, so I need the lowest latency possible, which is by using the asio driver. 

Share this post


Link to post
Share on other sites

If you're actually using the Realtek interface, do NOT use ASIO because that driver is super buggy. If you switch to WASAPI Exclusive, you can get sub 5ms latency easily, or 10ms using WASAPI Shared. You'll want to delete the Realtek ASIO driver entirely.

If you have another interface with proper ASIO drivers, leaving the Realtek enabled shouldn't interfere with it - I have various machines here with Win10 and 11 and the onboard sound is all enabled with no issues.

Edited by Lord Tim
  • Like 1

Share this post


Link to post
Share on other sites

The way to get rid of the Realtek driver coming back is to turn off the on-board audio device in the Bios, or, if you’re not comfortable delving under the bonnet, disable it in Windows device manager. You can then safely delete the dreaded Asio4All. There will be a registry key to delete too.

You can then use your off-board audio device for both Windows and DAW work. You have not yet said if you have one and what it is.

I have done this on my desktop and audio + W11 works just fine (Focusrite 18i20). Same goes for the laptop on W10.

J

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, Jeremy Oakes said:

The way to get rid of the Realtek driver coming back is to turn off the on-board audio device in the Bios, or, if you’re not comfortable delving under the bonnet, disable it in Windows device manager. You can then safely delete the dreaded Asio4All. There will be a registry key to delete too.

You can then use your off-board audio device for both Windows and DAW work. You have not yet said if you have one and what it is.

I have done this on my desktop and audio + W11 works just fine (Focusrite 18i20). Same goes for the laptop on W10.

J

I have a behringer umc22, but I rarely use it. I have no need to use it for cake walk or ezdrummer as my e drums plug directly into my laptop via usb. Maybe it's just my laptop, but it is impossible to delete the Realtek audio driver. I've deleted it from the device Manger about 100 times now and it just comes back. Also, I did go into my bios settings and there is no option to turn off the mother board sound, but I really wouldn't wanna do that as then I woukd have no sound at all.  Also, asio is the only driver that will give me low latency. Wasapi is around 10ms and that is unacceptable for drums, especially live. Asio is 1.5ms. That's a pretty significant difference 

Share this post


Link to post
Share on other sites

i just disable it in the device manager rather than delete it. i use this same tactic for a number of other bits as well since the OS finds and installs drivers for them regardless, however, disabling them means they're still in the system and so no further attempt is made by the OS to re/install them.

Share this post


Link to post
Share on other sites

Yep, Glenn is on the money there - if you want to get rid of the Realtek, disable it, not delete.

WASAPI is 10ms if it's in Shared mode, but if your interface allows it, try Exclusive mode. Shared has a hard lower limit of 10ms but Exclusive will let you go lower than that, at the expense of only CbB being able to use the driver when it has focus.

I can definitely vouch for using WASAPI Exclusive with a Realtek interface - I was actually getting lower latency and better performance out of that while I was on the road with my laptop than I was at home with my TASCAM 16x08 using ASIO. (Using a Scarlett 18i20 now and it's MUCH better)

Share this post


Link to post
Share on other sites
1 hour ago, Lord Tim said:

Yep, Glenn is on the money there - if you want to get rid of the Realtek, disable it, not delete.

WASAPI is 10ms if it's in Shared mode, but if your interface allows it, try Exclusive mode. Shared has a hard lower limit of 10ms but Exclusive will let you go lower than that, at the expense of only CbB being able to use the driver when it has focus.

I can definitely vouch for using WASAPI Exclusive with a Realtek interface - I was actually getting lower latency and better performance out of that while I was on the road with my laptop than I was at home with my TASCAM 16x08 using ASIO. (Using a Scarlett 18i20 now and it's MUCH better)

Disabling it will temporarily use the high definition codec, but as soon as i turn the computer off or restart, it reverts back to realtek. I could go in and disable it everytime, but that would be super annoying. I should have the option of the Realtek driver or HD driver, but I don't and that is my issue. Also, wasapi exclusive will give me about 5ms latency at best at that's with alot of static. 10ms is the lowest I can get with wasapi with no interference. 

Share this post


Link to post
Share on other sites

If it works like Win10, removing the RealTek entry from

HKEY_LOCAL_MACHINE\SOFTWARE\ASIO

will leave the chip enabled for use by other Windows drivers while preventing access to the buggy ASIO driver.

  • Like 1

Share this post


Link to post
Share on other sites

Why are you not using Roland (Edirol) ASIO? from your first post I guess you use e-drums. BTW your audio equipment (umc, roland, build-in) is not capable to work with sub 5ms RTL, I mean 1.5ms you  see somewhere is fake.  Note that headphones  with 3ms RTL are approximately the same as 0 latency with real drums (your head is about 1m away from drums, that is 3ms for the speed of sound).

Share this post


Link to post
Share on other sites
12 minutes ago, azslow3 said:

Why are you not using Roland (Edirol) ASIO? from your first post I guess you use e-drums. BTW your audio equipment (umc, roland, build-in) is not capable to work with sub 5ms RTL, I mean 1.5ms you  see somewhere is fake.  Note that headphones  with 3ms RTL are approximately the same as 0 latency with real drums (your head is about 1m away from drums, that is 3ms for the speed of sound).

The roland driver is faulty and latency isn't that great with it. The 1.5 ms is based off what ezdrummer showing me when I'm hooked up. The difference is quite noticeable between drivers 

 

Share this post


Link to post
Share on other sites

TD11 with lowest settings has RTL 5.4ms (3.2ms output) at 44.1kHz. And that is stable and usable with EZDrummer for sure, assuming your computer can handle that. Yes, that latency is not from top class. But significantly better latency have only interfaces over €200, and you need strongly optimized for audio computer for that. Till you are in €700 category, where 1.5ms output latency is possible with moderate optimization. You write about 1.5ms from €1 interface, on computer which is not even optimized to run Roland driver without problems...

Share this post


Link to post
Share on other sites
1 hour ago, azslow3 said:

TD11 with lowest settings has RTL 5.4ms (3.2ms output) at 44.1kHz. And that is stable and usable with EZDrummer for sure, assuming your computer can handle that. Yes, that latency is not from top class. But significantly better latency have only interfaces over €200, and you need strongly optimized for audio computer for that. Till you are in €700 category, where 1.5ms output latency is possible with moderate optimization. You write about 1.5ms from €1 interface, on computer which is not even optimized to run Roland driver without problems...

My laptop has an 11th Gen I7 with 16gb solid state drive. It's very capable, but the asio driver seems to be best as far as latency goes. I have a roland td25 and the best I can get using that driver is 7ms. 

Share this post


Link to post
Share on other sites
55 minutes ago, Michael Finnity said:

My laptop has an 11th Gen I7 with 16gb solid state drive. It's very capable, but the asio driver seems to be best as far as latency goes. I have a roland td25 and the best I can get using that driver is 7ms. 

Latency has little to do with the power of CPU, especially with just one not CPU hungry plug-in like EZDrummer. The system has to be tuned for music, that is in general not easy with notebooks.

7ms RTL should be sufficient for e-drums. If that is just output latency, so toward ~15ms RTL, then it is noticeable (but still playable). Apply some system tweaks and check system latency, there are many guides in the internet. As I wrote, TD can work on lowest or close to lowest settings without death optimization. The only case I couldn't bring TD latency under 12ms (RTL) was on very old Atom based box.  On almost 10 years old CoreDuo (Celeron) I could use next to lowest settings.

With "power save" power plan any audio driver glitch.

Share this post


Link to post
Share on other sites
Posted (edited)

So my question is -- I can disable realtek but it still shows in Cakewalk -- ok, so who cares? 

Well, if I change the Record Latency Adjustment to Steinberg -- it just reverts back to realtek.  I can find no place to disable realtek asio (asio specifically) -- I did go into registry and deleted it there -- all fine with Cakewalk, but the computer became very unstable.

Is there any real benefit to fighting the asio battle or should I just go with WASAPI.  Does it matter that the record latency shows realtek? 

(I should also say Cakewalk became rather unstable too -- but at the moment seems to have settled)

Or could there be some issue with my Steinberg driver (it's the latest)?

(new desktop computer with Windows 11 - old computer Windows 10 with no problem)

Thanks for any info/help.  (my first post since Sonar was revamped by Bandlab)

 

image.png.bfa4ed423dcc8557c217ef54d4b5c36a.png

image.png.82a049c74833dd7bc9e801557b730bff.png

Edited by Sheds

Share this post


Link to post
Share on other sites
1 hour ago, Sheds said:

So my question is -- I can disable realtek but it still shows in Cakewalk -- ok, so who cares? 

Well, if I change the Record Latency Adjustment to Steinberg -- it just reverts back to realtek.

You can disabled Realtek on BIOS level or Windows level, but no one really cares.

In Record Latency Adjustement there is a possibility to set manual shift for all devices you have, on dialog display it select the first... but only the setting for currently active device is used. So select Steinberg and check manual shift is 0 (or set correctly, in case you have measured it). For Steinberg, ASIO reported value should be fine (or very close to real), so set to use it.

Note that even in case ASIO reports correct value, it is for device only. In case you connect something with own latency to the input (f.e. digital mixer), extra manual adjustment should be used.  There are many detailed guides how to measure the value to set there, quick method is just loop record output, zoom to the sample level and notice the difference.

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks for the response.  It's so odd.  When I select Record Latency Adjustment I can change it, but it doesn't hold.   So switching it to steinberg is meaningless -- which again I don't care if it doesn't make any difference.

What I've discovered though it that if I set it Cakewalk on ASIO and let it ride with realtek lurking -- it sometimes becomes unstable -- and when I am out of Cakewalk other things get weird -- for instance YouTube videos freeze and won't play.  Again -- that's a so-what except it indicates an instability.  Sometimes it Cakewalk just kind of freezes and circles and circles.

When I deleted realtek in the registry, Cakewalk looked and ran great.  But the computer got a bit funky.  For instance -- Windows Explorer kept shutting off requiring me to restart it.  Again, there are worse problems in the world, but odd.

If you're still with me, I wonder if a newer Audio/Interface would have better drivers (I have no desire to buy a new one, but . . .) 

Finally, I've disabled realtek, but clearly the ASIO drivers are still there -- I can't figure out any additional way to disable them -- do you or anyone know that?  (without regedit)

Edit: I continued looking around and found a thread from a couple years ago (back when I didn't have this problem) and the consensus was to edit the registry.   I've done that before but I have to say it's a little concerning because my computer seemed to get unstable after that (perhaps a coincidence?)

Thanks, thanks, thanks.

image.png.fb242cb405f93e6e1bdd7690077bca32.png

Edited by Sheds

Share this post


Link to post
Share on other sites

"Device" and "Manual Offset" are connected, select Steinberg and set 10. After saving, open dialog again. You should find that offset is still 0 for Realtek and 10 for Streinberg.

About computer optimization for audio there are many threads and forums. Enabled Realtek by itself should not influence anything, at least not when unused (by Cakewalk and Windows). Getting most stable drivers under Window, which means RME device, is pricey.  Steinberg should work fine when computer/system are ok.

Share this post


Link to post
Share on other sites
Posted (edited)

This video has helped 1,000's of people. Let me know if you have further questions. It is not that hard to properly set up a audio system espesially if you are using a proper ASIO audio interface. On Board audio will work if you are only working ITB but otherwise you need ASIO or your tracks will not sync up. Using a drum module is one of the few situations where ANY latency can through you off so use the Drums Brain while tracking for Pete's sake and it won't matter. 99% of the audio interfaces used these days will be operating at around 10 ms of RTL at a SAFE buffer level. You want less then spend $800+ 

 

 

Edited by John Vere

Share this post


Link to post
Share on other sites

@John Vere In your video "Record Latency Adjustment" (7:30) note is not accurate. For some (historical?) reason, Cakewalk list not only currently used device there, but also other devices. Whenever dialog is open, it select "the first" in the list, which can be currently unused device.

Even more, Cakewalk can mess with these settings in case driver mode is changed and the sequence of devices in one mode  differ from the sequence in other, it seems like Cakewalk remember/show manual offsets as a list, ignoring devices. So the shift set for one device appear as a shift for other after driver mode change. That is clearly a bug. Cakewalk IO settings (MIDI and Audio) are periodically messed since years, I guess there is some general deep problem there which is hard to fix.

What I want to say, the fact some interface appear in "Record Latency Adjustment"  drop box (and even selected by default) is not an indication something should be changed/removed in the system.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...