Jump to content

Recommended Posts

Hi,

 I had been hearing the sounds of "Rice Crispies" in  my  project.--that is, crackles and pops. I do NOT remember hearing it previously (at least in this project), though in the middle of this project, I did update to an SSD and a little more RAM (because of frequent crashes.  I must add that as soon as I disable my reverb and a compressor type effect, the extra sounds go away. I did search this out on the Forum. I found an excellent thread, with many submissions, including a few by Robert E Bone. Thus, I anxiously went into the Preferences\Audio devices and clicked on the Asio Panel box. The setting was 256, so I inc'ed it to 1024, my highest setting. That immediately got rid of my crackles and pops, but it left me with something that I can't name. It sounds like, every 1-2 seconds, someone is completely turning off the volume of the audio track that I am soloing--that is, just for a split second, and then it goes back to the original volume. So, in essence, since the track is of my singing, my voice goes in and out.  When I listen to the track without effects, this recurrent sudden loss of audio does not occur. Again, as I listened again tonite, it's not like the sound of the voice is suddenly getting softer, it's that it completely cuts out. I would say it lasts 1/3 of a second every 1.5 seconds, approx. Almost like some other wave is cyclically cancelling it out.

I also tried to disable my Windows defender as well as another antivirus software I have, but that did not help. Those were other suggestions in that whole thread.

I even tried what another person said: namely, going to "Audio\sync and caching," and trying different Playback I/O buffers. Mine was 256, and changing this setting did not help this problem.

At least, I haven't had any crashes in the past few days.

I guess I could just copy the voice and effects Bus, and forward it if anyone wants to hear what I am describing--or at least 8 measures or so.

Thanks.

LNovik

Share this post


Link to post
Share on other sites

I should add to what I just wrote above. After writing the note, I had what I thought was a great idea: perhaps, since my plugin's were located under Program files on my original hard drive, and I am now running CBL on my new SSD, this program was having difficulty accessing the effects plugins while playing thru a song. I therefore copied all my plug in's to the Program files folder that is located on my SSD.

Brilliant, yes! Except it made no difference. I should add that when the voice shuts off, it's prob for more like 0.2 seconds, but again recurs every approx 1-1.5 seconds, so it's very noticeable.

LNovik

Share this post


Link to post
Share on other sites

I would increase your ASIO buffer a little until that sound goes away. 

  • Like 1

Share this post


Link to post
Share on other sites

Well - let's take a step back, and examine your use of plugins in this project.

There are some plugins made to be used during the MIXING phase of a project, and NOT for use during tracking/recording.  Things like convoluted reverb plugins, or others that use a "look-ahead" type of processing to do their thing, REQUIRE a super large buffer to be able to process.  You yourself mentioned that the Rice Krispies go away as soon as you power off or remove those plugins - that is a big clue, that tells you that one or more of your currently used plugins in the project are indeed needing a bigger buffer (ASIO Buffer Size if you are using ASIO driver mode).  Unfortunately, if you adjust the buffer size too big during recording, then you have too much lag to really track properly.

The solution to the above, IF that is what is happening, is to first try to identify which plugins are causing the crackles, and just until you finish the recording portion of your workflow, and move into mixing, power off those plugins, or temporarily swap them out for less consumptive plugins (like use a simple reverb instead of a convoluted reverb - just until you finish tracking).  This way, you can keep your ASIO Buffer Size down to a size that lets you record without noticeable lag.

Then, when you finish your recording of your tracks, and move to mixing, then jack up your ASIO Buffer Size to 1024 or even 2048, since a bit of lag prior to the project starting to play won't interfere with anything (since you aren't tracking at this point).  The super large buffer size will then allow you to either power back on, or swap back in, the more consumptive plugins (like a convoluted reverb, etc.), and life will again be joyous in your project.

I ALWAYS keep my ASIO Buffer Size at no more than 128 when recording, I can go lower, but often just let it be at that value, and I track with no lag issues.  Then, when moving to mixing, I ALWAYS then jack up the ASIO Buffer Size to the 1024 or 2048 size I mentioned above, and THEN I can put in the more robust plugins, and still have no problems.

Give the above a try, and post back, please. :)

Bob Bone

 

  • Like 1
  • Great Idea 1

Share this post


Link to post
Share on other sites

I would try to do some Windows optimization for Audio there are some great videos on YouTube covering this.   I was having a similar problem and this solved my issue.  I am running 128 samples in Asio now, I wish you the best you will fix it.

Share this post


Link to post
Share on other sites

The audio cut off issue could be coming from a not authorized plug-in.

 

Share this post


Link to post
Share on other sites

^^^ That would be my first guess, too.

It's typical for plugins to either periodically go silent or insert a noise burst when they're in demo mode. Try bypassing each plugin in your vocal chain one-by-one and you'll probably identify which one it is.

Crackles and pops are an indication that your CPU is sometimes unable to process data fast enough to keep the input or output buffers filled. When the data stream is interrupted, even for a millisecond, that manifests itself as a click or pop.

There may be things you can do to help your CPU out, such as killing background processes (wifi adapters being the most notorious culprit) that are monopolizing the CPU. But the quickest solution is to increase buffer sizes, which gives the CPU more time to do its thing. Some people like to set buffers low (128 or less) while tracking and then bump them up for mixing. Personally, I just keep mine set to the maximum value (2048) all the time for convenience.

Share this post


Link to post
Share on other sites

Thanks for all the feedback. To clarify definitions, I am assuming that “tracking” a project refers to recording new material, and “mixing” means listening to the project and adjusting volume/moving phrases around, etc.

So, I never use plugins when I am recording, or, if they have already been chosen in my project, I make sure to disable them for the time being (by clicking on their small rectangular box and noticing that the color fades.)

Also, if you reread my first long-winded message, I believe I said I am only talking about the mixing phase of my project. So, to repeat, since I had heard all these extraneous noise (cracks and pops), I looked up and found this info about inc’ing my buffer size. As I said, this did get rid of this noise, but has introduced this cyclical complete loss of sound every approx. 1.5 seconds. The sound loss is usually preceded by a pop or clicking sound, though this popping sound is not as apparent as the crackling I was getting prior to inc’ing my buffer size.

To answer another question, after I discovered this periodic loss of sounds, I did scale back the buffers to my original of, I believe, 256. That didn’t get rid of this volume loss. However, I’ll have to check tomorrow to see if perhaps I had the sound loss problem when I was having the popping and crackling. Perhaps the volume problem was present then, but with all the crackles, I wasn’t aware of it.

I can’t increase my buffer size past 1028. That’s the highest value listed—I guess bc of my audio interface (Focusrite, Scarlet  2i2.)

I don’t think I have any unauthorized plugin’s. I’m not that sophisticated. Only what came with Sonar in the past. And certainly, I know I only have 2 in my present project, as I’ve said: a compressor type and a reverb. I don’t think it’s a convolution reverb. One (the Reverb) is from Perfect space, though when I search on that under “included effects with  Sonar x3,” it says (32 bit only.) I have a 64 bit computer setup. And, even when I disable this reverb with the other effect still on, I still get the problem. I’ll get the name of the other effects soon.

Viewing some Youtube Windows optimization for audio sounds like a good idea. I’ll do that soon.

One last thing: I had said in the short note after my initial note to start off this thread that I moved my plugin files to my new SSD, where I am, of course, running CBL. Perhaps there are other parts of Cakewalk files that are still on my old disc that need to come to my SSD in order for it to run more smoothly?

Thanks again.

LNovik

Share this post


Link to post
Share on other sites

I agree with @bitflipper - the sound cutting out every 1.5 secs sounds suspiciously like a plugin that isn't authorised, and given that some plugins use hard disk serial numbers as part of their authorisation, swapping to a new drive may have de-authorised a plugin.

If you're using something like Sonarworks Reference, it may not even need to be in your project if it's working at a system level.

If it was a CPU problem, I'd expect the playback to stop rather than go silent for a bit and carry on. As bitflipper says, you normally hear pops & crackles with high CPU load.

Another possibility might be that you've got some synth sending MIDI data out somewhere and automating the output of one of your plugins somewhere?

I'd start by bypassing all effects. If the silence has gone, then introduce each effect one by one until you find the one that makes the issue come back. 

If the issue happens with all effects bypassed, try muting all the tracks and bring each track back one by one.

Share this post


Link to post
Share on other sites

I just want to throw this out there to you, I have a MAIN DAW and I have  secondary computer with all the same stuff loaded on it.  My secondary computer was having Rice Crispies playing the same project.  I did an optimization of windows 10 and it went away. My CPU was showing low usage in Cakewalk for my project but optimizing did solve the issue.  Don;t overlook this, it will help!

Share this post


Link to post
Share on other sites

I did go to Windows optimization for audio. I followed the first ½ of suggestions, such as changing my computer to highest performance mode, etc. I didn’t disable the graphics drivers, since a brief search on how to do this was not fruitful. I also didn’t download and try the Latency Monitor that they suggested, since that doesn’t seem to be my current problem.  MarkRounds: did you follow any specific instructions when you optimized your audio? Perhaps I am missing something.

I have said that even though I did increase my buffers to the highest mode available—1024, this does not make a difference. I could make changes to the sample rate, which is 44.1, but I have not tried that.

Unfortunately, it’s not as simple as turning 1 effect off, and then another…to find out which effect is causing me the problem. I am using only 2 effects in my project, Perfect Space and VC-64. When I turn them both off, the stuttering ceases. However, when I enable either one of these 2 effects, or both simultaneously, it recurs. I should say that as I listen to the sound more and more, rather than just a sudden loss of volume, it’s more of a periodic pop which takes the sound away for a split second. However, it’s not like the pops and crackles I had heard prior to inc’ing my buffers.  This is more of an every 1-1.5 second pop that occurs repeatedly during the singing. When there is a pause in the singing, the popping sound stops.

And, Robert E Bone, thanks for the info that Pefect Space is a convolutional reverb. Perhaps, I'll just try another reverb. But again, the popping even occurs when Perfect SPace is disabled, with just the VC-64 enabled. 

Again, I have downloaded and installed CBL on my new SSD and have 8 Gb of RAM, as well as a Focusrite Scarlet 2i2. I do have an older I5 Intel computer, though, as I’ve said, I’ve never heard this problem before.

LNovik

Share this post


Link to post
Share on other sites

I can say that the suggestion of optimizing Windows for Audio is essential these days.  Have you gone into Task Manager and closed unnecessary programs running in the background?  Those programs can add up, and will constantly chip away at precious CPU power.

Are you disabling your Anti-Virus software, and making sure your WiFi is off.  What you really need is the ability to completely disable your Anti-Virus, and some virus software will not allow you to fully disable it.  Anti-Virus software can eat up a lot of CPU.  

If you’re not going to be online while recording, disable your Windows Firewalls.  Just remember to turn them back on if you go online.  I’ve completely removed 3rd party Anti Virus software from my computer and just use the Windows Defender Anti-Virus.  Windows Defender can be completely disabled too.

I don’t know your personal computer use, but my music computer is strictly for music.  I only activate Windows Defender and the Firewalls when I’m updating something or downloading new music software.  

If you have the resources to use one computer for music, and another for your internet needs, I’d strongly suggest this route.

Also we have similar computer specs.  I have an i5 with 8 gigs of RAM, and an SSD second drive.  I can squeeze a lot out of that computer .  

Sqk

Edited by SynthManDan

Share this post


Link to post
Share on other sites

Thanks, SynthManDan. Actually, I DO have a separate computer for music. That is why I tried to simply update this a few weeks ago by getting the  Samsung SSD,  a little more RAM, and Windows 10--as opposed to getting a whole new computer. You're correct that it's difficult for me to figure  out how to disable my anti-virus or Windows Defender, but I will look into this.  I'll also go into task manager and see if anything else is running.  I don't use Wifi for my  computer-just a direct cable connection.  I'll figure out how to close my Windows Firewall as well. 

LNovik

Share this post


Link to post
Share on other sites
17 hours ago, LNovik@aol.com said:

I am using only 2 effects in my project, Perfect Space and VC-64

VC-64 is 32bit plugin might be this plug causing this issue???

Share this post


Link to post
Share on other sites

I am a bit confused - if this is the same project we have been referring to in our emails, I am not quite sure if you might be using Melodyne in the project.  I reviewed the emails, and while I understand you have Melodyne in your system, I am not sure if it is in the project or not.  I am also not suggesting Melodyne is causing issues - I just want to make sure we are all on the same page, with regard to exactly which plugins are used in this project.  Can you please clarify?   (I have had zero coffee yet this morning, as well, so am not yet actually functioning particularly well).

Also, I located another thread, from way back in the old forums, that had 2 comments about a loss of audio in 2 projects where they used VC-64, and I didn't include the link here, because they were only noted as 'hmmm' moments - without any additional information to explain anything that might help you.  I DID think mentioning that at least one other person had noticed that they were losing audio here and there in the two projects with VC-64 - perhaps it is worth you looking to use some other plugin, or perhaps consider purchasing J-Bridge (about $20) to try to see if different bridging software helps 32-bit plugins run in a 64-bit Cakewalk by Bandlab environment.

Bob Bone

Edited by Robert Bone
Added better explanation of my questions about Melodyne.

Share this post


Link to post
Share on other sites

Both Perfect Space and VC-64 are 32bit plug-ins that have not been updated in years. I know there are those that treasure their old plug-ins but it is not too late to stop using them.

Share this post


Link to post
Share on other sites

I took a look at the Focusrite Windows 10 Optimization page, as you had mentioned going through some of those suggestions, and one of the suggested optimizations they referenced was about altering Windows 10 to give more priority to Background Services.

Noel Bothwick (he is Senor Sonar, and now Captain Cakewalk - sorry, Noel, couldn't help myself there), has commented in the past, about that particular 'optimization' being not only unnecessary, for Sonar (I would assume this to remain true for Cakewalk by Bandlab), but that it could also make Cakewalk performance worse - some folks have reported Sonar crashing after that optimization was made, with the crashes stopping after reversing that change to Windows processing priorities.

Here is a link from the old forums, discussing that Background Services optimization, going directly to Noel's comments about it:

http://forum.cakewalk.com/FindPost/1239881

I hope that helps - and I am sorry you - and anybody out there - have to deal with conflicting information about what to do or not do, when you are just trying to have the software work well enough to be able to create and finish music production projects. :)  That particular optimization has been WIDELY circulated, and it is one of the unfortunate things about the internet that some things are - not always accurate.  

Bob Bone

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...