Jump to content
KSband

Using a midi expression controller for BiasFx2 in cakewalk

Recommended Posts

I got a Line 6 FBV Express midi foot controller, it has a vol/wah pedal and 4 assignable foot switches. I was hoping to control my BiasFx2 plugin with it, mostly wanted to use the Wah wah pedal effects it has. I have been trying for 2 days to get it to work but I can't get the plugin to receive any midi. This plugin has a stand alone on my desktop too, and it works on there, just not in cakewalk. Strangely I did get one of my organ plugins to work with it using my fishman midi guitar system and the Line 6 pedal, I can switch the Leslie off and on.

Share this post


Link to post
Share on other sites

I do not have the plug-in or hardware to test.

To control any FX plug-in that accepts MIDI input. the plug-in requires

  • Enable MIDI Input selected in the VST drop down in the standard header above the plug-in UI.WBoEAIf.png
  • A MIDI track with
    • its input set to the device sending the MIDI data,
    • its output set to the plug-in and
    • input echo enabled.

The plug-in may require some configuration too, such as mapping the incoming controller data to functions in the plug-in.

Note: Soft synth have "Enable MIDI Input" selected by default, effects do not. Effects that cannot use MIDI data have "Enable MIDI Input" disabled.

 

  • Like 2

Share this post


Link to post
Share on other sites

I just did that but it didn't work, I then configured a midi track with the Line6 as input and Biasfx as output (I had to configure Biasfx as a synth first to do this). Now the pedal moves in the Bias plugin on the other track but it's not making the recorded track Wah wah, not changing the sound.

Share this post


Link to post
Share on other sites

Holy cow, it works! I had switched the effect off. Man this was not easy to figure out. I told myself about five times this morning that I was done trying to do this. 

Share this post


Link to post
Share on other sites

There is no need to ever configure an FX as a synth. This option goes back a long way but has not been necessary since 2013.

All that effectively does is automatically turn on "Enable MIDI Input" at the cost of removing the FX from the FX plug-in layouts and adding the plug-in to the synth layouts.

 

Share this post


Link to post
Share on other sites

But there was no way to add Biasfx as a midi out on a midi track, it wasn't a choice. Is there another way to make it a choice?

  • Like 1

Share this post


Link to post
Share on other sites

Once "Enable MIDI Input" is selected, the first step in my post above, the plug-in is added to all MIDI track output drop downs.

Similar to how selecting "Enable MIDI Output" adds a plug-in to MIDI input drop downs.

Share this post


Link to post
Share on other sites

I didn't find the wah very useful in Bias, I think I'm going to try a real wah in front of the focusrite at some point.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...