Jump to content
  • 0
Misha

Stopped Audio engine, crackle pops in Cakewalk but not in Reaper

Question

Hi Folks.

Got a situation with "stopped audio engine" + crackle / pops in Cakewalk that I can not solve. Crackling, popping, stopping. Before anyone tries to volunteer, please  read  next few sentences. I am not a Reaper user, but downloaded it just to see if the same problem exists in Reaper. I replicated project using same audio interface settings, saved plugin presets and same audio file. These issues do not happen in Reaper. I will stress it again. Same computer,  same hardware, same settings of audio interface. Cakewalk produces "stopped audio engine" + cracks /pops while Realer runs smooth.

 

Tech stuff:

Thinkpad 2.6ghz, 6 core i7

32gb ram. Nvme 1tb samsung ssd.

Audio interface used for this project - Apogee One (last generation)

Settings are ASIO  2048 for the buffer, Safe Mode -ON

Project: 6 muted tracks without plugins in their "bins". One unmuted track.

2 plugins on master bus. Ozone9 with 6 modules and a Lurssen mastering plugin.

Cakewalk-last version.

 

What I tried in Cakewalk:

Multi core processing

Plugin load balancing 

Max buffer in driver

Config file: All three Thread schedules

Config file: extra plugin buffers: tried up to 3000

Tried to reset config file to default too.

Win performance set to Ultimate.

------

Again, given that Reaper plays same file with same plugins even at 512.. and Cakewalk acts up at 2048...on same computer..I am out of ideas what to try.

I gave a basic project example where Cakewalk acts up, this also happens on larger projects as well. If it rings some bells, usually bad stuff starting to happen with use of Izotope plugins, but  also with some combination /amount of instances of the other plugins as well. I feel, "Tweaking"computer should not be the solution as Reaper plays same files with same plugins without issues on same machine.

 

Thank you in advance for your time!

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

16 answers to this question

Recommended Posts

  • 1

John, "It must be a combination of Cakewalk and certain systems or Drivers." about right. But not limited to Cakewalk.  As far as Cakewalk development goes, I am pretty happy with it and especially given price tag, it is gold.

My findings... I went ahead and downloaded StudioOne (Professional), done basic install without all the bells and whistles. To be short,   Studio One also has these pops,stopped audio engine even with max buffers Settings "Dropout protection - Maximum"  + audio interface set to 2048 with "Safe" on. 

 

Long version:

They (studio One) have a pretty cool resource, VST CPU usage per instance monitoring tool (I believe we should have one too!) I loaded whole bunch (10+) Vsts... Dynamic EQs, Compressors, Delays of various brands some with "look aheads" just to see what happens. With exception of Ozone9.  CPU usage showed at around 25% which is normal and everything was working fine... Until I selected Ozone9.... Usage went into 70%+ and...  dropouts occured / audio stopped.

 

It seems... Reaper is using some sort of additional padding or distribution to make it work smoothly. Cakewalk, One does not. Or setting is not optimized.

 

P.S. I tried this in Cake: EnableSetThreadIdealProcessor = False   MixThreadCount = {number of cores minus 1, did not make a difference. At least not very obvious.

 

Evil Izotope?

 

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Thanks,  but that is exactly kind of the reply that I was trying to avoid.

If Reaper works out of the box , without ANY tweaking of computer, why there should be tweaks made to PC for Cakewalk to work "as expected".  Please enlighten me.

Share this post


Link to post
Share on other sites
  • 0

Ohh yes, I can post 20-30 conventional "tweaks" that I tried and untried.  And about 50 more that are part of processes like affinity or a part of multi tweaks such as Shut up windows app etc. I am almost certain it will get to the point of "my tweaks are better than yours"....

I do not think it is related to "tweaks".  One daw works with same combination of files /VSTs , one coughs. Using same hardware... without any operating system tweaks specifically made to benefit one over another. That should be the focus of discussion in my opinion.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Misha said:

Project: 6 muted tracks without plugins in their "bins". One unmuted track.

Muted tracks in CbB load the DAW as much as unmuted tracks because tracks may be unmuted any time even while the transport is running.

Archived tracks are ignored by the DAW.

If the tracks use synths, archived tracks should also have the synths disconnected to completely free up the resources used by the synths.

To disconnect synths use the power button in the synth rack when floated or docked in the multidock, otherwise; use the synth rack settings menu "D" in the image below

Browser.11.1.png

26 minutes ago, Misha said:

I do not think it is related to "tweaks".  One daw works with same combination of files /VSTs , one coughs. Using same hardware... without any operating system tweaks specifically made to benefit one over another. That should be the focus of discussion in my opinion.

It would be nice if it were that simple.

Share this post


Link to post
Share on other sites
  • 0

Try Start + run "control powercfg.cpl,,1" (without quotes) and set CPU Min and Max to 100%

Try disabling C-states and Intel Speedsteep (This is done in the PC's BIOS and the method varies between PCs)

In preferences | Audio | Configuration File try adjusting the following: EnableSetThreadIdealProcessor = False MixThreadCount = {number of cores minus 1} You might like to exit Cakewalk by Bandlab, go to the following folder and make a copy of the AUD.INI file before doing this: %appdata%\Cakewalk\Cakewalk Core

 

Share this post


Link to post
Share on other sites
  • 0

Scook,

Thanks,... while I get to what you hinting at, I do not think that is the case. I can have 30+ track project running smoothly with loads of VST's  and synths... but some projects much more slimmer, especially the ones that have Izotope stuff have these stopped engines, cracks and pops.  .In my basic example,  I mentioned, that there are only two plugins that I have which are Ozone9 and Lurssen.  I believe that most likely it's happening with how Cakewalk handles (newer) Izotope products  in particular but not limited to. I have tried several of Izotope's newer plugins of various nature.  From Vocoder to Neutron - same issues.  Their older plugin that I have (Nectar 2)  works fine. Definitely  has to do with how Cakewalk handles plugins. I can have a huge project, but can track vocals without any issues with low buffers when global FX are turned off. 

Also, Scook... "It would be nice if it were that simple."  I do not know about that... I am more optimistic, and I am willing to investigate further.  If no suggestions in this thread will solve issue, I will choose another  random "competitor" DAW and will try to run  same set of audio files + same VST's with same presets to see if issues are happening there. By then it would be safer to assume that I am correct in my judgement that issue is with Cake. I use Cakewalk non-professionally, but for a very long time.  I do not have any desire to switch DAWs, as Cakewalk has very particular workflow items that are dear to me. I am trying to solve this, and perhaps it will help others too, not bash the software :) 

 Promidi,

Thank you for trying.

The computer tweaks you mentioned I had done long time ago, but these settings in Cakewalk look interesting, that  I have not tried yet:

EnableSetThreadIdealProcessor = False   MixThreadCount = {number of cores minus 1

 

 

 

Share this post


Link to post
Share on other sites
  • 0

You should get an A+ for trouble shooting. 
Sorry I don’t have a solution other than I have seen a few threads like this where Izotope plug ins were doing the same. 

I ran into the same issue when trying the demos. In the end 
I didn’t see the benefits of using them as I’m not a fan of magic tricks to make stuff sound better. I think they might be good tools for people who don’t have a grasp on mastering yet. I found  there’s nothing they do that standard tools can’t do. It’s just a package. 

But that said they should work and I’m sure a lot of people never have issues. It must be a combination of Cakewalk and certain systems or Drivers.


This is a Cakewalk issue if other DAW’s don’t have issues. Cakewalk has old code upon old code. Reaper is probably more streamlined. Be interesting to try on a few other DAW’s like Cubase and Studio one. 

Edited by John Vere

Share this post


Link to post
Share on other sites
  • 0

Excellent investigation you really got to the root of it. I wonder how Izotope fairs on a Mac?  Or with Pro Tools? 
Im going to bookmark this thread for future references when others have this issue. 

Edited by John Vere

Share this post


Link to post
Share on other sites
  • 0

When comparing such issues in REAPER with other DAWs, make sure you disable "Anticipative FX processing". Some other DAWs have similar feature, but not Cakewalk. That feature makes "buffer size" relevant for recording/monitoring only, playback is processed "semi-offline" with specified buffer size (default 200ms, so ~8000 at 44.1kHz).

Check if something is different when plug-in GUI is open/closed. It can be graphics (driver) related issue.

Check DPC system latency when you observe crackle / pops. It can give a hint about problem origin (f.e. plug-in intensively access SSD and related operations block the system, happens with any nominal disk transfer rates).

With switched off Anticipative FX processing, you can use Performance Meter (enable all RT options there) to see what is going on.

Death optimized for audio system can utilize close to full processor power without audio problems, on a "standard" system problems can start appearing with almost idle CPU.  Especially without proper Windows Power Plan.

Share this post


Link to post
Share on other sites
  • 0
On 10/19/2021 at 8:17 AM, John Vere said:

I’m not a fan of magic tricks to make stuff sound better. I think they might be good tools for people who don’t have a grasp on mastering yet. I found  there’s nothing they do that standard tools can’t do. It’s just a package.

The iZotope suites (Ozone, Neutron, Nectar) don't do any "magic tricks" that I know about. As you say, they're just racks of processors, and they can't do anything that other plug-ins can't. With the Mastering Assistant and presets, Ozone is good for doing a quickie job on rough mixes. In my observation, some folks seem to think that everyone who uses Ozone uses it in the same way: hit the button, then accept whatever it comes up with. Maybe the earlier versions of Ozone tended to come up with over-limited and over-hyped solutions? In my experience the Mastering Assistant's suggestions are okay, they never make the thing sound worse, but I prefer the results I get without it. They're not meant to be blindly accepted, they're supposed to put you at a starting point that's further down the road.

As with many or most processors that affect dynamics, the presets (and the results of the wizard) are set up to make the level higher, which makes it impossible to know right away if they're making the sound better. Ozone and T-Racks One became less impressive once I started using Gain Match and MCompare.

There's still a school of thought that says you shouldn't master your own tracks regardless of what tools you use. 🤷‍♂️

Anyway, I like the processors that come in Ozone, Neutron, and Nectar, and their UI design is attractive and functional. I rarely if ever use them because they tend to chew up resources and I get issues like the ones @Misha is seeing.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Folks,

Thank you for replying. Interesting stuff.

azslow3, I thought that "extra plugin buffer size" (or similar wording) in config file in Cakewalk does exactly what you described? Similar to Anticipative FX processing. But did not solve Izotope issues

Erik,

I agree  almost entirely with what you said. I stayed away from Ozone as long as I could :) It was on sale that I could not refuse ... It seduced me.  I like a couple of modules enough to justify purchase. I agree, that overall it is overhyped thing, but for quick fix  it is ok. And individual modules can be very useful.

-----

Since Izotope very aggressively markets their plugins and some of their items are solid value for relatively low cost or free, ( I think they are giving out Ozone elements free now) I believe it is safe to assume they are popular among recording folks... Maybe someone from Cakewalk team can run  Neutron Advanced or Ozone Advanced in Cakewalk on good /average  pro-sumer machine. Something like i7, fast SSD, 32ram and see if anything could be done, so these hungry plugins do not cause Stop Audio Engine so often.

P.S. I can run some crazy NI stuff with multiple instances + Halion, dozen or so audio tracks with all kinds of VST processors  all.at the same time, and everything would be fine. As soon as Izotope stuff is added, hell starts. Only solution I found is to freeze all tracks. But that is not a preferred workflow. 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites
  • 0
7 hours ago, Misha said:

azslow3, I thought that "extra plugin buffer size" (or similar wording) in config file in Cakewalk does exactly what you described? Similar to Anticipative FX processing. But did not solve Izotope issues

ExtraPluginBufs is related to some Cakewalk internals. What exactly it does and how that can affect plug-in stability was not explained by Cakewalk (at least I have not seen any explanation). But it does not magically switch on anticipative processing, Cakewalk always process audio in Real Time.

Share this post


Link to post
Share on other sites
  • 0

azslow3,

I think you are right, because I have not experienced any difference by adjusting that value.

That is why I think it is a good idea for Cakewalk team to investigate if anything can be done to alleviate the issue.

Perhaps Izotope plugins are not the "best" but I think for "mastering" Ozone seems to be one of the most popular VSTs.  The only other one I can think of is Lurssen Mastering Console as a single plugin which I think is the next contender.

Of course it is Izotope's problem, not Cakewalk's,  as no plugin I have tried to this point sucks out so much computer resources.  But again, it would be good to know if anything  can be done within Cakewalk, other than freeze/mixdown to solve this.

Share this post


Link to post
Share on other sites
  • 0

I only have Ozone elements, and it consumes under 1% of (my) one CPU Core...

So, I still recommend first find where the problem is and then decide what to do with it. Easy with REAPER: create new project, add track, add Ozone with preset you want, record arm the track, open performance meter, look at "Total CPU", "RT CPU" and "RT longest-block" (right click and enable corresponding options if you don't see them). Compare numbers with GUI open and closed. You can post Performance meter screenshot here if you have difficulties interpreting the numbers.

Share this post


Link to post
Share on other sites
  • 0

I think I figured this one out..... well at least the cause of my frustrations.  VST3 was the culprit!

Changed out plugins used in the project to VST2, problems are gone.  Everything runs smooth.

I do not know "why" and unless there is a simple fix,   I do not know if I want to know "why" VST3 plugins were acting up.  I see no difference in final result. So will stick to VST2 for now. 

 

Thank you everyone participating in this discussion!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...