Jump to content
NOLAGuy

Problem shortening a track

Recommended Posts

If Ripple Editing is not working then I would respectfully suggest you're doing something wrong

  • Identify where the project ends, as described earlier
  • Select all
  • In the timeline, drag across where YOU want it to end and the actual end
  • Turn on Ripple Edit
  • Hit delete
  • Turn off Ripple Edit
  • Like 2

Share this post


Link to post
Share on other sites
6 hours ago, Bristol_Jonesey said:

If Ripple Editing is not working then I would respectfully suggest you're doing something wrong

  • Identify where the project ends, as described earlier
  • Select all
  • In the timeline, drag across where YOU want it to end and the actual end
  • Turn on Ripple Edit
  • Hit delete
  • Turn off Ripple Edit

Always possible that I am indeed doing something wrong. To be clear, although the overall problem related to the song not stopping until the end of the longest track, which was about 90 measures beyond the desired end of song, the specific problem I was  referencing was deleting the end parts of a single track (which was generated by a CAL routine). When I would highlight a section at the end of the track, the EDIT menu had the Delete options grayed out. Doing the same process with Ripple Edit turned on, I highlighted the same section of the selected track, and went to the EDIT menu, which did not have the Delete options grayed out, but selecting Delete (or Delete Special) did not delete the highlighted section of the track. The highlight went way, but the track was the same length as before. I have taken this project, removed all the plugins and audio sections, and have it ready to send to Cakewalk Support.

But before I do so, however, I will try doing the steps exactly as you list and see if the longest track(s) get reduced in total. I will try using both the Edit Menu option and also using the keyboard Delete key, since your steps didn't specify which. UPDATE: Tried this and could not get it to work.

If that works for the song, I would still question, though, why a section at the end of a track, (noting that I did not create the track(s)), cannot be highlighted and deleted using either the EDIT Menu Delete option, or using the Ripple Edit option. 

Thank you for your suggested sequence of steps. Always trying to learn the correct (and best) ways to use Cakewalk. I also need to learn how to capture a video of a sequence of steps in Cakewalk to help others find the problem.

UPDATE: I have attached a modified copy of the problem project. Took out all the audio, plugins, and left only the MIDI. If anyone has the time, you are welcome to load the file and try to shorten the tracks that go out to Measure 170. If you get it to work, Please send me the step-by-step workflo, including menu options.

I am using the Cakewalk 2021.06 Build 041 (64-bit) to try but also didn't work for me in the previous production 2021 build.

 

Cakewalk End-of-track Delete Prob.cwb

Edited by NOLAGuy
Updates

Share this post


Link to post
Share on other sites
13 hours ago, NOLAGuy said:

UPDATE: I have attached a modified copy of the problem project. Took out all the audio, plugins, and left only the MIDI. If anyone has the time, you are welcome to load the file and try to shorten the tracks that go out to Measure 170. If you get it to work, Please send me the step-by-step workflo, including menu options.

I must admit, I am baffled too.  However, I was able to get it working, by bouncing to clips:

I selected all the clips (Ctrl+A) and then right-clicked on any clip and selected Bounce to Clip(s).

 

BTW, I really enjoyed your catchy tune!

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, tparker24 said:

I must admit, I am baffled too.  However, I was able to get it working, by bouncing to clips:

I selected all the clips (Ctrl+A) and then right-clicked on any clip and selected Bounce to Clip(s).

 

1 hour ago, Bristol_Jonesey said:

Yes that is odd.

Bouncing to clips works without even having to invoke Ripple Edit

Gentlemen... Thank you both for the help in reviewing my problem and providing a solution that I was unaware of!

I guess sending this project file to Cakewalk Support would still be beneficial for them to check why Ripple Edit does not (appear) to work in shortening these generated Cakewalk generated tracks. Given the power of Ripple Edit, I can't be sure if it's something in my CW (or project) setup preventing RE from reducing the length of a track, my limited experience with using RE, or a possible quirk in Ripple Edit.

Share this post


Link to post
Share on other sites
2 hours ago, tparker24 said:

BTW, I really enjoyed your catchy tune!

It's actually an oldies tune that I found a MIDI file for. My hobby is enjoying creating vocals around oldies songs, and modify the MIDI's to add dynamics and customizations using synths and audio plugins. Sorta my personal "karaoke" backing-tracks! I also use Band-In-A-Box to develop new backing track styles totally different from the original songs, especially with their thousands of available styles recorded using real musicians., and ability to completely customize the results. I believe the music jargon is creating "covers" for these songs. Being retired and single, I got way more time than money, so spend hours in my music studio tinkering with songs and vocals.

Music Studio.jpg

  • Like 2

Share this post


Link to post
Share on other sites

I looked at the project. Before I fix the problem, tell me where the observed project end time is and what time you'd like it to be. I show the track labeled "Split Note F#3" to be the longest, ending at 5:26. Is that what you see?

Share this post


Link to post
Share on other sites
4 hours ago, tparker24 said:

Nice studio!

So what was the name of that oldies tune that you were covering?

Sorry... That would be "Let Me Be There", recorded by several artists but my fav was Olivia Newton John's recoding. Here's a Utube vid of her performing... https://www.youtube.com/watch?v=9UcTCYmoQTQ

Share this post


Link to post
Share on other sites
55 minutes ago, bitflipper said:

I looked at the project. Before I fix the problem, tell me where the observed project end time is and what time you'd like it to be. I show the track labeled "Split Note F#3" to be the longest, ending at 5:26. Is that what you see?

Thanx... Not at home right now, but the first couple tracks define the song and I think the longest track in the first 4 tracks was around 90 measures.

Yes... All the tracks labeled "Split Note XXX" are the tracks generated from the CAL routine, and those were the tracks I needed to shorten.

Earlier, a solution was offered to select the too-long tracks and "bounce to clips". Haven't yet tried that myself but the poster said it works.

Again, the core problem is why neither the EDIT Menu Delete nor Ripple Edit seems to not work shortening those "Split Note .,.." tracks.

 

 

Edited by NOLAGuy
update

Share this post


Link to post
Share on other sites
2 hours ago, bitflipper said:

I looked at the project. Before I fix the problem, tell me where the observed project end time is and what time you'd like it to be. I show the track labeled "Split Note F#3" to be the longest, ending at 5:26. Is that what you see?

I looked at the project and it can stop at Measure 98 (3:00). Yes, the longest track is the Split Note F#3 track ending at ~5:27.

Share this post


Link to post
Share on other sites
11 hours ago, tparker24 said:

I must admit, I am baffled too.  However, I was able to get it working, by bouncing to clips:

I selected all the clips (Ctrl+A) and then right-clicked on any clip and selected Bounce to Clip(s).

 

10 hours ago, Bristol_Jonesey said:

Yes that is odd.

Bouncing to clips works without even having to invoke Ripple Edit

Folks... wanted to update you on the "Bounce to Clips" solution. Itried it on the test file I sent y'all and yes it both shortened the tracks and also set the project endpoint at the end of the longest desired track. That test file was only MIDI.

I then tried the same on the original project with the audio files and plugins. The "Bounce to clips" again shortened the too-long tracks to the desired length, BUT it did not set the Project endpoint at the desired length. A CNTL-END takes the top green marker section all the way to where the original way-too-long track ended. I manually reset the song length (green shaded area in the timeline) to the desired length, saved the file, and did an export to Audio (WAV) file. The exported file, as before, ignored the mannuall set song length and the resulting WAV file was over 5 min long instead of 2:58.

So I'm back to correcting that issue using various workarounds which I've done before, because of the often discussed issue on this forum of not being able to set a "hard stop" /project-end marker in Cakewalk.

So again, thank you for all the help and providing the "Bounce to clips" solution for shortening tracks, which I've now added to my bag-of-tricks.

  • Thanks 1

Share this post


Link to post
Share on other sites
2 hours ago, rfssongs said:

Have you tried moving the tracks one by one clipped to the length you want ?

No, have not. I'll try and see if that changes anything different from the Select All then Bounce to clips.

Share this post


Link to post
Share on other sites
13 hours ago, NOLAGuy said:

I looked at the project and it can stop at Measure 98 (3:00). Yes, the longest track is the Split Note F#3 track ending at ~5:27.

Yup, CW thinks the project ends at 5:27, even though the last MIDI event (pedal up) occurs at 2:54:17. The longest clip contains a single MIDI note at 2:32. Clearly, the clip length as defined in the cwp file does not reflect the actual distribution of events within the clip. This is not an uncommon  occurrence.

This is because within the project, clips are their own objects with their own start and end times not necessarily correlated to the data within them. 

You can see this via the following experiment. Create a new MIDI track and open it in the PRV. Draw in a note, and watch a visual representation of the clip appear in the track view. Add a second note and see that the displayed representation of the clip automatically stretches to encompass both notes. Now delete the last note. The apparent length of the clip as visualized in the track view does not change. This is a routine performance optimization - you wouldn't want the program to have to scan the track to determine its effective endpoint every time you make an edit. Plus sometimes you'll intentionally want the clip to extend beyond the last note, e.g. so a long release doesn't get truncated.

Fortunately, there is an easy solution: the slip edit. That's what the feature is for, to let the user determine where the clip starts and ends irrespective of the data behind it. I did that with your project, no problem. Note that it can be difficult to get the slip-edit cursor(s) to show when the track is minimized. Try vertically expanding those too-long tracks before hovering your mouse over the trailing edge of the displayed clip to see the cursor. Drag the end of the clip back to where you want it to end. 

For the most part, however, trimming clips isn't necessary before exporting the entire song. Just use start and end selection points as I described earlier in this thread. If a long clip bothers you, use a slip edit and bounce. 

  • Like 1

Share this post


Link to post
Share on other sites

@bitflipper  First of all...Thank you for taking your personal time to review the problem project I uploaded!

I had never used Slip Editing before, but with your discussion and the entry in the CW Reference Manual beginning on p518, it appears to be a very straightforward solution to the issue that I raised as well as potentially useful to keep in one's toolkit relating to clips.

Your explanation also provides a reason why neither standard Track editing nor Ripple Edit worked on these tracks, which is also useful to understand.

With the earlier suggestions from @scook and others in the Forum on better alternatives to use of the CAL "Split a combined MIDI drum track into seperate tracks", I will be able to avoid the process that led to the strange drum track lengths.

Now, on to making the described modifications to the full audio and plugins version of the simplified project I submitted for analysis.

Share this post


Link to post
Share on other sites
On 6/30/2021 at 11:39 AM, bitflipper said:

For the most part, however, trimming clips isn't necessary before exporting the entire song. Just use start and end selection points as I described earlier in this thread. If a long clip bothers you, use a slip edit and bounce. 

This is a great idea but I'd like to add one small thought to add to that.

If you set up one arranger track the entire length of the intended length of the song and if you have set select events with selections then just clicking on that once will select all of the tracks & the length you need for export. (see below)

Normally Ctrl A works nicely for that but in the case of a length problem the Arranger track will provide a nice shortcut.

image.png.cf3f3995b855d256692af255ba6fc4bf.png

 

 

  • Like 1

Share this post


Link to post
Share on other sites
On 7/2/2021 at 3:50 PM, rfssongs said:

If you set up one arranger track the entire length of the intended length of the song and if you have set select events with selections then just clicking on that once will select all of the tracks & the length you need for export. (see below)

Normally Ctrl A works nicely for that but in the case of a length problem the Arranger track will provide a nice shortcut.

image.png.cf3f3995b855d256692af255ba6fc4bf.png

@rfssongs ...

I've been trying your arranger track tip, but with no success. I'm likely not doing something correctly. If you get time, would you provide a step-by-step instruction on setting up the arranger track the way you were able to make it work? If I can get that to work, twould be a real timesaver.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...