Jump to content
Count Vlad

Komplet Kontrol Krap

Recommended Posts

Posted (edited)

Hello, I have been at my wits end with Komplet Kontrol and Kontrol 6 plugins.  The regular instruments (TTS-1, SI,  Dimension LE, etc.) that come with Cakewalk all work wonderfully well and I never have any dread with them mis-performing.  With the Native Instruments (Kontrol) that is all they do!  Here is a list of my concerns:

1) Sometimes they (Kontrol) will play the midi notes and other times NOTHING!   And I didn't touch any settings.  They just have a mind of their own when they want to play.

2) Sometimes they (Kontrol) will not play imported midi lines, but if I write in a note prior to the imported midi line, it will be heard.  The imported midi lines following that note will not be heard.

3)  When I'm looking for the midi output on a Kontrol instrument it is impossible to find.  That is very essential -- KRUCIAL! -- not the many different screens you have to wade through to find the output section.   On top of that, it is even hard to find the right screen to get rid of that plugin.   Too much useless information with small fonts hidden somewhere on a big screen amongst many screens.   

4)  Also if I bring in a library of sounds not by Komplet Kontrol (but using it as a host) it too will be plagued with these setbacks.

So if someone can suggest any solutions that would be great.  I am at the point where I'm really starting to hate these guys... especially now that their commercials are following me around.  They have impressive commercials -- very sophisticated and professional looking state of the ART -- but the reality for me is quite the opposite.   Thanks.

 

 

 

Edited by Count Vlad

Share this post


Link to post
Share on other sites
Posted (edited)

Re 1-Check this setting in cake Edit-Preferences-MIDI-Other Options and uncheck “Zero Controllers When Play Stops” if it is checked. Also in kontakt there is a setting for each instrument that must be unchecked or it will or might go silent as well with any press of spacebar etc. not at my computer right now but it is in the box if you click the wrench thingy and i think the third box down needs to be unchecked too if you lose sound. On each instrument not once and done. 

Edited by treesha
Correction

Share this post


Link to post
Share on other sites

Thanks treesh for the suggestions.  Nothing has changed.  It has a mind of it's own and sometimes it is playing notes that are not there in the score.  It's the not-so-friendly ghost in the machine.  I looked for the wrench... and I can't find it anywhere, but I vaguely recall see it.  Where I don't know.  Maybe I'll find it one day when I'm not in a pissed off mood and go calmly back to Kontrol.  Thanks again!  

Share this post


Link to post
Share on other sites

I will find the wrench next time i am on my music computer unless someone tells u before i do. Its on kontakt around the top of an instrument on the left side.  

Share this post


Link to post
Share on other sites
Posted (edited)

I still can't find the wrench.   Here is a picture what I am seeing.  Thanks.

Screenshot (1).png

Edited by Count Vlad

Share this post


Link to post
Share on other sites

Unless you've got a Komplete Kontrol hardware controller,  I personally find very little use for Komplete Kontrol at all.

IMO you're much better off just inserting Kontakt 6 directly as either a Simple Instrument Track, Per-Output Instrument Track (my personal preference), or a Split Instrument Track.

The settings wrench  @treesha is referring to is here (it's actually a gear icon, which may be the source of the confusion):

image.png.e6514dad464fd4ec1692f1428224a9a9.png


You may also see it here:

image.png.90bbda841e49f914be944af168f8c7e4.png

Disabling "Zero Controllers When Play Stops" is important however when using certain Kontakt libraries, as they've broken the MIDI rules and assigned the mod wheel to things like cut-off filter.

Share this post


Link to post
Share on other sites

Thank you all.  This is starting to make sense.   Treesha said to uncheck a setting and I am assuming it is the "Accept all notes off / all sounds off"  that is in the controller part of the instrument options page (the wrench/gear)(see picture).  If not, please advise what I should be switching off (I'm assuming "off" is when the patch is dark colored).  Mark, I do use Kontrol as a single instrument -- the simplest way so far, but even with that I'm having these problems.        

Screenshot (2).png

Share this post


Link to post
Share on other sites

Finally on my music computer, busy week.. so here is what I found on the NI site when I initially had the problem in Kontakt 

"KONTAKT's Volume Resets When I Press Play in my Host Sequencer

Symptom

KONTAKT's Instrument volume is reset when you press play or stop in your host sequencer.

Cause

Some host sequencers are configured to send MIDI commands CC7 and CC10 when you press play or stop. KONTAKT can be configured to respond to these standardized commands to reset the loaded Instrument's volume.

Solution

Follow these steps to prevent KONTAKT from reacting your host sequencer's play / stop commands:

Load an instance of KONTAKT in your host sequencer.

Load an Instrument to KONTAKT's Rack.

Press the wrench button on the upper left side of your KONTAKT Instrument.

Click Instruments Options.

In the Controller tab, disable the option Accept Standard Controllers for Volume and Pan.

You can alternatively configure your host sequencer not to send the standard MIDI commands CC7 and CC10 when pressing play or pause. To learn how to do so, please consult your host sequencer's documentation."

So yes, if the box is unchecked it is dark color. I didn't know about the gear in Komplete Kontrol cause I seldom use it, so I learned something new. 

So between the setting to check in cakewalk and the box in NI, most of the time the unwanted volume changes stop for me.  I haven't had any problems with KK or K playing midi. I agree it is a complicated program(s) and after a year almost I am still learning. 

If you are having many specific KK or K problems maybe posting on the NI site forum would help. I have gotten some help there.  

  • Like 1

Share this post


Link to post
Share on other sites

The biggest problem with some of the newer NI Kontakt libraries ( like Hybrid ) isn't CC7 / CC10... it's CC 1 (Modulation Wheel).

For some crazy reason they've bound it to filter cut-off frequency.  When CC 1 is reset to its default (which from the MIDI spec is zero - bear in mind in most synths modulation is usually tied to the LFO for vibrato, so you actually want it off), it sets the cut-off frequency to 0Hz.  So no sound whatsoever comes through.

There's two workarounds:
1. Turn off "Zero Controllers When Play Stops"
2. Insert a CC 1 / 100 (or whatever you want your cut-off frequency to be) at 1:01:000 within your MIDI track.

  • Like 1

Share this post


Link to post
Share on other sites

Thank you Treesha and Mark.  I will give the advice a go and see what develops.  I will start with disabling the controller.  I don't have a problem with volume, so I'm good that way.  My one non-Kontrol (BBC Spitfire Orchestra) library is playing notes that aren't there -- no notes on the page -- so I'm thinking maybe it's something to do with cakewalk.  I'll also check out the NI forum, if things don't work out... or hire an exorcist to remove the evil spirits! 

Share this post


Link to post
Share on other sites
4 hours ago, Count Vlad said:

Thank you Treesha and Mark.  I will give the advice a go and see what develops.  I will start with disabling the controller.  I don't have a problem with volume, so I'm good that way.  My one non-Kontrol (BBC Spitfire Orchestra) library is playing notes that aren't there -- no notes on the page -- so I'm thinking maybe it's something to do with cakewalk.  I'll also check out the NI forum, if things don't work out... or hire an exorcist to remove the evil spirits! 

Playing notes that aren't there sounds like you've got MIDI Out enabled on one of your VSTi's.   

You can check for software synth MIDI outs by looking at the MIDI Input filter on any MIDI track.  Anything that appears between your hardware MIDI In's and the Virtual Controller are software MIDI outs, e.g:

image.png.a7d5a94b830b638f5f8c9fbc83d6f087.png

To disable the MIDI out, open that softsynth and uncheck it in the VST drop down menu:

image.png.fde37f586561ff595274e1394676d8b9.png

I've used SI Drum Kit as an example here, but all VSTi's have that menu.
 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...