Jump to content
G Randy Brown

SOLVED! - CbB won't release drivers for me

Recommended Posts

Posted (edited)

It's been a while since I've used CbB but I've recently noticed CbB won't release the drivers after I close the project.

I have to reset the audio or restart the PC to get back to normal.

As I recall CbB didn't want to share drivers when in use but would always release them when closed.

I've gone thru prefs and dont see an issue...any suggestions as to what I should do?

Edited by G Randy Brown
  • Confused 1

Share this post


Link to post
Share on other sites

Yes, sometimes it happens to me too, but not all the times.

There is a workaround: open Task Manager - find the cakewalk icon - select it - select End Task .

It should release the driver, so you don´t need to restart your PC.

  • Confused 1

Share this post


Link to post
Share on other sites

There is ongoing discussions about these issues. Killing the process in TM never works for me.

You're right about Cake not wanting to share audio devices. I only use an outboard interface with CbB, but it won't open at all even if another application is already using the onboard sound.

Share this post


Link to post
Share on other sites

Wow, well hopefully support is working on it...it must have broken with an update because I've never seen this in the 19 years I've been using CW.

Share this post


Link to post
Share on other sites

I think it's more to do with the drivers for your audio interface than Cakewalk. Example I have no issues when using my much older Scarlet interface. I can leave Cakewalk open and go watch a movie.  It supports all diver modes etc. But my brand new Motu M4 behaves terribly with sharing. And it only supports ASIO and WASAPI. 

I have to shut down Cakewalk now before opening Movie Maker or watching some videos. I imagine this is due to sample rates. In other words, Cakewalk is running at 44.1 and you can't do anything else that is running at 48. But I have no Idea why this is not a problem for my Focusrite. You do hear a little click when it switches. 

Share this post


Link to post
Share on other sites
19 minutes ago, John Vere said:

I think it's more to do with the drivers for your audio interface than Cakewalk. Example I have no issues when using my much older Scarlet interface. I can leave Cakewalk open and go watch a movie.  It supports all diver modes etc. But my brand new Motu M4 behaves terribly with sharing. And it only supports ASIO and WASAPI. 

I have to shut down Cakewalk now before opening Movie Maker or watching some videos. I imagine this is due to sample rates. In other words, Cakewalk is running at 44.1 and you can't do anything else that is running at 48. But I have no Idea why this is not a problem for my Focusrite. You do hear a little click when it switches. 

Hmm I could have sworn that I used to always run 24/48 even in CW  (to be consistant with all of my video work) but it appears you are right and your suggestions have resolved my issue.

I hit the ASIO Panel button under drivers and my Presonus Studio 2/4 was set to 44.1.

I changed it to 48 and within a couple of seconds it switched back.

I set CW to 44.1 and all is well so thanks very much!

  • Like 1

Share this post


Link to post
Share on other sites

I wished I had stayed with 48 back when. Now I'm working with video the 44.1 is a PITA. I had to use 44.1 because that's all my Yamaha 01V mixer supports and I was using it for the digital connection.  44.1 also made sense in the making a CD era too. But now everything I do is either a MP4 or a MP3. I still burn CD's for proofing in the car but it's pretty easy to just change Cakewalks export to 44.1 / 16. 

Anyhow, glad it worked for you. 

Share this post


Link to post
Share on other sites

Please edit the OP and update the subject with [Solved]

thanks

Share this post


Link to post
Share on other sites

I closed my video production company a couple years ago and don't take on any serious work nowadays but I feel sure I used to always run Vegas and Sonar in 24/48 and like you only used 44.1 when having to do things like CDs (thank god those days are gone 😄)

Share this post


Link to post
Share on other sites
2 minutes ago, scook said:

Please edit the OP and update the subject with [Solved]

thanks

I'll do that Steve even tho I don't feel it's actually "solved"...not sure why I can no longer run 24/48.

Share this post


Link to post
Share on other sites

You can, try setting Windows and CbB to the same sample rate.

If they are already set to 48 then some other apps are setting it 44.

Hunt done the apps and change them (it may be your browser).

 

Share this post


Link to post
Share on other sites
5 minutes ago, scook said:

You can, try setting Windows and CbB to the same sample rate.

If they are already set to 48 then some other apps are setting it 44.

Hunt done the apps and change them (it may be your browser).

 

As usual you are right Steve, I started a new  cwp and CW had no problem sticking with 24/48.

I guess my next task will be to find out what kept switching it back to 44.1...but it's good to know it's not due to CW.

Thanks again,

Randy

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...