Jump to content
Sign in to follow this  
NealClark

Insert Instrument Tracks

Recommended Posts

Posted (edited)

I mentioned in the feedback thread a while ago that the behaviour of the "Insert Instrument Track" function was behaving strangely. I was advised at the time by one of the developers that the way in which instruments tracks were added had been changed to make it consistent with the Insert Audio and Insert MIDI tracks functions. However this "New and Enhanced" behaviour is driving me nuts as it doesn't work as it did, doesn't work as it should or indeed doesn't even work consistently the same way.

I've created a short video showing how odd this behaviour is.

Can one of the developers please explain how this "insert above current track" is in anyway a step forward and why it doesn't work consistently or as explained.
 


 

Edited by NealClark

Share this post


Link to post
Share on other sites

I like consistency, too, but I have learned that often one person's improvements make extra work for someone else.  So, I got used to moving some inserted tracks back down to the bottom where they were previously, in or out of a folder, deleting extra tracks and/or instances, etc.  Gives me practice in being flexible--or following the advice of my mom: "Go with the flow."

While I don't look forward to another change here, its nice to have the heads up so its not a surprise.  🙂

Share this post


Link to post
Share on other sites

The inconsistency here is the right  click -> Insert Instrument behaviour on a blank space in the track view.  It should add the track at the end in this case, as it does with audio & MIDI tracks.

Right clicking on a track however, is a different case, as you are inserting in context with an existing track.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...