Jump to content
cclarry

Windows 10 DAW Tweak Guide (Unofficial)

Recommended Posts

good timing ...I have a new PC that I need to optimize after I install new SSD's and RAM upgrades... 

Share this post


Link to post
Share on other sites
Posted (edited)
29 minutes ago, mcmd said:

good timing ...I have a new PC that I need to optimize after I install new SSD's and RAM upgrades... 

or not...
As the 3rd article explains many optimization tweaks are based on XP era hardware.

Edited by TheSteven

Share this post


Link to post
Share on other sites
1 hour ago, craigb said:

Just in time for Windows 11!  LOL.  😆

The best way to tweak W11 is install W10 over it.

  • Great Idea 1
  • Haha 5

Share this post


Link to post
Share on other sites
2 hours ago, TheSteven said:

or not...
As the 3rd article explains many optimization tweaks are based on XP era hardware.

I don't even bother with these "tweaks" anymore.  Most of them are already done.  Most machines don't need this anymore.

  • Like 2

Share this post


Link to post
Share on other sites

I know I won't be going to Windows 11 for at least a couple of years.  My friend's company decided to make the upgrade last week and now he's lost 1.5 years worth of data!

Arrgh-facepalm-gorilla.jpg

  • Sad 3

Share this post


Link to post
Share on other sites
9 hours ago, craigb said:

I know I won't be going to Windows 11 for at least a couple of years.  My friend's company decided to make the upgrade last week and now he's lost 1.5 years worth of data!

Arrgh-facepalm-gorilla.jpg

Not my experience. I upgraded without any kind of problem whatsoever 

  • Like 2

Share this post


Link to post
Share on other sites
Posted (edited)
10 hours ago, Paul Young said:

I don't even bother with these "tweaks" anymore.  Most of them are already done.  Most machines don't need this anymore.

Yep. Do lots of mobile work on laptop. The only thing I tweaked were power settings - eg. to stop the CPU from throttling or cycling through power states, and a couple USB power settings. Battery / AC power switching is really the only problem I've found. Run 150 track projects no problem now. On my desktop it's maybe 2 tweaks to power settings and it runs 100% without issue. Actually, the Steinberg Power Profile is probably just fine, but I like to customize a little bit because I max overclock my CPU 24/7. Windows 10 is very efficient in my experience.

Edited by Carl Ewing
  • Like 2

Share this post


Link to post
Share on other sites
1 hour ago, Yan Filiatrault said:

Not my experience. I upgraded without any kind of problem whatsoever 

Same here. It's been a very clean upgrade.

Share this post


Link to post
Share on other sites

Any AMD specific tweaks out there? I bought a Dell Aurora with AMD Ryzen 5950x and projects are way more glitchy than my 5 year old Aurora with Intel 8700k. Both overclocked. Really frustrating!

Share this post


Link to post
Share on other sites
1 hour ago, tom said:

Any AMD specific tweaks out there? I bought a Dell Aurora with AMD Ryzen 5950x and projects are way more glitchy than my 5 year old Aurora with Intel 8700k. Both overclocked. Really frustrating!

Definitely check power settings. Any sort of power switching (i.e. throttling, minimum / maximum power states) will cause tons clicky weirdness as the computer tries follow power states. It's the source of many many problems with both Intel and AMD processors. Even if you're OC'd from the motherboard, the OS still has lots of control over the CPU (and CPU, GPU, etc. power).

Go to Power & Sleep Settings, then to "Related Settings / Additional Power Settings". Switch to "High Performance" and then "Change Plan Settings". Then go to "Change Advanced Power Settings"  and see what's available. You should see a setting for "Processor Power Management", and under that "Minimum" and "Maximum" processor state. Set both to 100% and see if that fixes anything.  (Consumes more power, but ensures CPU is rock steady.)

In the same window you'll see "USB Settings / USB selective suspend". Disable that. Also grab all updates from your MOBO manufacturer. Especially chipsets, BIOS, hard drive controllers, and USB controller drivers.

Also check for power options in your BIOS. Not sure about AMD, but Intel geared motherboards often have a lot of weird power settings. Intel Speed Step, Intel C-States, and other crap that mess with CPU throttling / speed. AMD may have the same. Try to get rid of anything that's messing with CPU speed / power. And check temperatures regularly when doing all this. :)

  • Like 1

Share this post


Link to post
Share on other sites

For Pro Tools, if you have one of the officially supported machines you can get recommended BIOS settings from the list at https://avid.secure.force.com/pkb/articles/compatibility/Pro-Tools-System-Requirements. For other machines you would need to read through the recommended settings for supported machines and translate them to your machine. The TLDR is pretty much what @Carl Ewing mentioned - disable the settings that can mess up the timing (the machine's gaming and overall performance will suffer after turning off all the tweaky boosts that cpu makers use, but your audio will be more stable)

Share this post


Link to post
Share on other sites
5 hours ago, Carl Ewing said:

Definitely check power settings. Any sort of power switching (i.e. throttling, minimum / maximum power states) will cause tons clicky weirdness as the computer tries follow power states. It's the source of many many problems with both Intel and AMD processors. Even if you're OC'd from the motherboard, the OS still has lots of control over the CPU (and CPU, GPU, etc. power).

Go to Power & Sleep Settings, then to "Related Settings / Additional Power Settings". Switch to "High Performance" and then "Change Plan Settings". Then go to "Change Advanced Power Settings"  and see what's available. You should see a setting for "Processor Power Management", and under that "Minimum" and "Maximum" processor state. Set both to 100% and see if that fixes anything.  (Consumes more power, but ensures CPU is rock steady.)

In the same window you'll see "USB Settings / USB selective suspend". Disable that. Also grab all updates from your MOBO manufacturer. Especially chipsets, BIOS, hard drive controllers, and USB controller drivers.

Also check for power options in your BIOS. Not sure about AMD, but Intel geared motherboards often have a lot of weird power settings. Intel Speed Step, Intel C-States, and other crap that mess with CPU throttling / speed. AMD may have the same. Try to get rid of anything that's messing with CPU speed / power. And check temperatures regularly when doing all this. :)

Many thanks for all that. Thats actually the tweaks I do, theres a very good list that Acustica put out which I follow:

 

https://confluence.merging.com/display/PUBLICDOC/Windows+10+Configuration

 

I have done these tweaks to both my machines but the AMD is performing worse. I reckon there must be something AMD specific I need to do

Share this post


Link to post
Share on other sites
Posted (edited)
9 hours ago, tom said:

Many thanks for all that. Thats actually the tweaks I do, theres a very good list that Acustica put out which I follow:

 

https://confluence.merging.com/display/PUBLICDOC/Windows+10+Configuration

 

I have done these tweaks to both my machines but the AMD is performing worse. I reckon there must be something AMD specific I need to do

Okay - checked some forums on overclocked 5950x and audio problems and most of the discussion was over RAM speed / timings. Specifically when using DCOP to auto overclock. Many needed to set their RAM back to default speed, or manually adjust timings (FCLCK) until they got stability. Seems the auto overclock was creating timing or voltage issues for both the CPU and memory. Do you get the same audio problems when not overclocking? If not, this might help narrow the problem down to overclock settings.

Edited by Carl Ewing

Share this post


Link to post
Share on other sites
Posted (edited)
17 hours ago, Eusebio Rufian-Zilbermann said:

the machine's gaming and overall performance will suffer after turning off all the tweaky boosts that cpu makers use, but your audio will be more stable

I think that may be a key point that many folks do not realize. A good gaming machine does not automatically mean a good DAW machine. But it can likely be wrangled into proper DAW form with a bit of care. :)

Stable real time audio processing is a bit more tricky than FPS in games, or even video editing.

Edited by abacab

Share this post


Link to post
Share on other sites
12 hours ago, Carl Ewing said:

Okay - checked some forums on overclocked 5950x and audio problems and most of the discussion was over RAM speed / timings. Specifically when using DCOP to auto overclock. Many needed to set their RAM back to default speed, or manually adjust timings (FCLCK) until they got stability. Seems the auto overclock was creating timing or voltage issues for both the CPU and memory. Do you get the same audio problems when not overclocking? If not, this might help narrow the problem down to overclock settings.

Wow thank you so much for the further research, when back in studio will look into this. I have the stock RAM (2666mhz) and I think upgrading RAM will improve things too 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...