Jump to content
  • 0
Richard L. Baumann

A short and simple one-track clip changes tempo for no apparent reason

Question

The attached MIDI file opens in Cakewalk for Bandlab.  It consists of only one short track that has no events other than note events, as evidenced by Event List view.  At about three seconds into the clip, the tempo slows down.  I haven't been able to find anything in any view that would seem to have anything to do with tempo setting.  Can anyone see anything that could cause the tempo change?

Johnny's song original.mid

P.S. When it is opened in any other application that plays MIDI files, such as Windows Media Player or VLC media player, it also slows down.  So the problem doesn't seem to be something in Cakewalk  by Bandlab, but Cakewalk provides the clearest views of the MIDI file in several different windows, including Event List view, where anything problematic about the file itself would be expected to be visible, but nothing shows up.  Very puzzling.

 

Edited by Richard L. Baumann
provide additional information and correct one grammar error

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Hi Richard,

I downloaded the linked MIDI file.

When I play it with a media player, like you say, there is a tempo change.

If I then drag the .mid file into  a blank CbB project I get two tracks, not one, and the project's default tempo of 120BPM is not changed. I perhaps need to check my import settings.

I then dragged the same file into REAPER and, again, I get two tracks, not one, and there is a tempo map associated with the .mid file.

I then tried right clicking on the .mid file in Windows Explorer and chosing "Open with > Cakewalk application," and this time I get a project with two tracks, again, and there is also a tempo change.

If you open Views>Tempo (Alt+Shift+5) you can see the tempo map there, and can edit it:-

image.png.4d9473ebce45224881c10f2d63f6bf04.png

 

cheers

andy

 

Share this post


Link to post
Share on other sites
  • 0
16 minutes ago, synkrotron said:

If I then drag the .mid file into  a blank CbB project I get two tracks, not one, and the project's default tempo of 120BPM is not changed. I perhaps need to check my import settings.

Importing MIDI into CbB strips tempo information. Imported MIDI data follows the project's tempo map.

17 minutes ago, synkrotron said:

I then tried right clicking on the .mid file in Windows Explorer and chosing "Open with > Cakewalk application," and this time I get a project with two tracks, again, and there is also a tempo change.

Opening MIDI files in CbB preserves tempo data.

Share this post


Link to post
Share on other sites
  • 0

Yeah, @scook, having checked my CbB preferences I couldn't find anything that would affect import of .mid files, so I deducted the above. It's probably in the manual somewhere but that involves reading!

cheers

andy :)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...