Jump to content
jono grant

No midi input after installing latest update

Recommended Posts

Hi, I just installed the latest Cakewalk update.

Now I have no midi input. Settings are the same

Please help!

Thanks

Jono

Share this post


Link to post
Share on other sites

I disabled some other midi devices to test and got my keyboard controller working again.

Something in the new update is messing things up though. I see some new features. Something in inputs now called "External" Not sure what that is yet.

Thanks

J

Share this post


Link to post
Share on other sites

Read the release notes there was a change made with how midi inputs are handled to prevent loopback from vst's that have midi output enabled. 

Share this post


Link to post
Share on other sites
1 hour ago, John Vere said:

Read the release notes there was a change made with how midi inputs are handled to prevent loopback from vst's that have midi output enabled. 

hi John.  I read that as well. Does that mean I don't have to turn off Midi output on my NI instruments anymore? First few times that happened I had no idea where all the random notes were coming from. (only happens on NI.)

Share this post


Link to post
Share on other sites

I believe so, don't quote me on that one. I just remember reading about it. Here, lets tag @scook and he can clarify for you. He can actually decipher the release notes. 

In the 100 years I've used Cakewalk I have only JUST started reading those release notes. But like most, half of it goes in one ear and out the other.. I am constantly having to re discover how things work. I just watched one of my own older videos and in that I double clicked on the Multi dock tab and it opened full screen!! In a video I just made I'm fumbling around dragging it here and there.  Use it or loose it .  Cakewalk is complicated, lets face it. 

Share this post


Link to post
Share on other sites
52 minutes ago, Michael Fogarty said:

Does that mean I don't have to turn off Midi output on my NI instruments anymore?

It's a lot safer in 2021.01 than before.

In the past when an instrument or MIDI track had echo enabled and its input was set to None, the DAW automatically switch to "All Inputs - Omni".. If there were plug-ins sending MIDI data, the track would play the data.  

This is more of a problem with synths because they have "Enable MIDI Output" turned on by default, if they have the feature. Effects always default to "Enable MIDI Output" off regardless. But both could be unwelcome sources of MIDI data.

Starting with 2021.01,

  • if there are any effect or synth plug-ins in the project with "Enable MIDI Output" turned on,
  • and an instrument or MIDI track has input echo enabled and while its input is set to None
  • instead of switching to "All Inputs - Omni" the DAW switches to "All External Inputs - Omni".

This prevents tracks automatically picking up MIDI data from plug-ins.

HTH

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...