Jump to content
Gavin O'Hara

Latency Issue with Scarlett Solo

Recommended Posts

I'm another brand new user/victim of CbB and Scarlett Solo that's having the "ever-so popular" latency problem. I've read a few posts here and reviewed some YouTube tutorials about how to solve latency issues. But none of them have been helpful enough yet. All I've wanted to do is record some original music in its simplest form, just 4 tracks (2 guitars, drums, and bass; no vocals). I don't have any high asperations of creating over the top music with numerous tracks, audio effects, and mixing adventures.

When I record a track of guitar, import an MP3 audio click track or a drum track from my old drum machine, it works just fine when they're recorded separately. Every time I try to record a second track, it's immediately out of time with the first track (while it's recording and afterwards). 

Under the Driver Settings, I have both the Playback Timing Master and Record Timing Master set to the Focusrite Usb Audio. The Audio Driver Bit Depth is set at 24 (based on a tutorial recommendation). The Mixing Latency's Buffer Size is greyed out probably because that's being controlled by the Focusrite Control App (currently set to 44100 sample rate and 512 buffer size).

Under the Playback and Recording, I have the Driver Mode set as WASAPI Shared. So here's where I need some guidance. Some have mentioned here that they're either using the manufacturer's ASIO driver or ASIOForAll driver (I have not installed the latter). I have the latest drivers installed dated December 2020. Is there really a ASIO driver for the Scarlett Solo or do they mean the Scarlett 2i2? Some have mentioned using the WASAPI Exclusive mode. NONE of these works. When I change it to ASIO, it wipes out the Timing Masters with no choices. When I change it to WASAPI Exclusive mode, the master channel and the recorded track max out and clip like crazy. I even downloaded and ran the Latency Monitor that was mentioned somewhere in the forums. It didn't find any issues either. Also, I have the Input Echos turned off for the tracks, have the "Direct Monitor" turned on for the Scarlett Solo and I'm not using any effects within CbB. Thanks in advance for any feedback that you might have.

 

Share this post


Link to post
Share on other sites
2 hours ago, Gavin O'Hara said:

Is there really a ASIO driver for the Scarlett Solo or do they mean the Scarlett 2i2?

The Solo and 2i2 use the same drivers.

 

2 hours ago, Gavin O'Hara said:

Under the Playback and Recording, I have the Driver Mode set as WASAPI Shared

Definitely use the ASIO drivers not WASAPI

 

2 hours ago, Gavin O'Hara said:

The Mixing Latency's Buffer Size is greyed out probably because that's being controlled by the Focusrite Control App (currently set to 44100 sample rate and 512 buffer size).

If you have the Driver and Playback mode set to ASIO then the Mixing Latency should not be greyed out. Set it to at least 128 buffer size otherwise you will get recording latency.

Share this post


Link to post
Share on other sites
1 minute ago, Brian Cadoret said:

The Solo and 2i2 use the same drivers.

 

Definitely use the ASIO drivers not WASAPI

 

If you have the Driver and Playback mode set to ASIO then the Mixing Latency should not be greyed out. Set it to at least 128 buffer size otherwise you will get recording latency.

this sounds good to me. Try it.

Share this post


Link to post
Share on other sites

Hi Gavin and welcome to the Cakewalk forums.

As Brian said, use the ASIO Focusrite driver.  Don't bother trying to use ASIO4all, it is not reliable in every case.

Kind regards,

tecknot

Share this post


Link to post
Share on other sites

Only ASIO will report RTL correctly to Cakewalk. Even though WASAPI is your second best driver mode it will not sync overdubbed tracks. You don't believe me do a loopback test.  

You'll be fine once you install and use ASIO. 

Share this post


Link to post
Share on other sites
54 minutes ago, John Vere said:

Only ASIO will report RTL correctly to Cakewalk.

I suppose this may be read several ways but it is not the case that all ASIO drivers accurately report latency. 

If ASIO drivers were always accurate there would be no manual offset provision when running ASIO driver mode.

Some ASIO drivers may not require an offset.

In some cases, the offset may be very small.

Share this post


Link to post
Share on other sites
7 hours ago, Brian Cadoret said:

The Solo and 2i2 use the same drivers.

 

Definitely use the ASIO drivers not WASAPI

 

If you have the Driver and Playback mode set to ASIO then the Mixing Latency should not be greyed out. Set it to at least 128 buffer size otherwise you will get recording latency.

Thanks for info about the buffer size. I've seen many smaller numbers tossed around, just wasn't sure where to start.

I'm documenting this response for all users regarding this problem. What I'm seeing here is a "software behavior" that you may or may not be aware of. This is the behavior:

When CbB was first installed, I believe the driver defaulted to the WASAPI. When you switch it to ASIO, the Playback and Recording timing masters are both set to "None." (Now I'm having problems trying to recreate the original problem for documentation purposes, lol). The driver switching does not "stick" right away. I had to create a brand new project, switch drivers, close the application, open the app, check the drivers, and repeat again. So it took several times of opening and closing the application for the ASIO driver to actually "stick" and work. 

Everything is now working perfectly. Thank you everyone!

 

Share this post


Link to post
Share on other sites

I just rebuilt a computer and as is my habit I do a few things before i INSTALL cBb.

First like others here I have to install bits and pieces of my older Sonar installs so as to get the Goodies that came with them. 

And at this point I install the latest drivers for my Interface which is a Scarlett 6i6 in this case. 

I have done this same procedure many times as I think Cakewalk likes to find my ASIO device on installation. 

I then install CbB  and first thing I do is check my Audio preferences. In the dozens of times I've been through this my Scarlett ( or others) have always been the only audio device and ASIO is up and running. I have never had to change driver modes from WASAPI.  

So I can only assume you opened Cakewalk at some point before you installed your drivers.  But it still does not seem right you had to do this 3 times so another assumption is possibly you have not set USB power suspend to disabled in Power advanced options and the interface was not on line.  

 

@scook  Yes possibly there are still some poorly written ASIO drivers ( like Creative) kicking around but  I think we've come a long way in the last 5 or so years. Seems drivers overall have greatly improved. Both my Scarlett and Tascam drivers are now miles ahead of the original releases. 

If you remember the thread about testing your timing offset years ago,  everyone who tried it had almost perfect results using ASIO.  I can't remember someone testing that didn't and this sort of covered a lot of brands of interfaces. If the timing was out it was by a very tiny amount that would not have any impact on recording overdubs.  Even iffy ASIO drivers performed better than none ASIO drivers. All cases of testing other modes , if you could, the timing was out by as much as a 1/8 note ( to use a well know reference ) so we collectively came to the conclusion that the recording timing offset was super important and people should be aware of this.   That's why it's nasty when a generic ASIO driver takes over your Recording Latency dialog box and that's why I will continue to warn people of the downside of other driver modes.  Often they are totally fine for everything but recording overdubs.   

Share this post


Link to post
Share on other sites

I remember the threads very well.

There is no amount of hand waving that can dismiss the fact that some benefit from an offset.

If one wants clips to line up properly, it is a good idea to test and apply any offset as needed regardless of driver mode or sample rate.

My current setup using a RME Babyface Pro 

lLSu0eP.png

running at 44.1K sample rate requires a -20 sample offset in ASIO driver mode to achieve this level of alignment

A8oraj5.png

 

Share this post


Link to post
Share on other sites

John Vere,

Yeah, I read somewhere (probably an Amazon review) that it was best to install the drivers first before installing CbB--which I "think" did (geez, I may have missed that step when I switched PCs). But the "USB power" stuff I did afterwards, lol. I have 3 PC's at home and I did have Cakewalk/Sonar installed on a different PC and using an older M-Audio interface. I ran into problems with that one due to running Cakewalk/Sonar and M-Audio interface (both 7 years old) on a PC running Win10 64-bit. And there's no way I'm running a virtual machine of Windows 7 just to make old crap work, lol.

Share this post


Link to post
Share on other sites
3 minutes ago, scook said:

I remember the threads very well.

There is no amount of hand waving that can dismiss the fact that some benefit from an offset.

If one wants clips to line up properly, it is a good idea to test and apply any offset as needed regardless of driver mode or sample rate.

My current setup using a RME Babyface Pro 

lLSu0eP.png

running at 44.1K sample rate requires a -20 sample offset in ASIO driver mode to achieve this level of alignment

A8oraj5.png

 

Yeah, that was gonna be my next line of questions if the above suggestions didn't work. Where or how do apply those offsets in CbB to compensate for the latency?

 

Share this post


Link to post
Share on other sites

Record Latency Adjustment is at the bottom of this page

The preference screen is slightly different depending on the driver mode.

Share this post


Link to post
Share on other sites

Ah, cool, thanks for that link. The values shown in my attachment here are way better than before. I think they were between 10-15msec before the changes.

CbB-Current Settings.jpg

Share this post


Link to post
Share on other sites

Yeah, I believe WASAPI Shared has a  buffer set to 10ms by the OS.

A factory supplied ASIO driver should be able to outperform all the other driver modes.

Unfortunately, there are exceptions.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...