Jump to content
Mark MoreThan-Shaw

Trying To Set Up New M-Audio Oxygen PRO controller

Recommended Posts

I have just bought the 61 key version of this new controller keyboard range. They include a bunch of presets to control various DAWs ( PT , MPC, Ableton,  Reason, Cubase,  Garageband ,  FL Sydio, Reaper, Bitwig, Logic , S1) but no Cakewalk or Sonar option.

I've downloaded the editor software for it  but I'm not really that clued up on this side of stuff. 

Does anyone have any thoughts on how I might get this working with CBB ? 

image.thumb.png.0d631135202751d70af05095082d786d.png

Share this post


Link to post
Share on other sites

@Mark Morgon-Shaw I am expecting a new Oxygen Pro 49 to replace my faulty Arturia Keylab Essential 49 (replaced/substituted under warranty).  It should be arriving this week. 

I will let you know if I have any luck integrating it with Cakewalk although one reason for getting this keyboard was the integration with Studio One Pro which I am in the process of migrating to from Cakewalk. I don't know if these new M-Audio Oxygen Pro controller keyboards are the same as the old Oxygen ones but they required DirectLink support which Cakewalk doesn't have. That Editor screenshot looks interesting though as it lists Mackie which should work with Cakewalk.

I'll let you know how I get on when it arrives!

 

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, ZincT said:

let you know how I get on when it arrives!

Cheers, nice one. I managed to get the transport controls to work under ACT

  • Like 3

Share this post


Link to post
Share on other sites
2 hours ago, Mark Morgon-Shaw said:

Cheers, nice one. I managed to get the transport controls to work under ACT

Good to know, thanks 👍

Share this post


Link to post
Share on other sites
11 hours ago, ZincT said:

I am expecting a new Oxygen Pro 49 to replace my faulty Arturia Keylab Essential 49 (replaced/substituted under warranty).  It should be arriving this week.

@ZincTWhat happened with the Arturia board?

Share this post


Link to post
Share on other sites
13 minutes ago, abacab said:

@ZincTWhat happened with the Arturia board?

It started randomly playing G1 notes. If I recorded some playing it would be littered with random G1 notes. It got to the stage where if I tapped the desk it was standing on it would play G1 notes! 

The pandemic slowed the return process down and the music shop where I bought it were unable to repair it so they sent it back to Arturia. I received it back from them in early December but after initially thinking the problem was fixed gradually G1 notes started appearing at random again. This time the shop agreed to replace it and I had been eyeing up these new Oxygen Pros after feeling a bit let down by Arturia. 

Share this post


Link to post
Share on other sites
5 minutes ago, ZincT said:

It started randomly playing G1 notes. If I recorded some playing it would be littered with random G1 notes. It got to the stage where if I tapped the desk it was standing on it would play G1 notes! 

The pandemic slowed the return process down and the music shop where I bought it were unable to repair it so they sent it back to Arturia. I received it back from them in early December but after initially thinking the problem was fixed gradually G1 notes started appearing at random again. This time the shop agreed to replace it and I had been eyeing up these new Oxygen Pros after feeling a bit let down by Arturia. 

Wow, what a terrible experience! Good for you, allowing the local music shop to try to work through it! You were probably a bit more patient than I would have been, but glad to hear they took care of you in the end! I have never had anything like that happen with any of the keyboards I have bought from the 80's to now.

Give us a report on that Oxygen after you get it set up and running!

  • Like 1

Share this post


Link to post
Share on other sites
On 1/11/2021 at 1:44 PM, Mark Morgon-Shaw said:

Cheers, nice one. I managed to get the transport controls to work under ACT

My Oxygen Pro 49 has arrived and I have to say that the keybed is really nice and it seems like a great controller keyboard. It feels solid and well made and is quite a bit heavier than the Arturia Keylab Essential 49 making it seem more substantial.

I set it up for DAW control in Studio One Pro using the DAW preset which works fine. This uses virtual MIDI3 in/out on the keyboard for Mackie control. Without changing the keyboard DAW profile (I left it on Studio One Pro) I then set it up in Cakewalk using ACT on MIDI3 which also seemed to work fine after some manual configuration. I used an existing Oxygen 49 profile and MIDI learnt some of the buttons/sliders on the new keyboard which I then saved as a new profile for the Oxygen Pro 49.  @Mark Morgon-Shaw Presumably this is also what you did?

I discovered that MIDI2 seems to be the DIN connectors on the keyboard but I'm not sure what MIDI4 is used for (any ideas?).

Edited by ZincT
  • Like 1

Share this post


Link to post
Share on other sites
On 1/15/2021 at 11:29 AM, ZincT said:

My Oxygen Pro 49 has arrived and I have to say that the keybed is really nice and it seems like a great controller keyboard. It feels solid and well made and is quite a bit heavier than the Arturia Keylab Essential 49 making it seem more substantial.

I set it up for DAW control in Studio One Pro using the DAW preset which works fine. This uses virtual MIDI3 in/out on the keyboard for Mackie control. Without changing the keyboard DAW profile (I left it on Studio One Pro) I then set it up in Cakewalk using ACT on MIDI3 which also seemed to work fine after some manual configuration. I used an existing Oxygen 49 profile and MIDI learnt some of the buttons/sliders on the new keyboard which I then saved as a new profile for the Oxygen Pro 49.  @Mark Morgon-Shaw Presumably this is also what you did?

I discovered that MIDI2 seems to be the DIN connectors on the keyboard but I'm not sure what MIDI4 is used for (any ideas?).

I think you set it up different to me but I'm not in my studio at the moment

Share this post


Link to post
Share on other sites
On 1/15/2021 at 5:29 AM, ZincT said:

I then set it up in Cakewalk using ACT on MIDI3 which also seemed to work fine after some manual configuration. I used an existing Oxygen 49 profile and MIDI learnt some of the buttons/sliders on the new keyboard which I then saved as a new profile for the Oxygen Pro 49.

I'm in the same boat at the moment. Just got the Oxygen Pro 49 yesterday and I've spent a frustrating few hours trying to get it to work as a controller. I took the same approach as above. And at the moment I have sliders and transport controls mapped okay. Current trouble is the knobs, which I wanted to use for pan control. The ACT Learn function recognizes them, however when I turn the pots, the pan only accepts two positions: 2%R and 98%L. That's it.

Anyone seen anything like that?

Share this post


Link to post
Share on other sites
14 hours ago, Charlie Hills said:

I'm in the same boat at the moment. Just got the Oxygen Pro 49 yesterday and I've spent a frustrating few hours trying to get it to work as a controller. I took the same approach as above. And at the moment I have sliders and transport controls mapped okay. Current trouble is the knobs, which I wanted to use for pan control. The ACT Learn function recognizes them, however when I turn the pots, the pan only accepts two positions: 2%R and 98%L. That's it.

Anyone seen anything like that?

I'm not at my keyboard right now but I have seen that behaviour on knobs when the keyboard is in DAW mode rather than Preset mode. Try switching the keyboard to Preset mode. Sorry, I haven't really dug much further in Cakewalk. 

EDIT: I tried that and it's doing the same for me. The sliders/transport are working fine but the pan is jumping from 2%R to 98% L. I never really got the Arturia working properly for transport control either. That's one area where an update from Cakewalk would be appreciated - to support a few of the more common newer keyboards out of the box (or maybe to convince h/w creators to include Cakewalk configs).

Edited by ZincT

Share this post


Link to post
Share on other sites

Aaaand, they just started working. I don't even think I changed anything. Like, I left for a while, came back, and decided to give the ACT Learning one more go. And suddenly they're responding as expected. Not sure how I feel about that.    ;)

Share this post


Link to post
Share on other sites
1 hour ago, Charlie Hills said:

Aaaand, they just started working. I don't even think I changed anything. Like, I left for a while, came back, and decided to give the ACT Learning one more go. And suddenly they're responding as expected. Not sure how I feel about that.    ;)

Very strange. It's still acting the same here.

I would be curious to see a step-by-step of what you did. 

For example, are you using MIDIIN3 for ACT? 

What does your ACT config page look like?

Which DAW do you have configured on the keyboard?

Share this post


Link to post
Share on other sites

I have made some progress with this. 

I was reading this thread ..

... which made me wonder whether setting Mackie/HUI control on the Oxygen Pro (Pro Tools DAW config) and then configuring a Mackie/HUI control surface in Cakewalk would work. 

Long story short; it does! 

Share this post


Link to post
Share on other sites
2 hours ago, ZincT said:

... which made me wonder whether setting Mackie/HUI control on the Oxygen Pro (Pro Tools DAW config) and then configuring a Mackie/HUI control surface in Cakewalk would work.  

Oddly enough, I woke up this morning thinking this same thing. Except for me the inspiration came from Studio One. I was messing around with the free version, just to gain some perspective, and found this page. M-Audio said to configure it as Mackie, and that seemed to work without too much effort.

However, I had a new problem. This time CbB stopped generating audio to my primary interface. It would work if I switched to speakers or headphones. But no data seemed to make it to my old UA-4fx. (Even though everything else on Windows had no problems doing so.) This distracted me enough that I didn't have time to look at the controller again. I'll try that out tonight (even though, at the moment, everything seems to be working on the controller front).

In the meantime, I've attached a couple screenshots to give a glimpse of my current config.

cbb-001.png

cbb-002.png

Edited by Charlie Hills

Share this post


Link to post
Share on other sites
5 hours ago, Charlie Hills said:

I'll try that out tonight (even though, at the moment, everything seems to be working on the controller front).

Whelp, I couldn't wait until tonight. I tried to set it up as a Mackie controller but that didn't work out at all. Given the success reported by others, I'm sure I missed a step, but I'm not sure what. The good news is that it didn't mess up my previous setup. So that still works. 👍

I think my bigger issue is still my audio I/O device. But that's going off-topic, so I'll leave it here. If I try the Mackie-approach again, I'll follow up. And if anyone has additional overall experiences with CbB + Oxygen Plus, please continue to share. 

Share this post


Link to post
Share on other sites
16 hours ago, Charlie Hills said:

Whelp, I couldn't wait until tonight. I tried to set it up as a Mackie controller but that didn't work out at all. Given the success reported by others, I'm sure I missed a step, but I'm not sure what. The good news is that it didn't mess up my previous setup. So that still works. 👍

I think my bigger issue is still my audio I/O device. But that's going off-topic, so I'll leave it here. If I try the Mackie-approach again, I'll follow up. And if anyone has additional overall experiences with CbB + Oxygen Plus, please continue to share. 

I normally have my Oxygen Pro set to Studio One DAW config as I use it with Studio One Pro 5, but for the Mackie/HUI setup to work in CbB I had to set the Oxygen config to Pro Tools. These were my preferences and controller page setups (I still have the ACT one in preferences but disabled for ACT and WAI)...

951025538_OxygenPro4900.jpg.2ae56ee3a2b775043e719392985808e9.jpg

 

883918494_OxygenPro4901.jpg.eaa1b557868b7aa9b79246b1f027ec17.jpg

Edited by ZincT

Share this post


Link to post
Share on other sites
4 hours ago, ZincT said:

I normally have my Oxygen Pro set to Studio One DAW config as I use it with Studio One Pro 5, but for the Mackie/HUI setup to work in CbB I had to set the Oxygen config to Pro Tools. These were my preferences and controller page setups...

Thanks! I'll give this another shot on my end, likely this weekend given my schedule. For anyone else browsing this thread and looking for help, I did have success with Oxygen Pro's USERDAW setting, using MIDIIN3, setting up an ACT controller, and learning three sets of controls:

  • Sliders
  • Transport
  • Knobs

The knobs were acting flaky for a bit (would only toggle between two pan settings, and not smoothly pan from -100/+100), but they soon righted themselves for reasons I can't explain. So my setup is working, though I would like to know how to map even more functions using the Shift button. That, however, remains a mystery to me.

Share this post


Link to post
Share on other sites

mc_protocol_mappings [MIDIbox].pdf Hi all I found this file which may help find the right settings although how you do this in the MAudio editor is currently beyond me. I also found this thread

'MIDI: Transport control not working from master keyboard AND external controller'

under Cakewalk Discuss which helps with setting Cakewalk to receive Mackie messages from controller. 

Still struggling but hoping this helps crack the setup

Share this post


Link to post
Share on other sites

Slightly off topic but has anyone used this with Reason on a Mac? I can’t even find the device listed in Reason’s midi controllers yet the Windows version it’s listed! I’ve managed to connect it via a generic midi controller but now obviously I can’t use any of the features because it doesn’t realise I’m using an Oxygen Pro 49 :/

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...