Jump to content
Enej Johhem

Future Request - Ability to send Midi from one midi track to multiple instruments & effects

Recommended Posts

It would be great if Cakewalk can send Midi from one midi track to multiple instruments & effects.

Another Request is that It would be great if I can automate the mute of Effects Plugin in the FX Rack

Edited by Enej Johhem
  • Like 2

Share this post


Link to post
Share on other sites
On 11/5/2020 at 8:29 AM, Enej Johhem said:

send Midi from one midi track to multiple instruments & effects

I would looooove this. I like to layer synth sounds with different instruments. I was kind of surprised when I discovered that Cakewalk doesn't already have that feature.

  • Like 1

Share this post


Link to post
Share on other sites
On 11/6/2020 at 2:59 AM, Enej Johhem said:

It would be great if Cakewalk can send Midi from one midi track to multiple instruments & effects.

Until this is available in Cakewalk, you could use a VSTi that has a MIDI Thru function. Then you can route its MIDI out to as many synths as your CPU can handle.

MIDImonitor 1.3 is an example of a VSTi that does MIDI Thru

https://pw.promidi.com.au/softopen/midiMonitor_x64.zip

Edited by Promidi
  • Like 1
  • Thanks 2

Share this post


Link to post
Share on other sites

My Cakewalk is doing exactly this and I want to get rid of it. I don´t remember when it started, but I did not had this "problem" but after one of the updates of octuber, I started getting this issue that all midi instruments would play the same notes, even if there is no midi information on a midi track. 

For example, I have one song with 4 midi instruments, 3 Synths Pads and one with drums. For some reason Cakewalk started playing all the midi patterns on all instruments. I was able to change that by selecting a specific channel on the MIDI section of each instrument, but when I export the cakewalk session, it exports the same midi pattern on all midi instruments. Even though when doing playback in the cakewalk session it did not do this. 

I attach an image with the setup on cakewalk and sound samples of the result I get. 

Any ideas what is happening?

Cakewalk Settings.png

test ok.mp3 test 1.mp3

Share this post


Link to post
Share on other sites
55 minutes ago, Roberto Navarro Camacho said:

My Cakewalk is doing exactly this and I want to get rid of it. I don´t remember when it started, but I did not had this "problem" but after one of the updates of octuber, I started getting this issue that all midi instruments would play the same notes, even if there is no midi information on a midi track. 

 

You might be better off posting this as a new topic on the following forum.

https://discuss.cakewalk.com/index.php?/forum/12-qa/

Share this post


Link to post
Share on other sites
49 minutes ago, Roberto Navarro Camacho said:

My Cakewalk is doing exactly this and I want to get rid of it. I don´t remember when it started, but I did not had this "problem" but after one of the updates of octuber, I started getting this issue that all midi instruments would play the same notes, even if there is no midi information on a midi track. 

For example, I have one song with 4 midi instruments, 3 Synths Pads and one with drums. For some reason Cakewalk started playing all the midi patterns on all instruments. I was able to change that by selecting a specific channel on the MIDI section of each instrument, but when I export the cakewalk session, it exports the same midi pattern on all midi instruments. Even though when doing playback in the cakewalk session it did not do this. 

I attach an image with the setup on cakewalk and sound samples of the result I get. 

Any ideas what is happening?

Cakewalk Settings.png

test ok.mp3 362.88 kB · 0 downloads test 1.mp3 665.36 kB · 0 downloads

You've probably got MIDI output enabled on your synths.

You can change the default by going to the insert synth options page and uncheck "Enable MIDI Output".  For existing synths, go to the VST menu at the top of the synth properties page, and disable MIDI output.

 image.png.440e91afd42331effaba69243165c468.pngimage.png.1805b73c741de759e67506d41e35b409.png 

However, if you really do need MIDI output on a synth, you'll need to use a specific MIDI input on your other tracks, rather than Omni, None,  or All Inputs, e.g.:

 image.png.c1ea2d44d9309b19c8c060242d80e36f.png
 

  • Like 1
  • Great Idea 1

Share this post


Link to post
Share on other sites
1 hour ago, msmcleod said:

You've probably got MIDI output enabled on your synths.

You can change the default by going to the insert synth options page and uncheck "Enable MIDI Output".  For existing synths, go to the VST menu at the top of the synth properties page, and disable MIDI output.

 image.png.440e91afd42331effaba69243165c468.pngimage.png.1805b73c741de759e67506d41e35b409.png 

However, if you really do need MIDI output on a synth, you'll need to use a specific MIDI input on your other tracks, rather than Omni, None,  or All Inputs, e.g.:

 image.png.c1ea2d44d9309b19c8c060242d80e36f.png
 

Hey Thanks!. That worked. 

 

  • Like 2

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...