Jump to content
Jeremy Crowhurst

Run Cakewalk, get "audio renderer error" on Youtube

Recommended Posts

Sorry it's probably a dumb question.  I'm a total noob.  There's a YouTube video that tells me how to get Cakewalk going, but once I start up Cakewalk, I lose the sound on YouTube.  I did a capture of the video, but Winamp and Windows Media lost their sound as well.  I get an error message "audio rendering error" or something like that, telling me to reboot my computer.

Rebooting does not help.

HELP!!!

Edited by Jeremy Crowhurst
addkitional info

Share this post


Link to post
Share on other sites

Both windows and CbB need to run at the same sample rate

Here is one way to get to the Win10 sound settings

CbB sample rate for new projects and projects without audio is set in Preferences > Audio  > Driver Settings

The sample rate for projects with audio is set by reading one of the project's audio clip headers.

Share this post


Link to post
Share on other sites

Enter your project or create a new one. Go to Edit>Preferences>Playback and recording and check the box that says "Suspend Audio Engine When Cakewalk is Not in Focus". It seems like Cakewalk kind of takes over the audio system while in use.

This will allow you to watch/listen to other applications as long as Cakewalk is not your active window, or the last window you've clicked on/used. This will at least allow you to have your project open, and click off/minimize Cakewalk before turning on/refreshing you're other media if you're doing a tutorial or something rather than repeatedly closing the app.

  • Thanks 1

Share this post


Link to post
Share on other sites
9 minutes ago, Michael Castelpoggi said:

Enter your project or create a new one. Go to Edit>Preferences>Playback and recording and check the box that says "Suspend Audio Engine When Cakewalk is Not in Focus". It seems like Cakewalk kind of takes over the audio system while in use.

This will allow you to watch/listen to other applications as long as Cakewalk is not your active window, or the last window you've clicked on/used. This will at least allow you to have your project open, and click off/minimize Cakewalk before turning on/refreshing you're other media if you're doing a tutorial or something rather than repeatedly closing the app.

The suspend audio option in Cakewalk is often not necessary. IIRC, it is off by default.

It depends on the driver mode and interface used.

Some systems have no trouble sharing audio drivers and interfaces between applications.

In no case, is it possible to share an interface between two applications running at different sample rates. 

Interfaces can only operate at one sample rate at a time.

  • Like 1

Share this post


Link to post
Share on other sites

WASAPI Shared mode can run at different sample rates from other applications because Windows internally sample rate converts and mixes the output  from all client applications. Even in ASIO mode some drivers can internally handle this by sample rate converting.

If youtube is failing its typically because Cakewalk is in ASIO mode and the driver doesn’t handle multi client use well.

  • Like 2

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...