Jump to content
fdadf DFaf

Alesis Nitro Mesh doesn't trigger. Is showing

Recommended Posts

Hey everyone.

 

Been stuck on this for hours! I have an Alesis Nitro Mesh edrum kit connected to my laptop via USB MIDI. Cakewalk shows the kit just fine but I can't get it to trigger anything no matter what I try.

 

I've followed a bunch of YT tutorials and still nothing. All I'm trying to do is get it to trigger a drum plugin (MT Power Drum 2).

 

- Windows 10. Up to date.

- The kit shows under "Devices - MIDI". Both inputs and outputs showing. I can select the kit just fine.

- I can create a new Empty Project.

- "Input" on the project can be set to the kit. MIDI Omni selected.

 

But nothing happens with I hit the kit.  Literally nothing happens in Cakewalk. (The only thing that happens is the normal Alesis module sounds coming through the module headphones as per usual).

 

Completely new to DAW's/Plugins etc, so please bear with me if I've explained it wrong.

 

Any help would be massively appreciated. Thanks!

 

Bunch of screenshots attached if that helps anyone...

 

5.thumb.png.7a6b148cbdcdeb954691151ad1b7bc0b.png6.thumb.png.24363ee9fa87f04e44ec86fce0c2d271.png7.thumb.png.dadd89447d40d9dc84e3384e30066ab2.png8.thumb.png.48ccf257ab4726fe8dbbb2050fd430e8.png9.thumb.png.1bfbca02740cb1f04f6f8a5eec0c6fd1.png

Share this post


Link to post
Share on other sites

A soft synth requires

  • both a MIDI and an audio track or
  • a simple instrument track (a simple instrument track is a hybrid displaying MIDI input and audio output controls in a single track)

in order to receive MIDI data and return audio to the DAW.

 

The last 2 images show the synth and a MIDI track only.

 

Add and audio track to the project and set the input of the audio track to the synth.

 

Share this post


Link to post
Share on other sites

Hey thanks very much for that speedy reply - much appreciated!

 

I just want to confirm that all I'm after is the ability to hear the plugin drums sounds in my headphones when I'm playing on my kit. I don't have any need to record, edit, or do anything else with Cakewalk. I'm just trying to replace the crappy module sounds that comes with my kit.

 

Is your solution what I need to do to make that happen?

 

Cheers

Share this post


Link to post
Share on other sites

Recording or not In order for the DAW to do anything with the audio generated by a plug-in there must be a track for the audio.

Audio tracks and simple instrument tracks serve that purpose.

 

One thing you will have to contend with when using software to generate sounds in place of your hardware is delay caused by audio interface buffering. You may find this delay to be a problem. Most use the hardware sound module instead of monitoring a soft synth through the DAW to avoid this delay.

 

 

Share this post


Link to post
Share on other sites

Really appreciate the help. A lot of new terms to get to grips with for me here :)

 

So I've tried adding an audio track and setting the input to the synth (which I'm guessing in the plugin?)

 

This is what I've done but it still nothing happens with I hit the kit.

 

I assume I didn't do it right...

 

Untitled.thumb.png.2c1824643b1e7d34ad2d7b33686eaa1e.png

Share this post


Link to post
Share on other sites

Something happened

The audio track shows it received a +2.0db peak signal from  somewhere (MT-PowerDrumKit maybe)

The audio track is routed to the Master bus.

To make the buses visible click the  Mixing.10.2.png  near the bottom of the track header pane. Just to the left in 7 MT-PowerDrumKit Stereo in the image above (n.b. the image is reversed in the Tungsten theme you are using).

 

This is likely an audio setup problem review the setup in preferences.

 

Share this post


Link to post
Share on other sites

Fiddled around with all of these but no change I can see?

 

I (perhaps wrongly) assumed there would be a place in Cakewalk - perhaps with a keyboard showing - where one could see if ones MIDI inputs were working.

 

I can see the kit, but I have no way of checking if Cakewalk is actually registering the hits/inputs.

Untitled1.thumb.png.533c8a3f896fa0abdf02c3f0129322c1.png

Share this post


Link to post
Share on other sites

Both track 2 and the master bus show audio passed through them.

Arm the MIDI track for recording, the press the record button in the transport and record the MIDI data being received.

This will give you some data in the DAW to test with.

 

 

Share this post


Link to post
Share on other sites

Thanks.

 

The metronome clicks away, but that's it. When I play it back it's just a silent recording. I was hitting the drums kit throughout but that doesn't seems to register.

Untitled2.thumb.png.38f39488b8f186364f55b7c09c6f2543.png

Share this post


Link to post
Share on other sites

First, I'd make sure MIDI data is getting from the drum brain to Cakewalk.

  • Open a new empty test project
  • Add a MIDI track
  • Set the MIDI track's input to Alesis Nitro>MIDI Omni
  • Record-arm the MIDI track
  • Record a few seconds of playing the Alesis Nitro

If no MIDI data was recorded, that means MIDI data is not flowing out of the Alesis Nitro brain into Cakewalk.

Check the Alesis Nitro to make sure it's set to transmit MIDI data via USB.

  • Like 1

Share this post


Link to post
Share on other sites

Hi Jim,

 

Yes I've just done that and no MIDI seems to record despite the kit showing up in Cakewalk and being selectable etc.

 

The Alesis module isn't a complicated one, and I don't see any setting to enable MIDI. The Alesis website also describes it as plug-and-play with no drivers needed for USB MIDI.

 

I'm at a loss...?

 

 

Share this post


Link to post
Share on other sites
55 minutes ago, fdadf DFaf said:

Hi Jim,

 

Yes I've just done that and no MIDI seems to record despite the kit showing up in Cakewalk and being selectable etc.

 

The Alesis module isn't a complicated one, and I don't see any setting to enable MIDI. The Alesis website also describes it as plug-and-play with no drivers needed for USB MIDI.

 

I'm at a loss...?

 

 

If no MIDI data is recorded, none is arriving at the "Alesis Nitro" USB interface.

 

Just read the User's Guide.

You have to set Local Control to OFF.

If it's set to ON, the pads will trigger the onboard sounds (but not send MIDI data).

If it's set to off, the pads will send MIDI data.

If you want to hear the Nitro sounds (while recording MIDI), make sure the MIDI track's Input Echo button is enabled.

Share this post


Link to post
Share on other sites

Local Controller is set to OFF now (it wasn't before - my apologies), but I still don't see anything happening in Cakewalk when I hit the kit?

Share this post


Link to post
Share on other sites

Could use MIDI-OX to see if the MIDI data is making it to the PC

It's pretty easy to use

  • download
  • run the installer
  • run midiox.exe
  • set input in MIDI-OX to the drum kit
  • hit the drum pads

the notes should appear in the MIDI-OX display. If they do not the problem is before Cakewalk. If the notes show up in the display it is a Cakewalk configuration issue.

 

Share this post


Link to post
Share on other sites

I'm using the Alesis Nitro Mesh kit.

Here's how I've set mine up:

- Alesis Nitro Mesh MIDI IN device enabled in CbB, but not the MIDI output device  ( MIDI driver mode is MME )
- Insert Addictive Drums 2 as a simple instrument track - in AD2's map screen, I've created my own drum map to match the Nitro's notes.

That's pretty much it.

Seeing as the MIDI device is actually showing for you, I would look at the following:

- First check your MIDI driver mode within CbB  Preferences (MIDI -> Playback & Recording). If it's set to UWP,  try setting it to MME.  You need to have no projects loaded to change this.

- Next, verify which MIDI notes are being sent. You could be really unlucky and find that the drum VST you're using has a completely different note mapping to the Nitro Mesh.

Try inserting a piano VST or something that covers the full range of notes.  If you're getting notes being played by hitting your pads, then look at the note mapping within your drum VSTi. 

If there's no way of mapping notes within the VSTi, then read up on creating drum maps.  @Creative Sauce has a great tutorial here: https://www.youtube.com/watch?v=sIquUl-7NfE

  • Like 1

Share this post


Link to post
Share on other sites
14 hours ago, scook said:

Could use MIDI-OX to see if the MIDI data is making it to the PC

It's pretty easy to use

  • download
  • run the installer
  • run midiox.exe
  • set input in MIDI-OX to the drum kit
  • hit the drum pads

the notes should appear in the MIDI-OX display. If they do not the problem is before Cakewalk. If the notes show up in the display it is a Cakewalk configuration issue.

 

Hey Scook, thanks for this tip!

 

I followed those steps and as far as I can tell there is no MIDI signal arriving at the laptop when I hit the kit - regardless of the settings on the kit module.

 

Could this be something a simple as a faulty cable or is it more likely to be an issue with the Alesis module or the laptop? Brand new kit and brand new MIDI-USB cable, but I suppose either could still be faulty? The kit appears in MIDI-OX.Untitled3.thumb.png.b49e382ff42903521d394da308bfc1ff.png

Edited by fdadf DFaf
Formatting

Share this post


Link to post
Share on other sites
11 hours ago, msmcleod said:

I'm using the Alesis Nitro Mesh kit.

Here's how I've set mine up:

- Alesis Nitro Mesh MIDI IN device enabled in CbB, but not the MIDI output device  ( MIDI driver mode is MME )
- Insert Addictive Drums 2 as a simple instrument track - in AD2's map screen, I've created my own drum map to match the Nitro's notes.

That's pretty much it.

Seeing as the MIDI device is actually showing for you, I would look at the following:

- First check your MIDI driver mode within CbB  Preferences (MIDI -> Playback & Recording). If it's set to UWP,  try setting it to MME.  You need to have no projects loaded to change this.

- Next, verify which MIDI notes are being sent. You could be really unlucky and find that the drum VST you're using has a completely different note mapping to the Nitro Mesh.

Try inserting a piano VST or something that covers the full range of notes.  If you're getting notes being played by hitting your pads, then look at the note mapping within your drum VSTi. 

If there's no way of mapping notes within the VSTi, then read up on creating drum maps.  @Creative Sauce has a great tutorial here: https://www.youtube.com/watch?v=sIquUl-7NfE

Many thanks for this, Mark. Nice to know someone with this kit has got it working!

 

As per Scook above, I think the problems might be before Cakewalk, but once I get that sorted I'll follow your steps for the setup.

 

Cheers

Share this post


Link to post
Share on other sites

In case anyone comes across this thread in the future who have a similar problem: My drum module ended up having to be sent back to Alesis under warranty. I spent a couple of weeks with Alesis support troubleshooting over email and they eventually suggested the module was probably faulty.

  • Like 1

Share this post


Link to post
Share on other sites

I am using the alesis nitro mesh kit but when i even prug in my headset all i get is static what is the problem

 

Share this post


Link to post
Share on other sites
5 hours ago, RIPtide said:

I am using the alesis nitro mesh kit but when i even prug in my headset all i get is static what is the problem

 

If you're getting nothing plugging your headset into the nitro mesh module itself, then it's probably a faulty module.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...