Jump to content
Michael Martinez

mixup in tracks using the same Drum instrument

Recommended Posts

I've got several projects that I'm working on and I do not have this problem with any of them except for the last one I started. I don't know what I did to get it to this weird state: 

I've got Cakewalk's SI-Drum-Kit assigned as an instrument on each of four different tracks, so that I can dedicate one for kick, one for hi hat, another for snare, and a fourth for toms and other stuff so that I can EQ them differently. Additionally, I have some other tracks with different instruments assigned to each of them. The topmost track is the drum track to be used for Toms. Right now it has no music data in it, it's a blank track. The weird thing is that if I solo this track it plays the data that's in the track right below it (which happens to be kick drum.) Same thing with the track below it: if I Solo it it doesn't play its own data, instead it plays the data in the track below it.  And so forth until I run out of drum tracks. The track below the last drum track is an instrument track with a non-drum instrument. If I solo this track, it plays correctly. 

Any thoughts? Is this just some weird state and I should scratch the project and start fresh? Or is there a known way to fix it? 

On a related note: is there a way to bulk-assign a particular midi channel to the midi notes contained in a track? When I created these drum tracks I forgot to assign them to Channel 10 and they are all currently using Channel 1.

Share this post


Link to post
Share on other sites

I just realized I might know how this happened. When I first created the projected, I created several blank tracks and I tried moving one of them up to be towards the top. I remember there was some problem with this move, it wasn't successful. Maybe something got confused at that point.

Share this post


Link to post
Share on other sites

Might want to check out

 

To set channel on selected notes

 

Share this post


Link to post
Share on other sites

@scookThanks for the links. I don't think the problem was related to Always Echo Current Midi track, but I can't test anymore because I already fixed it by creating new tracks, copying the data over and deleting the old tracks. I'll keep your link for future reference in case the issue arises again.

The second link for bulk setting midi channel very useful - thanks.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...