Jump to content
Sign in to follow this  
Panu Pentikäinen

Export audio - how to utilize 100 % CPU/disk?

Recommended Posts

Just wondering why Cakewalk does not utilize 100 % CPU or Disk when exporting a mix with Fast Bounce setting on. Is there something to tweak in the Preferences to get the most of the system?

For example, in the screen capture I was mixing a typical small project with only 32 tracks, and 20 FX. CPU usage is 41% while disk usage is barely 3%. For comparison, Premiere and AE in the same machine keep system 100% utilized during rendering.

 

 

 

image.png

Edited by panup

Share this post


Link to post
Share on other sites

Noel would have a real explanation...   😉

I'm guessing it has something to do with the fact that not every process in a DAW can be multi-threaded.

Video rendering is much different in that regard.

 

  • Like 1

Share this post


Link to post
Share on other sites

I tested some settings to see if I could increase CPU utilization.
- Cakewalk always restarted after making changes to settings.
- Same project in every test.

 

  1. BounceBufSizeMsec=250
    CPU utilization dropped from 41 % to 34 %.
     
  2. Increase audio interface buffer 128 => 512.
    CPU usage: 38 %.
     
  3. Enable Plug-in Load Balancing
    CPU usage: 38 %.
     
  4. Disable Plug-in Load Balancing
    ThreadSchedulingModel from 1 to 2.
    CPU usage: 38 %.
     
  5. Close all open 5 FabFilter plugin GUIs.
    CPU usage: 28%. (Weird.)
     
  6. FabFilter plugins open again.
    ThreadSchedulingModel  from 2 to 1.
    ExtraPluginBufs=5
    CPU usage: 38 %.
     
  7. ThreadSchedulingModel=1
    Set  EnableSetThreadIdealProcessor=False
    ExtraPluginBufs=5

    CPU usage: 41-42 %.
     
  8. Set  EnableSetThreadIdealProcessor=False 
    MixThreadCount=8
    ExtraPluginBufs=5

    CPU usage: 40%
     
  9. Set  EnableSetThreadIdealProcessor=False 
    MixThreadCount=4
    ExtraPluginBufs=5

    CPU usage: 32%
     
  10. Set  EnableSetThreadIdealProcessor=False 
    MixThreadCount=32
    ExtraPluginBufs=5

    CPU usage: 38-39 %, peaking to 55% every few seconds

 

Summary:

Best settings found so far for this very project:

EnableSetThreadIdealProcessor=False 
MixThreadCount=8
ExtraPluginBufs=5

MixThreadCount=32 was not bad either because it created some CPU bursts.

To be continued...

 

Share this post


Link to post
Share on other sites

Disabling plug-ins (additive):

  1. Disable Waves CLADrums - 41%
  2. Disable ValhallaPlate => CPU usage 41%
  3. Disable 5 FabFilter Pro-R instances => 41-42%
  4. Disable FabFilter Pro-MB => 42%
  5. Disable FabFilter Pro-L2 => 46%
  6. Disable three more FabFilter Pro-L2  => 51-52%
  7. Disable 5 FabFilter-Q3 => 48-53%
  8. Disable FabFilter Pro-DS => 47%
  9. Disable one more FabFilter Pro-R => 46%
  10. Disable FabFilter Pro-L2, DS, Q3, Q3, C2, C2, Q2, Q3, Q3, Q3 => 54%
  11. Disable FabFilter Pro-C2, Sonitus:Delay, Sonitus:Gate, Sonitus:Compressor, Q2, C2, C2, => 63%
  12. Disable Sonitus:Gate, Sonitus:Gate, Q3, Cakewalk Channel Tools, Cakewalk Channel Tools, Q2,  C2, Q3 => 57%

Conclusion: Plug-ins are the throttleneck, especially the old Sonitus DirectX plugins  [in thist very project at least].

Conclusion 2: I'm a big fan of FabFilter plug-ins! :) L2, DS, Q3, C2 and Pro-R are my goto tools now.

Edited by panup

Share this post


Link to post
Share on other sites
3 minutes ago, Noel Borthwick said:

It wont consume 100% CPU because the hard disk is the gating factor. It can only run as fast as your disk can read and write the project.

Are you sure? Disk usage shows barely 3%. Audio files are on SSDs.

Edited by panup

Share this post


Link to post
Share on other sites

Disk I/O is on a single thread so even if you have many cores we won't saturate the disk. 
But there are other factors as well. Many plugins are known to gate the speed by which they can process.
To verify if that is the case try globally bypassing all effects in the project from the toolbar before doing the bounce.

Using a large buffer size will yield some benefits however. You can set the BounceBufSize variable to a high value to force it to use a large buffer size.

There is probably room for optimization but its unlikely to ever achieve full CPU bandwidth.

Share this post


Link to post
Share on other sites

I don't think one can compare video rendering to audio processing. They are very different things. Each frame in a video would have to be rendered. Audio is a walk in the park compared to that video processing. 

Share this post


Link to post
Share on other sites

Noel's explanation makes sense and it confirms there's nothing fundamentally wrong on my system settings. Render times are not even a real problem. On my new system Cakewalk renders 4 min song made of 50+ audio tracks with 50+ FX in 30 seconds. Finally it feels like being in the future.  :)

Share this post


Link to post
Share on other sites
Posted (edited)
On 2/27/2019 at 7:44 PM, panup said:

Noel's explanation makes sense and it confirms there's nothing fundamentally wrong on my system settings. Render times are not even a real problem. On my new system Cakewalk renders 4 min song made of 50+ audio tracks with 50+ FX in 30 seconds. Finally it feels like being in the future.  :)

Whats your  new system?

Edited by mike2mars

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...