Jump to content
JohnK

BUG: MIDI trim clip not always working

Recommended Posts

The apply trimming to a MIDI clip, does not always trim, without a "little help"

For example, if I create a new clip with only two notes in it, separated by 33bars, then cut the clip in two around the half way point, then try to apply trimming to either clip, neither gets trimmed.

1. Create a clip with two notes 33 bars apart

901218365_01longclip.PNG.6712f9c74a5377799e1d8db728732eea.PNG

2. Split the clip approx half way.

1930256503_02spliclip.PNG.10745a934dc19a8e3743b9c5d0ff5f7a.PNG

which results in the two clips as expected

1262071725_03splitclipresults.PNG.e58129f91fff4c5cfea613988db7ad7e.PNG

3. So I try to trim the first clip, but it does not change.

565002280_04applytrimmingresults.PNG.7657ec1d725a7add4a36f8aa1999ae38.PNG

4. I manually trim the end of the clip a little

1612381378_05manuallytrimclip.PNG.53eae956504acefbc968bcef972cd3bd.PNG

5. And now when I apply trimming, it works.

954062169_06Applytrimmingresults.PNG.97185cf9a2e20742daece26582e58231.PNG

06 Apply trimming results.PNG

Share this post


Link to post
Share on other sites
Posted (edited)

I'm not understanding.  At step # 3, "I try to trim the first clip, but it does not change." and then at step # 4, "I manually trim the end of the clip a little."  If you manually trimmed at step 4 what kind of trim did you attempt at step 3?  Will you clarify step 3 please @JohnK?

Edited by Jim Fogle

Share this post


Link to post
Share on other sites
Posted (edited)

 

4 hours ago, Jim Fogle said:

I'm not understanding.  At step # 3, "I try to trim the first clip, but it does not change." and then at step # 4, "I manually trim the end of the clip a little."  If you manually trimmed at step 4 what kind of trim did you attempt at step 3?  Will you clarify step 3 please @JohnK?

I am not 100% sure the exact part I haven't been clear about, so please forgive me if I repeat anything you already understand. I am also repeating the steps for my own benefit.;) and also as another test confirming it.

So, at step 2, I have split the clip into two parts around 15 bars each. The first clip (I should of named them...) has a single note in it at 1:01:000 followed by 15 bars of nothing. I wish to trim the nothing off from the clip, so it is cut down to only the length of the single note. So at Step# 3 I right click on the clip and select "Apply Trimming" from the pop-up menu, but it does nothing, it fails. Step three should of cut it down to only the length of the note. So the "type of trim" at step #3 is from the pop up menu, after right clicking on the clip. I just realised, the image is probably all you needed...:$

applytrimming.png

At step 4, I manually trim the end of the clip a little (its just what gets the apply trimming menu item to work), and then re-do the pop-up menu based apply trimming. THIS time it works and the clip is down to the length of the note. If I was to manually try and trim the clip all the way down, I would run the risk of either cutting off an unseen note/event, or trim the clip shorter than the length of the note.

Actually, more out of interest and learning, is there another type of "Apply Trimming" I don't know about?

Edited by JohnK
  • Like 1

Share this post


Link to post
Share on other sites

Try this (this setting affects split behaviour):

- Open Preferences
- Check the Advanced radio button
- Customization\Editing
- Untick "Non-Destructive MIDI Editing"

Repeat your test.

Otherwise, rather than Trim, do Bounce to Clip.

Edited by Kevin Perry

Share this post


Link to post
Share on other sites

@JohnK, thank you for providing your response to my question.  Your description and screen shot answered my question.

I do not use the trimming command so I am not familiar with using it.  I use forum questions and responses as a learning tool.  I was having trouble understanding how the program was supposed to "know" what you wanted without you telling it.

Normally there is more than one way to perform a task.  Alternately could you have split each clip again adjacent to each note and then deleted the resultant two empty clips?

  • Like 1

Share this post


Link to post
Share on other sites
31 minutes ago, Jim Fogle said:

Normally there is more than one way to perform a task.  Alternately could you have split each clip again adjacent to each note and then deleted the resultant two empty clips?

There is a lot of things I could do as a workaround (the one example I gave of how I get it to work is clearly one). However,  there is NO reason Cakewalk should not do it already, and hence I see it as a bug.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Kevin Perry said:

Try this (this setting affects split behaviour):

- Open Preferences
- Check the Advanced radio button
- Customization\Editing
- Untick "Non-Destructive MIDI Editing"

Repeat your test.

Otherwise, rather than Trim, do Bounce to Clip.

Again, there are ways (including the example I gave) to force it to work, but it should do it as is "written on the pack". As it does not, its a bug, and hence my post. As I stated, I already have a workaround.

As for Un-ticking "Non-Destructive MIDI Editing", I explicitly do not want this, so will not un-tick it. Do not forget, I already have a simple working method to force it to do what I want, but I should not  have to do this. i.e. I do not need to use bounce to clip.

I was not looking for a work-around (I have one). I am simply documenting a bug.

  • Like 1

Share this post


Link to post
Share on other sites
40 minutes ago, Jim Fogle said:

I was having trouble understanding how the program was supposed to "know" what you wanted without you telling it.

Normally there is more than one way to perform a task.  Alternately could you have split each clip again adjacent to each note and then deleted the resultant two empty clips?

The program (i.e. cakewalk) should be using the very simple logic of "find the last midi event in the clip, then trim the clip to the end of this last MIDI event". By selecting the clip, I am telling it everything it needs to know to perform the task, as it has the MIDI events which has their times and lengths.

As for your suggestion, thanks, but the way I use to work-around the bug, already does what I need. It only becomes problematic if I accidentally manually clip (ie too eager at step 4) too far and cut off a MIDI note or event accidentally. NB: Your suggestion would have the same problem.

Sorry to repeat myself, but I have a work-around. The OP is highlighting a bug which forces me to use a work-around, when I should not.

 

  • Like 2

Share this post


Link to post
Share on other sites

I don't see how. There are no MIDI events from bars 2 through to 30, so trimming the clip down to 1 bar IS non destructive MIDI Editing.

Also, how would my manual adjustment then make non destructive MIDI allow the trimming? To Cakewalk, its as if I simply  had chosen a different point to cut it at. It somehow appears to think that a user generated cut-point is a MIDI event, but a user dragged clip end is not. Its inconsistent, and therefore I still see it as a bug,

Share this post


Link to post
Share on other sites

Not sure why, but...

When 2 clips butt against each other, like in your example, you have to Bounce to Clip(s)

When 2 clips have empty space between them you can Apply Trimming or Bounce to Clip(s)

I almost always use Bounce either way

Edited by sjoens

Share this post


Link to post
Share on other sites

Simply dragging the end of a clip, makes the trimming work, for that clip. But from memory, the second clip also will not trim until it is also manually adjusted.

Share this post


Link to post
Share on other sites

@JohnK,

Thank you for taking time to answer my question.  I understand you're two note example is just that, an example.

In my mind I agree that you've demonstrated a bug that can easily be duplicated.

Share this post


Link to post
Share on other sites

Rather than applying trimming..have you instead tried Bounce to clips ? Its the same thing as Apply trimming. Might fix your issue here.

Share this post


Link to post
Share on other sites

Its not about doing it, its about it being a bug. I already have explained above my workaround while describing and proving the bug. I am simply logging & reporting the bug, so that maybe the devs will fix it in the next release. The issue (i.e. bug) should be fixed in cakewalk.

To further that it is a bug, and it is not related to non-destructive-edits, I just found today, that sometimes, if it does not work the first time, simply trying again, often works :$ but not always. My above method in the OP has worked every time.

Share this post


Link to post
Share on other sites

It may or may not be a bug tho.

According to the online help, Trimming is for individual clips while Bouncing is primarily for joining 2 or more clips together.

Splitting a single clip in 2 without providing a gap between them may be why Trimming isn't working here.

Even so, Bouncing works on single clips the same way Trimming does. Removing empty tails.

If you simply Bounce instead of Trim, it works with one step.

Share this post


Link to post
Share on other sites
2 hours ago, sjoens said:

It may or may not be a bug tho.

According to the online help, Trimming is for individual clips while Bouncing is primarily for joining 2 or more clips together.

Splitting a single clip in 2 without providing a gap between them may be why Trimming isn't working here.

Even so, Bouncing works on single clips the same way Trimming does. Removing empty tails.

If you simply Bounce instead of Trim, it works with one step.

You say " Trimming is for individual clips". When I split a clip, I have TWO individual clips, so that requirement is satisfied. And I am only trimming a single one of those clips at any one time.

You say "Splitting a single clip in 2 without providing a gap between them may be why Trimming isn't working here.", which was actually my first thought, especially since by manually trimming the clip a little, enabled the trimming to be applied. HOWEVER, I have since found that splitting the clip, running the  trim (which appears to do nothing) and then running the exact same trimming again, worksO.o So, the second time when it does work, there is also no gap. Also, logically, it should not make any difference if there is a gap. A clip should be reduced to the time of the last midi event and its duration, regardless of other clips.

As I have said before, I already have a solution(two now that I know I can simply run it twice)  so am not looking for a solution. I am simply reporting a bug. Which, it is.

Edited by JohnK
added clarification on single clip

Share this post


Link to post
Share on other sites
On 9/5/2020 at 3:07 AM, JohnK said:

As I have said before, I already have a solution(two now that I know I can simply run it twice)  so am not looking for a solution. I am simply reporting a bug. Which, it is.

Sorry, but LOL. Not at you, but because this is one of my pet bugaboos: making an earnest request for a feature or reporting a defect, and having people offer "here's how to accomplish what you are trying to do."

I used to think that it was defensiveness about the software, but speaking for myself, I just have an impulse to help people. I think we're wired this way, one of the more endearing things about humans. We see someone having difficulty and want to help them ease it. It gives us a good feeling.

The confounding thing in these situations is that you were the one who was trying to be helpful, by taking the time to report (with illustrations) a defect so that the people who develop the software can fix it at some point. The unwanted effect is that the person who posts the feature suggestion or defect ends up feeling not listened to, which humans really don't like.

Seems straightforward to me: either the program allows you to apply Trimming to a clip that's touching another clip, or the documentation tells you that you can't, and that the thing to do is Bounce instead. If one of those things isn't true, then either the program or the manual needs to be changed. Thanks for reporting it.

Edited by Starship Krupa
  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...