Jump to content
Marco Ortega

Grooved Clip Lengthens

Recommended Posts

I've had this issue come up a number of times when transforming a clip to a groove clip and have it loop-able. I've previously been able to fix the length issue by shortening it and bouncing it to clip then looping it but it isn't working now.

Essentially I want to have this clip become loop-able. When I select Groove Clip Looping, it lengthens the clip ever so slightly. Please see below.

I've looked this up in the forums and seen mentions of the DAW not counting beats correctly for the clip? And that this can be fixed in the Groove Clip Header bar? Not sure how to have that appear and fix that if that is the issue.

 

loop clip 1.png

loop clip 2.png

Share this post


Link to post
Share on other sites

If you have 'Play Effects Tails On Stop" enabled, that will cause a clip to lengthen when bounced or exported.

Share this post


Link to post
Share on other sites
1 hour ago, 57Gregy said:

If you have 'Play Effects Tails On Stop" enabled, that will cause a clip to lengthen when bounced or exported.

Cool. Where would I find that setting to disable it?

Share this post


Link to post
Share on other sites
26 minutes ago, Colin Nicholls said:

Here's the Groove Clip Header Bar - it's in the Inspector. Select the clip:

image.png.486ec467eb1c152641f17da86022d87e.png

Awesome! This fixed it. It miscounted the number of beats in the clip by one. Adjusted that and it did the trick! Thank you so much :)

Share this post


Link to post
Share on other sites
On 8/27/2020 at 12:35 PM, Marco Ortega said:

Cool. Where would I find that setting to disable it?

Well, I may have misled you. In SONAR, it was under Options>Audio but I  can't find that in Cakewalk by Bandlab's Preferences. They may call it something else?

Share this post


Link to post
Share on other sites
On 8/27/2020 at 9:35 AM, Marco Ortega said:

Cool. Where would I find that setting to disable it?

Possibly this:

Accommodating effect tails during clip export

Effect tails are the reverberations or signal delay that continue after the source has stopped. If your project uses track or clip plug-in effects (reverb, delay, etc.) that result in effect tails, you will need to extend the duration of the exported clips in order to properly accommodate the effect tails. Otherwise, the exported clips will end prematurely, before the effect tail is finished.

You can tell Cakewalk to automatically add a specific amount of time to each exported clip. To specify how much time to add to all exported clips to accommodate effect tails, go to Edit > Preferences > File - Audio Data and specify the global Clip Tail Duration N Seconds value. Set the value high enough to allow for any delay or reverb or other effect that you may have patched into a track.

Share this post


Link to post
Share on other sites
On 8/27/2020 at 2:49 PM, 57Gregy said:

If you have 'Play Effects Tails On Stop" enabled, that will cause a clip to lengthen when bounced or exported.

This has nothing to do with the OP's beat count issue.

It is an audio setting so it would not affect MIDI clips.

This setting was replaced in SONAR X3 when VST3 support was added.

The new settings is called Always Stream Audio Through FX

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks. 
I realize I'm about 15 years behind, but I got it from the SHS 6 Help:

MIDI Effects (MIDI Plug-ins) 

SONAR provides the ability to use plug-in MIDI effects. Using plug-in effects is similar to using the MIDI processing commands off-line. The overall procedure is as follows: 
⦁    Select the MIDI data to be affected. 
⦁    Choose the effect you want from the Process-MIDI Effects menu or from the popup menu's MIDI Effects menu. 
⦁    Set effect parameters (or select a preset if you've made one for this purpose). 
⦁    Click Audition to preview the music with the effect applied. 
⦁    Click OK to apply the effect to the selected MIDI data. 
If you're not happy with the result, choose Edit-Undo before doing any additional work. 
MIDI effects can be applied to whole or partial clips. For example, you can apply an echo to just one note. 
MIDI effects can also be applied to MIDI tracks in real time (during playback) in the Track and Console views. Unlike any of the processing described so far, using effects in real time is non-destructive. This means that the MIDI data itself is not modified. 
Note: 
Offline effects may cause your MIDI events to grow in size. For example, when you apply echo, the clip may need to grow to accommodate the tail end of the echo. 
Note: Offline effects may cause your MIDI events to grow in size. For example, when you apply echo, the clip may need to grow to accommodate the tail end of the echo. 
 

I assume that if you have an effect in a MIDI track and are playing it through a soft synth, that would extend the clip.
One of these days I'm going to start using CbB so any info I put here might be relevant. 😄

 

Edited by 57Gregy

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...