Jump to content
  • 0
harleygnuya

Input Echo Latency

Question

Cakewalk SONAR Platinum 23.10.0, Windows 10 Pro 64, Numerous VSTx plugins

ASIO through MOTU Traveler mk3, 44.1k, 16b, 256 samples/buffer

image.png.06ccd0104e9c0e5d860b0bcbc3d811ee.png

When I record on track 5 using input echo, I get a significant delay (~1 sec +) in my headphones, which I know is not surprising.   But here's the fun part:  To get rid of the delay, I have to turn off FX on tracks 5 & 6 and bus E.

image.png.80377b475fef85d9321bb1db1196452e.png

Turning off anything less than all three makes no noticeable change in the delay.  If I leave any of those FX's turned on , I still get the delay.

Even if I leave one of those FX's turned on, but turn off each of the plug-ins within it , image.png.f06c122a9708560dcf2b73a1769f0869.png  I still get the delay.

My first question is, is this normal/expected behavior?         Why is there no noticeable change in the delay when I turn off a plug-in?  Why does it require me to turn off all three FX's in order to get rid of the delay?  I would think that I would notice some kind of change as I remove plug-ins and/or turn off FX's, but I don't, until all three are off.  And if I have to turn off those three, how come I don't have to turn off any of the others?

As I said, I can live with doing this when I record, I'm just trying to look under the covers a bit and understand what's going on to make it work this way.  Any ideas?

Thanks, Ken

image.png

image.png

image.png

image.png

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

The plug-in delay compensation used by the project is the maximum delay needed for any track or bus in the project to keep everything in sync. Bypassing the effects on any track or bus may not affect PDC if the delay needed to keep it in sync is less than or equal to the delay needed to keep any other track or bus in sync. For live tracks take a look at the PDC button in the mix module.

 

  • Like 2

Share this post


Link to post
Share on other sites
  • 0

Most major DAW applications have what's called Automatic Plugin Delay Compensation (automatic PDC).

If a latent plugin is inserted *anywhere* in the project, all other audio is delayed by that amount to maintain sample-accurate sync.

If you have several latent plugins inserted in series, the latency adds up quickly.

The workaround is either to avoid latent plugins when tracking... or use the Global PDC Bypass option in the Control Bar.

 

Latent plugins are often Mastering, Linear-Phase, Convolution, or Look-Ahead type processing

Edited by Jim Roseberry
  • Like 3

Share this post


Link to post
Share on other sites
  • 0

Your image is not very clear but you seem to have a lot of instances of Neutron going there. It's quite cpu heavy. If you turn Neutron instances off and then it works ok then that is your answer. I've found most Izotope plug ins to be like that and don't use them when tracking. - just for mixing. If you want to record to a mix that has whatever they are bringing to the mix party applied then bounce the entire mix to an audio track and use that to track so that you can bypass all your plugins (E) when recording.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

That RX7 Breath Control has a look ahead buffer on it, IIRC. What that means is it needs to see what is coming to react in a smooth fashion, so ”real time” it is forced to delay the rest of the project.

Some FX are only designed for mixing, and others have a ”low latency” setting on them, or even ”low CPU” if you need to track with them enabled. I am not sure if RX7 has those, but it is something to be aware of... both look ahead buffers and high CPU hit will mess up tracking. Global FX bypass is a quick solution for most cases.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
8 hours ago, paulo said:

Your image is not very clear but you seem to have a lot of instances of Neutron going there. It's quite cpu heavy. If you turn Neutron instances off and then it works ok then that is your answer. I've found most Izotope plug ins to be like that and don't use them when tracking. - just for mixing. If you want to record to a mix that has whatever they are bringing to the mix party applied then bounce the entire mix to an audio track and use that to track so that you can bypass all your plugins (E) when recording.

Yes, I was in the process of mixing when I decided to add something to one of the vocal tracks.  I was using the Neutron so that I could adjust EQ on each of the tracks if needed, from Total Balance Control in the Mix bus.   Thanks for the suggestion to bounce the tracks.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...