Jump to content
Ronman

Midi filter on instrument track?

Recommended Posts

I want to add a midi filter to an instrument track that accepts midi, but all the FX are audio-related.

I described the situation in relation to instructions given in another topic.  Please see:

 

Share this post


Link to post
Share on other sites

The 4 buttonss from left to right are: Audio FX, Midi FX, Instruments, Rewire. Select the Midi FX button.

1172661893_2020-08-0407_44_48-Window.jpg.945014020bbb9f82fcaf4a8708cc0d37.jpg

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

If the workspace is set to "Advanced", then that option comes up  (first screenshot).  But clicking on midi Event Filter doesn't do anything obvious.

Afterward, when I click the FX on the instrument (circled in red), it still only brings up audio effects. (second screenshot)

Capture.PNG

Annotation 2020-08-04 161318.png

Edited by Ronman

Share this post


Link to post
Share on other sites
23 minutes ago, Ronman said:

when I click the FX on the instrument (circled in red), it still only brings up audio effects

That's correct. I have posted twice and will try one more time. To access the MIDI FX rack for an instrument track use the instrument track inspector. The links are in my other posts or just look it up in the help.

Share this post


Link to post
Share on other sites

Intuitively (that is, based on years of doing things more or less the same way), I thought of splitting the instrument track and testing the Midi Event Filter on the midi track.  I don't recall ever having used that plug-in and, I wanted to try a new plug-in method; so, I inserted the plug-in using the Inspector. It worked!!!!! So, thanks for this Q & A!!

I still need to read the details about how the midi event filter works, though.  I just created a short loop and listened to the changes I had made (notes and CCs) after the loop came around. 

 

 

Share this post


Link to post
Share on other sites
7 hours ago, User 905133 said:

I still need to read the details about how the midi event filter works, though.  I just created a short loop and listened to the changes I had made (notes and CCs) after the loop came around. 

 

 

You set it to limit what passes through. You only want notes of a duration of longer than 10000? Tick the Notes checkbox, in the Dur slider either type 10001 in the bottom text box or move the arrow until the text box says 10001. Now only notes with a duration of longer than 10000 ticks will sound.

In the Key slider you can limit the range of notes that will pass through. Get rid of that annoying bottom octave bass riff.

Using the Key slider, if you have a polyphonic MIDI track you can copy the MIDI to multiple tracks, set different note ranges for each track, and route them to different synths.

  • Thanks 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...