Jump to content
Dega

KORG Control Surfaces

Recommended Posts

I have a couple of KORG NANOKontrol1 controllers that I had used fairly successfully in X3. Now that I'm using CbB I'd like to use them again. They show up as controllers in Windows and I have the latest drivers but they don't show up under MIDI Devices or Control Surfaces in CbB. I was sure they showed up when I first went to CbB but no longer

It's entirely possible that I did something wrong or stupid. Is there a way to "reset" detected devices or manually add these to Cake? I really prefer having sliders / panning knobs / mute / solo / and arm right at my fingertips and not have to grab the mouse.

Anybody using these or know what I may have done / not done . . . ?

Share this post


Link to post
Share on other sites

Is your MIDI Driver mode MME or UWP?  Two weeks ago I had a similar problem. I had tested UWP and forgot to switch it back to MME.  Once I switched it back, my nanoKontrol[1]s were visible and worked!!!

Share this post


Link to post
Share on other sites
3 minutes ago, User 905133 said:

Is your MIDI Driver mode MME or UWP? 

I can't answer that until I get home this afternoon haha. Actually MIDI Driver mode isn't something I remember seeing anywhere. Is this under "Preferences"?

 

Share this post


Link to post
Share on other sites
Just now, Dega said:

I can't answer that until I get home this afternoon haha. Actually MIDI Driver mode isn't something I remember seeing anywhere. Is this under "Preferences"?

{P]references > MIDI > Playback and Recording

  • Thanks 1

Share this post


Link to post
Share on other sites

Finally got a chance to look at this - My driver is set to MME and in fact that is the only choice in the drop down. Any other suggestions?

On 7/7/2020 at 1:46 PM, User 905133 said:

Is your MIDI Driver mode MME or UWP? 

 

Share this post


Link to post
Share on other sites

Here's what I'm seeing in Windows and Cakewalk

 

2020-07-08 (2).png

2020-07-08 (1).png

2020-07-08.png

Share this post


Link to post
Share on other sites

Are they be listed in CbB Preferences > MIDI > Control Surfaces?

 

Share this post


Link to post
Share on other sites
Posted (edited)

If the previous question doesn't lead to a solution, I have another idea that might be worth looking into.

Basic idea: someone posted a link to Korg Tools, I downloaded and installed, and then had problems until I did something--which I believe I described in the thread.

The clue that jogged my memory--the names of the ports!  I had names from an earlier driver, but the new one uses different names. New style names:

image.png.8421259211265663d17ce89a414627c0.png

Earlier in the thread below is the link to the Korg Tools.  This post described the issue I had and the solution that ended up with input devices with the SLIDER/KNOB suffix and output devices with the CTRL suffix.

Diagnostic questions: Do the nanoKontrols show up in the Korg Editor? Can you get any of the sets from the devices? (That is, does communication work?) 

For what its worth, these are from the Control Panel:

image.png.92bd0e94bd2886291afe38dc0fb13359.png

 

Edited by User 905133
to add a link to a >>possibly<< related solution

Share this post


Link to post
Share on other sites
12 hours ago, User 905133 said:

Diagnostic questions: Do the nanoKontrols show up in the Korg Editor? Can you get any of the sets from the devices? (That is, does communication work?) 

For what its worth, these are from the Control Panel:

image.png.92bd0e94bd2886291afe38dc0fb13359.png

 

OK you may have gotten me closer - When I open the KORG USB-MIDI Driver window, the "Device List" button is greyed out so there is an issue there. Any idea what I need to do to get the KORG software to see the two devices?

Share this post


Link to post
Share on other sites
Posted (edited)
On 7/9/2020 at 10:18 AM, Dega said:

OK you may have gotten me closer - When I open the KORG USB-MIDI Driver window, the "Device List" button is greyed out so there is an issue there. Any idea what I need to do to get the KORG software to see the two devices?

Well, maybe there's hope!  Some more diagnostic questions/comments:

  • Did you use the current driver tool?  I used the one referenced here. I don't remember if I used the tool to delete the port that probably had the old driver associated with it.  I might have because I wanted to make sure I'd be using the same usb port for the nanoKontrol from then on (not just any old usb port).  Not sure if I did that through Windows' device manager.
  • Does the tool show the most recent driver versions?
  • Do you have the current version of the Korg Editor?
  • Does the Korg Editor find the first nanoKontrol(s) [that is, with just one plugged-in]? EDIT: I got them working without unpluging either one.
    • NOTE: I just checked my Korg Editor--and it didn't find either of my nanoKontrols.  Also, MIDI-OX sees them, but isn't getting any midi data. Same for Cakewalk] So, now I am wondering if the failed Windows 10 Features Update and Rollback did its usual thing--changing my setup and then failing to put it back the way I had it.  😞 
    • I know both nanoKontrols were working before the failed Windows update.  Problem solving this now.**

**UPDATE: I reconstructed what I did before [see post from 4/1/2020] and after rebooting, midi-ox and Cakewalk both verify that Windows is once again passing nanoKontrol's midi data to midi software

  • Here's what I did: (1) reinstalled and ran the Korg USB Tool, which reinstalled the same drivers I had; (2) downloaded and reinstalled the newest Korg Editor; (3) ran the Editor and when it didn't see the devices, selected the nanoKontrol manually, and set the midi ports manually; (4) rebooted Windows.   

Just a guess, but after the Windows 10 Failed Update, while the Korg drivers were still installed and my PC still saw the nanoKontrols and they were still plugged into the same usb ports, something got changed that prevented the "Rolled Back" OS from passing on the midi data.

  • Footnote [7/12/2020]: Without going into all the details, I allowed my PC to do another bound-to-fail features update.  This time the nanoKontrols worked properly both before and after the failed windows update. Therefore, there was no need to re-setup the ports. 🙂

Once again, I needed to go into the Korg Editor's Preferences and manually set the MIDI ports. Perhaps that was saved in a Korg nano/Editor  configuration file that the Failed Update had no knowledge of and therefore didn't restore it, but instead used what Windows 10 thought my setup should be--i.e., its own default.  I don't know.

Not sure this will help you, but maybe.  It worked for me--again!!!  🙂 

On 4/1/2020 at 5:49 PM, User 905133 said:

Thanks for the Korg link.  I decided to download the latest configuration utility and found my Korg Kontrol Editor no longer worked, despite the fact that the nanoKontrol itself still worked (per MIDI-OX).  After getting midi port failure messages and an inability to receive/send [communicate], I finally found how to correct the problem. Just a guess, but I think the The 2020 Korg driver uses a different device name than my previous driver.  My solution was to change the device marked "(Not Connected)"--possibly from a previous configuration file--to the names evidently used by the new driver.  I had to do this for both MIDI IN and MIDI OUT.

I mention this here in case someone else updates their Korg USB-MIDI Tools and has a similar problem.

 

image.png.b3b326e8b602ed38ccced87385a6d1ef.png       New Korg USB Driver device names : image.png.a4aff94aaa3037d1611faf5019ebdae8.png

[July 9, 2020: emphasis and de-emphasis added]

 

Edited by User 905133
(2) to add a footnote re: a failed update; (1) to add an update (success!!!)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...