Jump to content
Sign in to follow this  
jono grant

cakewalk not closing properly

Recommended Posts

Hi @John Nelson

Thanks for sending the dump file, it was useful.
It's a bizarre crash. The problem is actually triggered by the plugin BFD. When shutting down it apparently ends up dispatching windows messages and as a result inadvertently launches the start screen! This crashes the Windows shell. 

I suspect this is something that may have been fixed by BFD since you have a very old version dated 2012. You can verify that this is the issue by changing CbB to not show the start screen. (Preferences | Display settings | Show start screen). Do you see BFD pop a dialog box or something when you close a project?

I've also defensively addressed this in CbB by ensuring that start screen only opens when all projects have finished closing.

PS:  In the future when using file sharing services please send links that don't require the recipient to create an account. Dropbox has become obnoxious now about  forcing recipients to create accounts. Its much better to use something like google drive and send a private link.

Share this post


Link to post
Share on other sites
On 3/5/2019 at 6:38 PM, msmcleod said:

IMHO JBridge is FAR superior to BitBridge, as it has so many compatibility options to tweak.

Cakewalk's integration with JBridge is good to. You no longer have to fire up JBridger to create 64bit wrappers around your 32 bit plugins.

If you go into the plugin properties (either from the Synth rack, or Plugin Manager), check "Load with JBridge wrapper" and the next time you load it, it will be with JBridge.

Cakewalk also uses its original VST id, so you can swap between BitBridge and JBridge without it thinking it's a different plugin.

FYI JBridge can also help with 64 bit plugins, such as the UJAM Virtual Guitarist VSTi's which seem to require a crazy high buffer size otherwise.

So do this with any VST I have that is 32 bit, would you suggest?

Share this post


Link to post
Share on other sites

I have to restart my computer every few days because of this.  Might seem like a small problem, but it would be really nice to have a fix for this!

 

Share this post


Link to post
Share on other sites
Posted (edited)

I'm getting this recently, when closing Cakewalk I can watch in Task Manager how it's moved from Apps to Background Processes and staying there until I right click on it and kill the process. The combination of plugins is Amplitube 4, Waves Echosphere and UVI Workstation. When I close Cakewalk with any of the mentioned plugin alone it's moved quickly to Background Processes and then vanishing from there quickly so it seems fine but if I create a track from Track Template containing the combination of these plugins Cakewalk will dwell in Background Processes on closing and I won't be able to run it again until I kill the process first. I was going to create a new topic on this but this title simply matches perfectly.

Edited by chris.r

Share this post


Link to post
Share on other sites
Posted (edited)

I've been getting this also recently.  I think it started a little before 2021.04 but not sure.  It's fairly consistent.  I most often see the hangs when closing a project with Ctrl-F4 or else clicking on the close project button on upper right.  Usually I want to load another project without closing CBB when this happens.  Sometimes it's difficult to close the cakewalk.exe process in Task Mgr and in some cases only a reboot will clear it.  I've had some luck with taskkill from command line but it takes a while to close that way.

Edited by craigr68

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...