Jump to content
  • 0
Samuel Sheehan

Random drum sounds appearing in export, not heard in project

Question

Hello, any help would be hugely appreciated! 

having a very strange problem where my track is sounding fine within the project but as soon as I export it, a crash cymbal is heard on a specific beat. The problem comes and goes and doesn’t happen with every export. 
 

I have tried to export drum tracks alone, and then the rest of the track alone, neither of which have the crash sound in the export; but then when I export the two groups together the crash is back. 
have also some multiple other iterations of exports to try and isolate where that sound lies but with no luck. 
this leads me to believe cakewalk May just be struggling to export all 38 tracks at once and malfunctions. 
 

thanks a million 

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

When unexpected MIDI notes play often it is the result of one or more synths with "Enable MIDI Output" turned on and the track playing the notes having its input set to "All Inputs - MIDI Omni"

To check the synths open the plug-in UIs and click on the VST2/3 drop down

M9I2IRu.png

Instrument and MIDI tracks can get set to "All Inputs - MIDI Omni" if the input is set to None and the track gets "Input Echo" (the button to the right of the record button) turned on. One way this happens is when Always Echo Current MIDI Track is enabled.

 

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
13 hours ago, scook said:

When unexpected MIDI notes play often it is the result of one or more synths with "Enable MIDI Output" turned on and the track playing the notes having its input set to "All Inputs - MIDI Omni"

To check the synths open the plug-in UIs and click on the VST2/3 drop down

M9I2IRu.png

Instrument and MIDI tracks can get set to "All Inputs - MIDI Omni" if the input is set to None and the track gets "Input Echo" (the button to the right of the record button) turned on. One way this happens is when Always Echo Current MIDI Track is enabled.

 

Howdy, @scook.  Have you encountered phantom exported notes, like described in the OP, from the combo of conditions you describe? 

I ask, because those are default behaviors, and I work primarily with MIDI, as a keyboard player, and I never have unexpected MIDI notesget added when I export, and I always accept the Enable MIDI Output as checked, by default, in the Insert Soft Synth Options dialog, and I also almost always leave MIDI track Input assignments set to None/Omni.

Bob Bone

Edited by Robert Bone
tweaked a few words for clarity

Share this post


Link to post
Share on other sites
  • 0

No because I take steps to prevent unexpected note playback. The combination of conditions has been the subject of numerous threads.

"Enable MIDI Output" has been the default since X3 for synths with the capability, however; many synths lack the feature.

"Always Echo Current MIDI Track" is also the default.

Instrument/MIDI track input set to None is not the same as Omni. When set to None the track rejects all input. When set to Omni the track accepts all input. The potential for trouble happens when a track has its input set to None and "Input Echo" gets turned on. Enabling "Input Echo" causes CbB to switch the input from None to Omni.

If a track is set to Omni and a plug-in is set to send MIDI data there is nothing to prevent the track from picking up the data.

Share this post


Link to post
Share on other sites
  • 0
11 hours ago, scook said:

No because I take steps to prevent unexpected note playback. The combination of conditions has been the subject of numerous threads.

"Enable MIDI Output" has been the default since X3 for synths with the capability, however; many synths lack the feature.

"Always Echo Current MIDI Track" is also the default.

Instrument/MIDI track input set to None is not the same as Omni. When set to None the track rejects all input. When set to Omni the track accepts all input. The potential for trouble happens when a track has its input set to None and "Input Echo" gets turned on. Enabling "Input Echo" causes CbB to switch the input from None to Omni.

If a track is set to Omni and a plug-in is set to send MIDI data there is nothing to prevent the track from picking up the data.

Wow - I would have thought I would have experienced this, at some point.  Thanks for explaining.

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
13 hours ago, scook said:

 The potential for trouble happens when a track has its input set to None and "Input Echo" gets turned on. Enabling "Input Echo" causes CbB to switch the input from None to Omni.

If a track is set to Omni and a plug-in is set to send MIDI data there is nothing to prevent the track from picking up the data.

That has made me check.

Input Echo off. Input says Omni, but dropdown says it is actually None. I cannot get it to say None. Seems like a bug.
 

Edited by Nigel Mackay

Share this post


Link to post
Share on other sites
  • 0

I have experienced this when my MIDI tracks have groove clips or step sequencer clips in them.   I often times must bounce the MIDI clips first before export, no clue why.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...