Jump to content
Sign in to follow this  
noynekker

Windows 10 update (v2004) messes with my audio {SOLVED}

Recommended Posts

Posted (edited)

Since I did the latest Windows 10 update (v2004) I've had a new problem I haven't seen before with previous Windows updates . . .

If I launch Cakewalk by BandLab (latest version) my ASIO drivers (M-Audio M-TRACK QUAD) work well, but when I go to a Windows media player, or to play music in my browser there is absolutely no sound. Seems the latest Win 10 update has migrated the basic audio driver to a WDM 2.9.64 driver. I used to be able to have Cakewalk open, and go listen to mixes in Windows Media Player, or Groove Player, or go online and listen to audio in a browser . . . well, that ceased to be ! Now, I have to actually close Cakewalk and disable / enable Windows sound settings to actually be able to listen to audio. BASICALLY, CAKEWALK AND WINDOWS ARE NOT SHARING NICELY ANYMORE.

Any of you recent updatees here have this experience ? . . . or, am I simply missing some checkbox somewhere in the sea of checkboxes ?

Perhaps my 6 year old M-Track Quad drivers have been kicked into the past where they belong, or a Cakewalk setting needs adjustment. Perhaps Microsoft is reminding me to go spend money on something newer at my local audio store. If I rollback, the Update lords will roll me forward again eventually . . . please reassure me I'm not the only one who has run into this issue ? It's been 3 weeks and I have found no solution, just more grey hairs in the sea of grey hairs.

Edited by noynekker
solved

Share this post


Link to post
Share on other sites

Try going into Preferences>Playback and Recording and checking the box near the top of the page that's labeled "Suspend Audio Engine When Cakewalk Is Not in Focus."

To quote the online help:   "This option allows other software to access device drivers. When this option is checked, other software can access device drivers when Cakewalk is not the focus of Windows."

If that doesn't work,  you might try downloading Audacity (free)  https://www.audacityteam.org/download/windows/  and using that to listen to mp3's,  *.wav files, etc. You might have more control over drivers that way. 

Share this post


Link to post
Share on other sites

Thanks for replying William . . . I have that option in Cakewalk preferences already checked, but it still doesn't allow ASIO and WDM drivers to be shared between Windows and Cakewalk. When a "major" Windows update happens, it basically resets, and re-enables  all the audio settings, such as the Realtek onboard audio, the NVIDIA HD drivers . . . which I usually disable once again . . . I've had to go and tweak things after such an update before, but this time it seems to make no difference.

Yes, your Audacity idea may be a possibility . . . If I could assign the Asio drivers . . . they might share nicely , or not . . . thanks I'll check it out

Share this post


Link to post
Share on other sites

Are Windows and CbB set to the same sample rate?

 

Share this post


Link to post
Share on other sites

Well scook, that's an interesting question . . . Cakewalk projects are defaulted to 24 bit - 44.1K sample rate, and it appears that Window is set the same . . . as far as I can see . . . Line In Properties, Default Format = 2 channel,24 bit, 44100 Hz . . . and I've unchecked Exclusive mode (Allow applications to take exclusive control of this device) . . . . but you got me fishing through the many Windows sound settings +  drop down menus and I think I found the correct setting to allow sharing of the drivers, it now appears to be working as before !, but I can't totally be sure which setting change actually fixed it  . . . but damn, it's working again . . . until my next windows update when I may have to go menu fishing again.

(I think it was Sound Control Panel - Line In Properties - Listen - Playback Through this Device . . . change from default playback device to M-Track Quad WDM) ??

Share this post


Link to post
Share on other sites

Glad to read it appears to be fixed...for now.

 

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Excellent scook, that solved my problem also.
I run Studio One at 48kHz and that was b;ocking CW.
Funny though, it didn't used to before Windows 10 v2004

Edited by Kozmyk
forgot to set replies

Share this post


Link to post
Share on other sites

I have a slightly different problem which I think has been caused by a Windows update as it's only recently started happening.  The sound on my Windows 10) PC is working fine.  I then leave the PC for an hour or so and when I return there's no sound in any applications or on any websites.  I then open up Cakewalk, load a song and start playing and the sound is fine.  Close Cakewalk and the sound has returned to everything else.  It's as though Cakewalk kicks the audio back into life!

Any ideas?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...