Jump to content
Xrenyn

SOLVED Long silence at the end of projects

Recommended Posts

Posted (edited)

I am encountering this error for the second time where Cakewalk thinks a project (that I've linked below) is way longer than it actually is. The song itself is 45 seconds long, yet Cakewalk thinks it goes on for over 2 minutes, therefore rendering over a minute of mere silence.

Last time I could actually apply a fix from a previous thread about the same issue (http://forum.cakewalk.com/FindPost/3205742) where I would open the Event List view and delete all events after the end of my song, but I can't find it anymore in the places it once was.

Looking at the cakewalk manual https://www.cakewalk.com/Documentation?product=Cakewalk&language=4&help=EditingMIDI.45.html , the Event List view should be in one of those drop-down menus, but it isn't:

grafik.png.cd34dac35aac881b6e613394c3008de1.pnggrafik.thumb.png.130b21c4e784c57f9c8d4ce385fc2ccc.png

So how can I get rid of the silence at the end of my tracks, or am I doomed to always select my track before rendering it?

super long silence at the end.cwp super long silence at the end.mp3

Edited by Xrenyn
Solution was different to what I expected, so I had to remove misconceptions from my question

Share this post


Link to post
Share on other sites
1 minute ago, Xrenyn said:

Looking at an outdated cakewalk manual https://www.cakewalk.com/Documentation?product=Cakewalk&language=4&help=EditingMIDI.45.html , the Event List view should be in one of those drop-down menus, but it isn't:

Far from being outdated, the manual is revised and updated with every release.

When documented features are unavailable the first thing to check is the workspace setting. Change the workspace menu to Advanced, None or create your own workspace.

Share this post


Link to post
Share on other sites

As @scook mentioned, if you don't see the Event List, you're likely in a Workspace. Switch to the Advanced or "None" workspaces and you'll see the Event List available. 

As for the export, Cakewalk renders based on selection. Simple way to adjust the end time of the project is to simply hold Shift and click the time ruler where you want the export to end. Then go to File | Export -> Audio.

Share this post


Link to post
Share on other sites

Thanks alot, you were right @scook, the Event List view was just hidden in the workspace I was using

grafik.png.f0b578c12de2da2d9eb676756d48098e.png

Checking that checkbox allowed me to access the Event List view and selectively delete all events past the 45 seconds mark, marked with black in the screenshot below

grafik.thumb.png.05f27551d3b0907e78e021093e7979ff.png

Share this post


Link to post
Share on other sites
Posted (edited)

The long space after the supposed end of the project and the fact that in 99 percent of cases really nothing's found until the real end is a question that I remember from many many years.

In my opinion  the moment has come that Cakewalk can make possible that the user can place a stop  anywhere he likes.

 

Edited by lapasoa

Share this post


Link to post
Share on other sites

Yup, this has been a PITA for years. A "Stop" marker  would be helpful.

Share this post


Link to post
Share on other sites
Posted (edited)

Ran into this last night and thought I'd relate what I found.
An old project, all audio, but with 10 or so archived MIDI tracks.
The song didn't stop at the end of the last clip, so I decided to find out why.
I opened all of the archived MIDI tracks and took a look at the event list, and on the next-to-last drum track, I found one drum hit with a duration in the BILLIONS!
I don't know how that happened, I don't think I held the key down that long (I'd probably still be holding it!), but decreasing the duration to a normal drum hit length, the project now stops where it should.
Edit to add: didn't know archived tracks would still be read.

Edited by 57Gregy
  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...